Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 9 réponses, has 2 participants.

Last updated by markD-33 il y a 4 mois et 4 semaines.

Assigned support staff: Andreas W..

Auteur Messages
mai 17, 2019 à 9:03 #3836997

markD-33

Tell us what you are trying to do?
The button on the website doesn't lead to the translated page. We would like to use "/en/" for pages in english and the regular form of the slug for french pages. Can you please have a look at how its currently set up and apply the changes?

Is there any documentation that you are following?
No.

Is there a similar example that we can see?
No.

What is the link to your site?
hidden link

mai 17, 2019 à 10:48 #3837245

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

The language switcher on your homepage leads correctly to

hidden link

It seems that the page is not translated correctly. Could you please confirm this?

On the pages for Training, Marketing and Resources I can see that the form appears in French. Is it correct that you are using Stereo Contact Form for this section?

As far I can see we did not test Stereo Contact From with WPML which for it would be helpful if I could have a look at your site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

mai 20, 2019 à 11:36 #3850605

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I revised the Site URL structure at WPML -> Languages and everything is correctly set up here.

When visiting zour French homepage and clicking the language switcher I get redirected to hidden link which is totally correct.

I can see that you did not enable the WPML TranslatioN Editor so far. You should consider one of our options, as this will enhance and speed up your translation procress. Specially, if you use page builders we highly recommend to use the Classic Translation Editor or the Advanced Translation Editor, as these methods make sure that the whole layout will be copied at the same time.

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Once you use the translation editor you will see the completion status of your translation. In case a page does not show any language switcher option it is for the reason that there is not any translation or the translation was not yet finished to 100% when translating for the first time.

Let me know if you need further assistance.

Kind regards
Andreas

mai 21, 2019 à 1:19 #3850751

markD-33

Hi Andreas,

When I click on the english button on the following page :

hidden link

It leads to the homepage instead of this page :

hidden link

Can you please tell me why ? Why doesn't it lead to the correct pages ? I still don't have a clue why and that was my initial question.

To add a translated page, I click on the "+" button in the CMS.

All the content of the site got translated by a professionnal translator. So I'd like to use that content instead of using the translation plugin to translate the french text. If I enable the Classic or advanced translation editor, will I be able to replace some of the content with the content of the professionnal translator ?

Thanks!

Mark

mai 21, 2019 à 2:01 #3855963

markD-33

Here's what I mean in case you need more info :

hidden link

mai 21, 2019 à 2:28 #3856159

markD-33

Also,

How can I enable the Classic Translation Editor or the Advanced Translation Editor ?

Is it part of the package I've already bought or is it something different ?

Thanks !

mai 21, 2019 à 2:32 #3856173

markD-33

The option is supposedly in WPML > Settings but I can't find it there. Can you please tell me how to activate it ?

mai 21, 2019 à 3:18 #3856573

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sorry for the misunderstanding.

I see you did not install our Translation Mangement Plugin which is requiered in order to use the Translation Editors.

Please go to Plugins -> Add new -> Commercial and download and activate Translation Management. Afterwards proceed with activating one of the Translation Editors.

Kind regards
Andreas

mai 21, 2019 à 3:45 #3856925

markD-33

Hi Andreas,

The plugin you are refering to, Translation Management, doesn't appear in Plugins -> Add new -> Commercial as you mentioned. Please see the following video showing the available options : hidden link

Also, can you please pay attention to my request so that I get a full answer to my issue ?? Here it is copied again :

When I click on the english button on the following page :

hidden link

It leads to the homepage instead of this page :

hidden link

Here's what I mean in case you need more info :

hidden link

mai 21, 2019 à 4:07 #3857079

markD-33

My issue is resolved now. Thank you!