Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 8 réponses, has 2 participants.

Last updated by alainH-10 Il y a 8 mois.

Assigned support staff: Andrés.

Auteur Messages
février 3, 2021 à 5:11 #7999191

alainH-10

Je tente de :

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : Logo translate in english

À la place, j'ai obtenu : the previous link (localhost link) of the logo

Annotation 2021-02-03 170940.png
février 4, 2021 à 7:08 #8003175

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Il s'agit d'une erreur de migration, pour cette raison votre logo point toujours vers la version local.

Or, vous pouvez essayer votre migration à nouveau en vérifiant que tous vos liens pointent vers le nouveau domaine ou vous pouvez retraduire votre logo dans WPML > Traduction de chaînes vers las URL correcte.

Cordialement,
Andrés

février 4, 2021 à 3:41 #8008647

alainH-10

Bonjour,

Merci pour vos conseils.

Cependant je remarque que j'ai le même problème sur mon serveur local.

Sauf que sur le serveur local l'adresse pour tous les logos est la bonne donc tout s'affiche bien.

Mais si je souhaite changer le logo anglais par exemple, cela ne fonctionne pas via les Avadas Option.

Par ou dois-je donc passer pour modifier l'url des différents logo dans toutes les langues s'il vous plaît ?

(Via String translation je ne trouve rien qui se rapporte au logo)

Merci !

février 4, 2021 à 5:39 #8009775

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour. Or, comme vous avez le thème Avada, s'il vous plaît, essayez le suivant :
- Allez aux option du thème.
- Changez de langue depuis la barre supérieur.
- Téléchargez votre logo.
- Répétez cette action pour chaque langue.
Est-ce que cela résout votre problème ?

février 5, 2021 à 10:00 #8014671

alainH-10

Merci, en effet cela devrait fonctionner, mais ça ne fonctionne pas.

Je pense que c'est ainsi que j'ai fais la première fois pour mettre un logo pour chaque langue. Cependant maintenant il m'est impossible de changer de logo de cette manière.

J'ai même essayé d'aller modifier moi même la valeur dans la base de données, mais rien n'y fais, l'url locale reste encore et toujours à la même place. Impossible de la modifiée. 🙁

MAJ : Le problème a évolué, j'ai pu débloquer une partie des langues en choisissant "toutes les langes" dans le menu en haut, au lieu de ne choisir qu'une seule langue. Cela à permis de débloquer toutes les langues sauf l'Anglais. qui reste toujours bloquée avec l'url locale précédente

Le logo anglais actuel n'est autre que le logo "mobile" et non le standard, que j'ai du retirer car il ne fonctionnait pas.

février 5, 2021 à 11:52 #8016105

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci, mais pouvez-vous m'indiquer ce que s'arrive lorsque vous essayer de rajouter votre logo ? Pour quoi cela ne fonctionne pas ?

Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 512M ?
Vos valeurs actuelles sont:
- MemoryLimit 512M
- WP Memory Limit 128M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '512M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

février 8, 2021 à 10:58 #8030655

alainH-10

Bonjour, je viens d'ajuster la valeur de la variable "WP_MEMORY_LIMIT", mais cela ne corrige pas le problème. Lorsque j'enlève le "mobile logo" et que je met le logo par défaut, le système utilise de nouveau l'url locale. :/

MAJ : Après avoir modifié le logo pour passer du logo mobile au logo standard, pour tester et voir si cela fonctionne. Un nouveau problème est apparu, le logo standard anglais ne fonctionne toujours pas ET le logo mobile refuse maintenant de s'afficher.

Le logo anglais est donc maintenant complètement hors service, même si je remets 128Mo au lieu de 512Mo.

février 8, 2021 à 1:13 #8032789

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Est-ce que vous pouvez suivre cette procédure :
❌ Faites un backup complet de votre site ❌
- Allez à WPML > Assistance technique.
- Cliquez sur le lien de 'dépannage'.
- Cliquez sur le bouton 'Effacer le cache dans WPML’.
- Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'.
- Cliquez sur le bouton 'Configurer les informations linguistiques’.
- Cliquez sur le bouton: Rectification du classement element_type
- Cliquez sur le bouton: Fix WPML tables collation.

Puis :
- Allez à WPML > Traduction de chaînes.
- Cherchez les chaînes de traduction pour votre logo.
- Supprimez ces chaînes.
- Retournez aux options Avada et enregistrez votre logo.

Est-ce que cela résout votre problème ?

février 18, 2021 à 12:18 #8117831

alainH-10

Bonjour, la solution proposée n'a pas réglée le problème :/