Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur a créé des pages avec des champs ACF, les champs repeater et flexible Solution: Il faut configurer le champs pour être traduisible, et configurer le champ parent en "copier". voir en détail https://wpml.org/fr/forums/topic/certains-page-creer-avec-acf-et-traduit-avec-wpml-ne-saffiche-pas/#post-4587303 Relevant Documentation: https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/traduire-des-champs-personnalises/

This topic contains 7 réponses, has 2 participants.

Last updated by jessicaD-2 il y a 1 mois.

Assigned support staff: Jamal.

Auteur Messages
septembre 16, 2019 à 3:51 #4582277

jessicaD-2

Je tente de : Traduire les pages de mon site sous 3 langues (FR, EN, ES) après avoir créer toute les pages dans la langue par défaut (FR) et mis tous les traductions suivant chaque langue. Certains pages ne s'affiche pas du tout ou paritelement si on choisi la langue espagnol (MIAMI -ES). J'ai déjà essaié de supprimer la page traduction, recréer celle-ci par duplication mais même la duplication ne s'affiche pas C'est comme si le contenu était vide).

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : hidden link traduit en espagnole)

À la place, j'ai obtenu : une page vide sans content. Sur certains page aussi, il y a les images qui ne s'affiche pas (img src="") sur certains langue. En ce moment, j'ai l'impression que le site au complet bug car je ne peux plus faire de backup ni installer d'autre plugin.

J'aimerais vous soumettre les accès mais comme je suis sur une instance ovh, comment puis-je trouver les accès ftp? J'ai l'habitude d'utiliser une connexion ssh avec une identification par clé?
Merci d'avance de votre soutien

septembre 16, 2019 à 3:57 #4582413

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Veuillez vérifier que les champs ACF utilisés dans la page sont configurés pour être traduisible à l'instar de cet article de documentation.
https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/traduire-des-champs-personnalises/

Si vous pensez que c'est bien configurés, je vous prie de m'accorder un accès temporaire pour vérifier cela de plus prés. L'espace privé est activé pour partager les accès en toute sécurité.

Cordialement,
Jamal

septembre 17, 2019 à 6:56 #4585857

jessicaD-2

Bonjour, je n'ai pas encore pu résoudre mon problème de page traduit non affiché. La version par defaut (FR) et la première traduction en anglais (EN) s'affiche très bien mais en Espagnole (SP) le contenu de la page reste vide.
Voici la page en question et ci-joint une capture. hidden link

septembre 17, 2019 à 7:54 #4586165
jessicaD-2

Je continue de vous faire part de mes actions pour résoudre le problème, j'ai enregistré le plugin et j'ai obtenu une clé. Puis, j'ai voulu installé "Media translation" mais je tombe sur une erreur (impossible de créer le dossier - voir capture)

Les nouveaux fils créés par Jamal et associés à celui-ci sont repris ci-dessous :

https://wpml.org/fr/forums/topic/erreur-impossible-de-creer-le-dossier-lors-de-linstallation-de-media-translation/

septembre 17, 2019 à 9:55 #4587303

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pour le problème de traduction. Il faudrait configurer les champs ACF systèmes(prefixé par _) en tant que "Copy". Le champ parent "content" doit aussi être configuré comme traduisible.
Je viens de changé la configuration des deux champs dans les captures attachées, puis j'ai mis à jour la page pour forcer la traduction, ensuite j'ai terminé la traduction, et cela semble corrigé le problème de la page espagnole.

Je vous laisse le soin de configuré les autres champs si vous en avez toujours besoin.

Pour le problème d'installation de Media Translation, j'ai créé un autre ticket pour le traiter. Pour les règles de support, nous ne pouvons gérer qu'un problème à la fois. Cela nous aide à vous fournir un meilleur service et à aider les autres utilisateurs à trouver toutes les informations exposées.

Je reste à votre disposition.

Cordialement,
Jamal

septembre 17, 2019 à 11:02 #4587849

jessicaD-2

Merci de votre retour, je vais configurer les autres champs et reviendra vers vous en cas de besoin sur ce problème.

septembre 17, 2019 à 2:51 #4589457

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je vais mettre le ticket en attente de retour client. Répondez dessus si vous avez besoin d'assistance plus. Sinon, je vous prie de marquer le ticket comme résolu.

Cordialement,
Jamal

septembre 19, 2019 à 5:38 #4601457

jessicaD-2

Le problème de page est resolu. Merci beaucoup de votre retour mais j'ai encore un autre problème dont je vais détailler dans un autre ticket.