Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 4 réponses, has 3 participants.

Last updated by lucieH-3 Il y a 1 an et 5 mois.

Assigned support staff: Max.

Auteur Messages
décembre 9, 2020 à 10:59 #7623683



I'm trying to personalize the image of one flag, but I've tried all the all format (18x12 px).
Can you help me ?

Thanks a lot,


décembre 9, 2020 à 12:55 #7625091

Diego Pereira

Languages: Anglais (English ) Espagnol (Español ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

It's possible to use a custom flag using the steps below:
- Go to WPML > Languages > Site Languages
- Click on "Edit Languages"
- Select "Custom Flag" on the language row
- Upload the custom flag image and save

Please let us know if it worked for you.

If the issue persist, could you please elaborate a little more on this issue, so I can better understand? E.g. The link of the page, steps you've tried, etc.

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

PS: To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here:

Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

décembre 9, 2020 à 1:03 #7625139


I've tried those steps but it doesn't work. I would like to change the picture of the dutch language. I've tried with a jpeg file but it doesn't appear on the menu language switcher on : .

Capture d’écran 2020-12-09 à 14.00.13.png
décembre 9, 2020 à 6:43 #7628571


Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Sao_Paulo (GMT-03:00)


The current filename of the image is missing the last character:

<em><u>hidden link</u></em> 1_Plan de travail

When I add the "g" at the end it works:

<em><u>hidden link</u></em> 1_Plan de travail 1.jpg

Please double-check the filename on your computer to have the correct extension, then go into the screen from your screenshot and try to upload it again.

Also, in case it doesn't help, I enabled debug information for this support ticket. We need this to be able to help you faster. Here's how to get this information from your site and provide it to us:

décembre 9, 2020 à 10:33 #7629799


My issue is resolved now. Thank you!