Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Je tente de changer le language original de mon site du français vers l'anglais et non l'inverse afin d'utiliser l'éditeur de traduction.

La solution: - Allez à WPML > Assistance technique. - Dépannage. - Réinitialiser. x Réinitialiser et désactiver WPML - Redémarrer la procédure d'installation.

This topic contains 15 réponses, has 2 participants.

Last updated by Andrés il y a 1 an.

Assigned support staff: Andrés.

Auteur Messages
octobre 8, 2018 à 4:54 #2796969

Sibiline

Bonjour,
Je tente de changer le language original de mon site du français vers l'anglais et non l'inverse afin d'utiliser l'éditeur de traduction. Lorsque je vais sur "translations' dans WPML, je ne peux changer le language original (capture écran en PJ). Comment dois-je faire ? j'ai déjà fait toute la mise à jour de mon site en français et je voudrais juste le dupliquer en anglais.
Merci de votre réponse rapide. Je suis dans l'urgence.
En vous remerciant,
Cordialement

octobre 9, 2018 à 6:07 #2798321

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Lorsque vous installez WPML pour première fois, l'extension considère que tout le contenu existant a été créé dans la langue par défaut, dans votre cas l'anglais.

Or, si votre contenu original a été créé en français, vous devez réinitialiser votre WPML. Par contre, vous allez perdre le contenu déjà traduit. Est-ce que j'ai bien compris votre question ?

Pour réinitialiser votre WPML :
- Allez à WPML > Assistance technique.
- Dépannage.
- Réinitialiser.
x Réinitialiser et désactiver WPML
- Redémarrer la procédure d'installation.

Cordialement,
Andrés

octobre 9, 2018 à 7:20 #2798525

Sibiline

Bonjour Andrès,

Merci pour votre message. Comment voyez-vous que mon site a été crée en anglais?
J'ai indiqué language par défaut : français (capture écran en pj).

Si je dois réinitialiser WPML, je vais perdre l'anglais ou le français?

J'ai terminé mon site en français et je voudrai écraser toutes les pages en anglais avec la mise en page française. Comment dois-je procéder?

Merci.
Cordialement,
Sibiline

octobre 9, 2018 à 7:31 #2798591

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de cette information Sibiline. D'après la première capture d'écran, WPML vous propose de traduire depuis l'anglais vers le français. Or, si vous avez le français comme langue par défaut actuellement, au moment de l'installation de votre WPML, vous avez choisi l'anglais. Pour cette raison, WPML considère que tout le contenu qui existait à ce moment était en anglais.

Or, si vous décidez à réinitialiser votre WPML et installer le français comme langue par défaut :
- WPML va prendre tout vos pages et articles comme créés en français.
- Les traductions faites dans la Traduction de chaînes vont disparaître.

Finalement, si vous souhaitez écraser toutes les pages en anglais avec la mise en page française, vous pouvez :
- Choisir le français comme langue par défaut.
- Aller à WPML > Paramètres > Configuration du contenu multilingue
- Comment traduire les publications et les pages
x Créer des travaux de traductions manuellement
- Visitez vos traduction en anglais.
- Cliquez sur le bouton "Écraser avec le contenu en français".
- Retournez à WPML > Paramètres > Configuration du contenu multilingue
- Comment traduire les publications et les pages
x Utiliser l'éditeur de traduction classique
- Traduisez à nouveau votre page en anglais.

Documentation:
https://wpml.org/fr/documentation-6/traduire-vos-contenus/utiliser-la-gestion-de-traduction-de-wpml/

Cordialement

octobre 9, 2018 à 10:56 #2799604

Sibiline

Merci pour votre réponse.
Si je choisis de réinstaller WPML, pouvez-vous m'assurer que je garde la version française de mon site et que je pers toutes les pages anglaises? J'ai fait une sauvegarde de toutes les pages anglaises sur word pour garder les textes. De ce fait, il ne me restera plus qu'à dupliquer toutes les pages (mise en page y compris) du français vers l'anglais et juste réinsérer le texte en anglais dans les champs proposés automatiquement?
Cordialement

octobre 9, 2018 à 11:06 #2799631

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Non, comme j'ai fait mention antérieurement si vous réinstallez votre WPML, l'extension ne va pas à éliminer vos pages anglaises. Elle va considérer que toutes vos pages ont été créés en français, voire les pages en anglais.

Par contre, vous n'avez pas besoin de récréer vos pages anglaises après la réinitialisation :
- Allez au Bureau > Pages.
- Cherchez et ouvrez une page en anglais désormais marquée comme français.
- Dans la partie droite, dans le bloc de langues, indiquez que cette page a été créé en anglais.
- Puis, associez cette page comme traduction de la respective page en français.

Cordialement

octobre 9, 2018 à 1:22 #2800145

Sibiline

Merci pour vos informations.

J'ai désinstallé tous les plugins WPML et je les ai réinstallé car je n'ai pas trouvé l'endroit pour les réinitialiser. Cependant, mes traductions prennent toujours l'anglais comme langue originale. J'avais pourtant sélectionné dans les "general settings" le français comme langue du site. Le fait d'avoir réinstallé WPML a tout remis en anglais. Je ne comprends pas pourquoi.
Merci de votre aide.

Cordialement

octobre 9, 2018 à 1:55 #2800327

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Réinstaller l'extension n'est pas suffisant, vous devez la réinitialiser.

Pouvez-vous m'indiquer l'étape bloquant pour pouvoir vous aider :
- Allez à WPML > Assistance technique.
- Dépannage.
- Réinitialiser.
x Réinitialiser et désactiver WPML
- Redémarrer la procédure d'installation en choisissant le français comme langue par défaut.

Cordialement

octobre 9, 2018 à 2:04 #2800345

Sibiline

Merci pour votre message.

je suis désolée mais dans l'onglet "support" (qui doit correspondre à Assistance technique), je vois ceci (en PJ). Je n'ai pas "dépannage" ni "réinitialiser".
Ou dois-je aller pour trouver "dépannage"?

Merci de votre aide.
Cordialement

octobre 9, 2018 à 2:07 #2800368

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre explication. Or, si votre admin se trouve en anglais :
- WPML > Support.
- Troubleshooting.
- Reset.
x I am about to reset all translation and language data.
x Reset and deactivate WPML

Cordialement

octobre 9, 2018 à 3:15 #2800740

Sibiline

Merci pour vos explications.
J'ai finalement réussi à réinitialiser le plugin.
Maintenant, j'ai un problème dans la mise en page du menu. Je ne sais pourquoi.

En fait, je voudrais qu'à chaque changement de mise en page d'une page française, la page anglaise correspondante soit aussi changée en même temps. Je voudrai juste changer le texte ensuite du français vers l'anglais.

Je comprends un peu mieux comment le système fonctionne. J'ai désormais toues les pages anglaises mélangées avec les françaises. Pour celles dans lesquelles je n'ai pas changé la mise en page, j'aimerais procéder comme vous me le proposiez plus haut. Je suis allée
Bureau > Pages.
- j'ai ouverts une page en anglais désormais marquée comme français.
- Dans la partie droite, dans le bloc de langues, j'ai indiqué que cette page a été créé en anglais.
- Puis, j'a mis "this is the translation of" puis j'ai indiqué ma page en français.

Quand je retourne sur "translations", ces deux pages associées n'apparaissent pas.

Merci de votre patience et de votre aide.
Cordialement

octobre 9, 2018 à 3:20 #2800758

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait! 🙂

Par contre, par normes du support nous ne pouvons pas traiter des différents sujets sur un même ticket. Cela nous permet de vous donner un meilleur service et aux autres utilisateurs d'accéder à l'information ici exposé. Je dois vous demander d'ouvrir un autre pour nous concentrer sur cette nouvelle situation, vous pouvez me l'assigner directement et nous pouvons continuer à travailler ensemble sur ce sujet.

Cordialement,
Andrés

octobre 9, 2018 à 6:53 #2801677

Sibiline

My issue is resolved now. Thank you!

octobre 10, 2018 à 5:57 #2803030

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait ! 🙂
Belle journée.

octobre 10, 2018 à 6:38 #2803115

Sibiline

Bonjour Andrès,
J'ai ouvert un autre ticket pour résoudre mon dernier problème. Il vous est adressé.
Bien cordialement,
Sibiline