Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Commentaire non affiché sur article traduit

Solution: Please update WPML and add-ons to their latest version

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 21 réponses, has 3 participants.

Last updated by bernardL-9 il y a 7 months.

Assigned support staff: Alejandro.

Auteur Messages
mars 18, 2019 à 8:51 #3373187

bernardL-9

Après avoir traduit un article du français à l'anglais avec le thème Divi, il n'est pas possible de voir la traduction du module commentaire. Il n'y a pas encore de commentaire sur l'article source (français). Il n'est pas possible d'écrire et soumettre un commentaire sur la traduction de l'article.

Page de l'article franco: hidden link
Page de l'article anglo (pas visible pour tous pour le moment): hidden link

Quand je fais un update de l'article anglo l'option "Allow comments" revient désélectionné (voir image). La même chose arrives avec les autres articles.

Le paramètre "Synchroniser les commentaires le un contenu dupliqué" est sélectionné.

Merci de m'aider à comprendre.

mars 19, 2019 à 9:22 #3377059

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

J'avoue que je ne comprends pas bien le problème pour le moment, j'ai donc écrit un commentaire sur la page française, le commentaire est en attente de modération pour le moment. Voir capture attachée.

WPML ne support pas la traduction des commentaires. Un commentaire écrit dans la version française d'un article serait visible juste dans la page française. Et pareil, un commentaire écrit sur la traduction anglaise serait visible juste sur la page anglaise.

L'action de dépannage relative aux commentaires sur WPML->Assistance Technique->Dépannage, supprimes le commentaires orphelins, par exemple dans le cas ou un article a été supprimé ou dans le cas ou une traduction d'un article a été supprimée.

"Allow comments" sur la version anglaise devrait être opérationnelle après publication de la traduction. Du moment que la traduction n'est pas encore publiée (Statut brouillon, ou la seconde langue n'est pas encore public). Les commentaires ne pourront pas être opérationnels.

Finalement, pourriez vous élaborer encore votre question ? Pourriez vous m'aider à comprendre en utilisant le modèle suivant:
1. Je vais sur xxx.
2. Je fais xxx.
3. Je m'attends à xxx.
4. J'obtiens plutôt xxx.

J'ai aussi activé l'espace privé pour partager les accès en toute sécurité, j'aurais probablement besoin de me connecter pour voir la page anglaise aussi.

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

mars 19, 2019 à 2:47 #3380377

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Bernard,

Merci pour les accès. Je vois bien que l'option "Allow comments" reste désactivée après qu'on l'ait activé et enregistré la traduction. J'ai testé avec la traduction anglaise du même article.
La configuration des commentaires sur WPML->Paramètres me semble correcte.

Pourriez vous faire les tests suivants, de préférence sur un serveur de test, ou sur le site directement.
1. Faire une sauvegarde de base de données.
2. Basculer sur un thème par défaut (Twenty Seventeen).
3. Désactiver toutes les extensions non WPML.
Si l'erreur n'est pas présente sur cette configuration, c'est probablement un conflit, réactiver 1-par-1 votre thème et les extensions pour détecter qui cause ce conflit.

Si l'erreur est présente dans cette configuration, c'est probablement un bug, our un cas de bord. Je voudrais dans ce cas faire une copie de votre site(on utilise Duplicator) et voir avec nos développeurs pourquoi cela arrive dans votre site.

Je reste à votre disposition.

Cordialement,
Jamal

mars 19, 2019 à 6:13 #3382373

bernardL-9

Bonjour Jamal,
J'ai fait ce que vous m'avez suggéré:
-Copie du site avec Duplicator
-Installation du site localement sur mon ordi à l'aide de Local by Flywheel
-Utilisation du thème WP 2017 avec nouvel éditeur et seulement WPML activé: pas de problème
-Utilisation du thème WP 2017 avec nouvel éditeur et tous les plug-ins activés: pas de problème
-Retour à Divi (avec ou sans child) avec éditeur classique et seulement WPML activé: pas de problème
-Retour à Divi (avec ou sans child) avec éditeur classique et tous les plug-ins WPML activés: problème
-Retour à Divi (avec ou sans child) avec éditeur classique et seulement WPML Yoast SEO activés: pas de problème

Je suis retourné sur le site en ligne pour essayer avec Yoast SEO désactivé...

Il semble effectivement y avoir un conflit avec Yoast SEO. J'utilise la version Version 10.0.1

Que doit-on faire à partir d'ici?
Si vous avez besoin d'une installation locale de votre côté, je peux vous fournir le fichier Duplicator.

Merci,
Bernard

mars 19, 2019 à 9:55 #3383621

bernardL-9

Re bonjour,
J'ai oublié de mentionner que oui, il y a un problème quand Yoast SEO est activé mais avec DIVI et l'éditeur classique WordPress.

Il n'y a pas eu de problème avec WP 2017 et Yoast SEO avec le nouvel éditeur WP. Je n'ai pas essayé l'éditeur classique dans cette configuration. Est-ce que je devrais?

Merci,
Bernard

mars 19, 2019 à 10:29 #3383697

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour. Comme vous avez pu trouver le conflit, j'aimerais qu'on puisse l'isoler de votre environnement, j'ai donc créé un serveur de test. Les accès sont sur le message privée.
Veuillez charger le thème Divi, configurer WPML et activer Yoast, si vous arrivez à reproduire l'erreur sur ce serveur. J'escaladerais ce cas à nos développeurs.

Si l'erreur n'est pas reproduite, j'escaladerais le ticket à notre équipe de 2ème niveau pour plus d'analyse.

Je reste à votre disposition.

Cordialement,
Jamal

mars 20, 2019 à 1:58 #3384281

bernardL-9

Bonjour Jamal,
J'ai fait ce que vous m'avez demandé.
Je suis capable de reproduire le problème sur l'article "Hello World!"

J'ai aussi réalisé que le problème est aussi dû au module Divi "Commentaires".
-Si j'enlève ce module de la page franco, puis synchronise la page anglo, le problème ne survient plus.
-Si je replace le module "Commentaires" sur la page franco, puis synchronise la page anglo, le problème revient.
-Désactiver le plug-in Yoast SEO règle ici aussi le problème.

Merci,
Bernard

mars 20, 2019 à 8:28 #3386039

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Bernard,

Merci pour votre retour. Avec tous les tests que vous avez pu faire, je vais escalader ce cas à notre équipe de compatibilité pour trouver une solution définitive. La demande sera traitée selon les priorités de l'équipe de compatibilité, et je vous ferais un retour aussitôt que je le peux.

J'imagine que vous pouvez activer l'une des solutions que vous avez trouvé pendant la résolution de ce bug. Désactiver Classic Editor, ou les commentaires sur Divi. Yoast par contre est beaucoup plus critique pour votre site et devrait rester activé.

Merci encore une fois pour votre collaboration. Je reste à votre disposition.

Cordialement,
Jamal

mars 20, 2019 à 12:13 #3388181

bernardL-9

Jamal,
Comme workaround je vais éviter d'aller modifier la traduction d'un article en utilisant l'éditeur DIVI. Il arrive parfois que ce soit nécessaire, dans ces cas j'irai désactiver Yoast SEO temporairement.

Je vais attendre la solution avant de fermer le ticket.
Tenez-moi au courant des développements.

Merci
Bernard

mars 20, 2019 à 12:42 #3388363

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Le ticket est maintenant escaladé à notre équipe de compatibilité. Je vous tiendrais au courant de toute nouvelle aussitôt que possible.

Merci.
Jamal

mars 26, 2019 à 12:05 #3462093

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

L'équipe de développement essaye de reproduire cette erreur sans succès. Voici un serveur de test, ou nous avons installé Divi, Yoast et Classic Editor sans pouvoir reproduire cette erreur.
Pourriez vous voir si nous avons oublié un paramétrage ?
Sandbox: hidden link

Cordialement,
Jamal

mars 26, 2019 à 1:05 #3462633

bernardL-9

Bonjour Jamal,
Merci pour votre retour.
Je viens de reproduire le problème.
Voici la séquence (images à l'appui):
1-Aller dans le menu des Articles anglophones. Cliquer Modifier de l'article Hello World!.
2-Dans le panneau Discussion, activer l'option autoriser les commentaires.
3-Mettre à jour l'article.
4-Dans le panneau Discussion, l'option autoriser les commentaires s'est désactivé.

Ce problème survient si Yoast est activé ET qu'un module DIVI 'Commentaire' est utilisé dans la page...
Mais je crois avoir trouvé une piste à l'aide de l'article 'compsupp-3752 - Test EN' que vous avez créé. Voir le prochain Reply.

mars 26, 2019 à 1:19 #3462821

bernardL-9

Avec l'article 'compsupp-3752 - Test EN':
Au départ, je n'étais pas capable de reproduire le problème. J'ai donc ajouté un module DIVI 'Commentaire'. Toujours pas de problème...

Alors j'ai pensé aller modifier le Slug en enlevant le suffixe '-en' (car s'est ce que je fais avec mes articles). Le problème survient!

Il n'y a pas de problème avec la page française. J'ai essayé la même chose en enlevant le suffixe '-fr' sans problème.

Merci de votre aide,
Bernard

mars 27, 2019 à 9:16 #3468861

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour. Même après votre manipulation, je pouvais poster un commentaire en anglais.
Il fallait que j'ouvre la version anglaise en edition manuelle pour voir que l'option des commentaires est toujours désactivé après sauvegarde. Et je ne pouvais pas poster un commentaire.

J'ai escaladé ses tests à notre équipe de compatibilité, je reviendrais vers vous aussitôt que possible.

Cordialement,
Jamal

mars 28, 2019 à 6:50 #3485023

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

L'équipe de compatibilité a pu reproduire cette erreur et prendra en charge le ticket.
Heureusement, ce n'est pas bloquant, on peut par exemple désactiver Yoast le moment de sauvegarder l'article.
Je tiendrais au courant de l'avancement de cette demande aussitôt qu'on aura un retour de l'équipe.

Cordialement,
Jamal