Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 23 réponses, has 2 participants.

Last updated by Jamal il y a 2 mois et 2 semaines.

Assigned support staff: Jamal.

Auteur Messages
juillet 23, 2019 à 3:46

aissamO

Je tente de :

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : Que tout fonctionne !!

À la place, j'ai obtenu :
1-Problème d'accès au menu plugins au niveau du dashboard (voir capture d'ecran en pièce jointe)
2-Les liens des pages au niveau du menu renvoient tous vers la page erreur 404 à présent.

juillet 23, 2019 à 5:22 #4268435

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

je dirais que c'est un conflit de compatibilité avec une autre extension ou avec le thème, veuillez essayer le test suivant:
- Basculer vers un thème par défaut, et vérifier si ça corrige l'erreur.
- Désactiver toutes les extensions non WPML et vérifier.
Si l'erreur n'est pas visible sur l'un des deux cas, réactiver votre thème puis les extensions une à la fois et vérifier à chaque fois pour détecter quelle composante génère cette erreur.

Il se peut que ce soit aussi à cause de d'anciennes versions des extensions. Veuillez essayer avec les dernières versions que vous pourrez télécharger sur https://wpml.org/fr/account/downloads/

De mon coté, j'ai pu accéder à plusieurs pages sur votre site sur les deux langues, et j'ai pu aussi accéder à la page des plugins. J'assume que vous avez pu corriger le problème depuis tout à l'heure.

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

juillet 24, 2019 à 4:32 #4276403

aissamO

Bonjour,

J'ai déjà effectué les tests demandés et le problème persiste. Tous les plugins WPML sont à jour.

Un moment donné j'ai activé les deux à la fois, mais je ne pouvais plus effectuer la moindre modification sur le site web, jusqu'à la désactivation de WPML Translation Management.

En mode sans échec, on me signalait que le plugin WPML CMS ne se chargeait pas correctement.

Prière d'investiguer davantage.

Cordialement.

juillet 25, 2019 à 8:38 #4280873

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je viens d'essayé d'installer l'extension Translation Management pour vérifier ses erreurs et l'installation semble bloquée, j'ai rencontré la même erreur sur le menu Plugins que celle sur votre capture d'écran.
En revanche, j'ai pu accéder à plusieurs pages produit en anglais, à la page blog et à un article, j'ai pu ajouter un produit au panier en anglais.

J'ai voulu éxecuter les actions de dépannage sur WPML->Assistance technique->Dépannage, mes toutes les requêtes se terminent avec une erreur 500. J'aurais aimé désactivé l'extension Translation Management via FTP, mais je n'ai pas eu accès.

Pour l'instant, je vous prie de m'accorder un accès FTP, et activer le déboggage PHP
https://wpml.org/fr/documentation-6/informations-pour-les-developpeurs/debogage-de-wpml/#activer-la-fonction-integree-de-debogage-dans-wordpress

Je continuerais mon analyse. Veuillez aussi faire une sauvegarde de base de données.

Cordialement,
Jamal

juillet 25, 2019 à 11:23 #4282465

aissamO

Bonjour,

J'ai créé un compte FTP pour vous, mais je ne vois comment vous l'envoyer en messagerie privée.

Cordialement.

juillet 25, 2019 à 11:59 #4282775

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

J'ai activé l'espace privé. Si vous avez des doutes, utilisez mon addresse email jamal.b(at)onthegosystems.com

Cordialement,
Jamal

juillet 25, 2019 à 12:42
juillet 25, 2019 à 1:16 #4283441
aissamO

Par la même occasion,

Je ne comprends pas pourquoi les pages des catégories de produits sont accessibles en Anglais, tandis qu'en Français je reçois la page d'erreur 404, et pourtant la traduction était bel et bien faite.

Est ce que ce dysfonctionnement est lié à celui du conflit entre Plugins ?

Cordialement.

Les nouveaux fils créés par Jamal et associés à celui-ci sont repris ci-dessous :

https://wpml.org/fr/forums/topic/les-pages-de-categories-produits-ne-sont-pas-accessibles-sur-la-langue-par-defautl-francais/

juillet 25, 2019 à 3:25
juillet 25, 2019 à 3:29 #4284679

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

J'ai réactivé/désactivé le plugin à plusieurs reprises, le problème est toujours constatée, mais aucune erreur n'est écrite sur le fichier des logs.

Pour pouvoir investiguer ce problème sans affecter votre site en ligne, j'ai créé un nouveau serveur sur notre platefrome, et je vous ai envoyé les instructions pour migrer votre site dessus sur mon dernier message privé(JUILLET 25, 2019 À 3:25).

Je continuerais mes investigations dés que vous ayez terminé la migration.

Cordialement,
Jamal

juillet 26, 2019 à 11:39 #4292003

aissamO

Bonjour,

La migration a été effectuée avec succès.

La langue du thème est l'anglais, mais j'utilise le français comme langue par défaut.

Dans l'attente de votre retour.

Cordialement.

juillet 29, 2019 à 10:10
juillet 29, 2019 à 10:10 #4298607

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre collaboration. J'ai basculé le thème vers Twenty seventeen et j'ai désactivé toutes les extensions non WPML et WooCommerce.
Ensuite j'ai pu activer WPML Translation Management et WooCommerce Multilingual sans aucun soucis. J'ai aussi executé toutes les actions de nettoyage sur WPML->Support->Troubleshooting avec succès.

Je dirais donc que c'est un souci de compatibilité avec un autre composant. Je vous laisse le soin de vérifier sur le serveur migré quel composant est la cause de ce problème. Vous pouvez utiliser vos propres login/password.
Veuillez réactiver votre thème, et les extensions une à la fois et tester à chaque fois de visiter la page plugins pour vérifier qui pause problème.

Il faut aussi noter que l'extension WP Cache a été automatiquement désactivé sur le serveur migré, il se peut qu'elle soit à l'origine de ce problème.

J'ai mis sur un message privé(JUILLET 29, 2019 À 10:10) la liste des extensions qui n'étaient pas installées au début de ma manipulation.

Je reste à votre disposition.

Cordialement,
Jamal

juillet 29, 2019 à 2:47 #4301059

aissamO

Bonjour,

Je ne pense pas que le problème soit lié à l'un des plugins précités, car pendant bien longtemps tout fonctionnait à merveille sans le moindre souci.

Le fait de tout désactiver, et de ne laisser que les extensions WPML et WooCommerce pour que ça fonctionne, est peut être un indicateur qu'il s'agit principalement d'un problème de limite de mémoire. D'ailleurs, l'exercice d'activer les plugins 1 par 1, a été déjà réalisé auparavant et n'a rien donné comme interprétation.

J'ai du augmenter la limite de la mémoire au niveau du fichier php.ini, et il me semble que cela fonctionne à présent, mais j'aimerai bien tout de même avoir votre confirmation par rapport à ça.

Bien cordialement.

juillet 29, 2019 à 2:55 #4301193

aissamO

Je viens de rencontrer le même problème de nouveau.

En activant le mode sans échec, je retrouve l'erreur suivante au niveau du plugin WPML CMS (voir screenshot)

Cordialement.