Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Marqué : 

This topic contains 10 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 4 mois.

Assigned support staff: Andrés.

Auteur Messages
mai 16, 2018 à 11:03 #2155635

floran

Bonjour Bonjour !

Je rencontre un souci avec l'utilisation de WPML et m'en remet à vous ! 😉
Je suis en train de finaliser un site wordpress censé être disponible dans les langues suivantes : langue principale - Français (FR), Anglais (EN) et Espagnol (ES).

Pour la création des pages anglaises et espagnoles, j'ai dupliqué les pages françaises puis coché la case "traduire à part".

Mon problème : dès que j'effectue la moindre modification sur une page FR, le contenu est écrasé et remplacé par le contenu FR sur les pages EN et ES. En gros, la moindre modification sur la version française du site affecte les traductions concernées. ;(

Pour la construction des pages, j'ai utilisé le page builder fourni avec le thème. J'ai pu remarquer que c'était précisément ces contenus (intégrés dans le page builder) qui étaient écrasés. Les titres, widgets etc. - intégrés en dur dans l'éditeur WordPress - restent inchangés, ils ne sont pas écrasés par la version FR.

Le thème est vendu comme étant 100% compatible avec WPML, mais après de nombreux échanges vains avec le support de ce dernier, je ne sais plus trop quoi faire. J'ose penser qu'il s'agit peut-être d'un problème de configuration ou quelque chose du genre, je croise les doigts !

Merci par avance pour votre aide.

mai 16, 2018 à 11:37 #2155932

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Il semble que la configuration de votre Page Builder a été configuré como "Copier" à la place de "Traduire".
- Pouvez-vous ouvrir une page en question.
- Descendre à la partir "Multilingual Content Setup"
- Vérifier que le(s) champ(s) associé au contenu de votre Page Builder est marqué comme Traduire.
Est-ce que le problème est résolu ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

mai 16, 2018 à 12:51 #2157245

floran

Merci pour votre retour.
J'ai vérifié, les champs associés au page builder sont bien configurés sur "traduire" (cf. screenshot joint)

Comment vous transmettre les infos de débogage ?

mai 16, 2018 à 2:05 #2159234

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

1. Pouvez-vous essayer à rendre votre information de débogage à nouveau ? Vous devez voir un champ pour ce but.

2. Pouvez-vous cliquer sur le lien "Afficher les champs du système" que s'affiche sur votre capture d'écran ?

3. Pouvez-vous me dire le nom de votre Page builder ?

Cordialement

mai 16, 2018 à 6:46 #2162794

floran

Merci Andrés pour vos retour,

J'ai renseigné les infos de débogage ci-dessus.
À propos du page builder, j'ai comme l'impression qu'il s'agit d'un outil dédié au thème.
La doc du thème est dispo ici : hidden link

En PJ, l'affichage des champs personnalisés "champs système" + aperçu du page builder en question.

Merci !

mai 17, 2018 à 6:13 #2167737

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Merci de votre information de débogage. Votre thème Hotel Master n'est pas dans notre liste de compatibilité. Cela n'implique pas forcément qu'il n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.
https://wpml.org/documentation/theme-compatibility/

1. Pouvez-vous marquer le champ _dp_original comme Traduire, est-ce que la situation change ?

2. Si ce n'est pas le cas, pouvez-vous mettre à jour votre thème ?
hidden link

Cordialement

mai 18, 2018 à 1:38 #2184797

floran

Bonjour Andrés,

J'ai passé "dp-original" sur traduire mais rien de change malheureusement.
Le thème est également à jour.

J'ai eu en parallèle un retour de la part du support du thème, cf. message ci-dessous.
"Hi,

This seems to cause from "WPML Media" plugin.

Could you try deactivating that and see if it's working or not ? If it works, could you try contacting the WPML author to see why WPML Media made a changes to post_meta field which isn't related to the Media file ?"

Merci encore pour votre aide,

mai 18, 2018 à 6:26 #2186171

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

mai 18, 2018 à 2:48 #2189909

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci beaucoup de votre claire description, je viens de visiter votre site et reproduire cette situation.

Je viens de discuter avec notre Équipe de compatibilité et ils m'ont confirmé qu'il s'agit d'un problème de compatibilité avec votre thème car il n'utilisez pas de shortcodes pour la création de contenu. La bonne nouvelle est qu'il sont déjà identifié ce problématique est ils essayent de trouver une solution temporaire car ils ont essayé de contacter l'auteur ça fait quelques mois sans chance.

Merci pour les détails de contact que vous nous avez fourni et pour nous attirer l’attention sur ce sujet. Je vais envoyer les détails à notre Équipe de Compatibilité des thèmes et plugins, et ils vont contacter l'auteur à nouveau.

S’il vous plaît, cette procédure peut prendre du temps car il dépend aussi de la vitesse que l'auteur réponds à nos efforts pour lui contacter. Il serait très important si vous essayez de contacter l'auteur en lui demandant de nous répondre.

Vous pouvez aussi lui demander de faire partie de notre programme Go Global, cela pourrait lui permettre de faire son thème compatible avec WPML. https://wpml.org/documentation/theme-compatibility/go-global-program/. Il pourrait aider à accélérer ce processus.

Cordialement,
Andrés

mai 21, 2018 à 4:21 #2202880

floran

Bonjour Andrés et merci pour l'ensemble de vos retours.
J'ai repris contact avec le support du thème en leur demandant qu'ils reviennent rapidement vers vous.

J'espère que nous serons en mesure de trouver une solution prochainement. Dans l'attente, si vous avez la moindre question ou tout simplement besoin de précisions concernant le problème rencontré, n'hésitez pas à me demander !

Encore merci,
Virginie.

mai 22, 2018 à 7:02 #2205234

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Virginie,

Justement je viens de recevoir un feedback de notre Équipe de compatibilité. Pour résoudre ce problème :

- Je suis allé à WPML > Gestion de traduction > Configuration XML personnalisée.
- J'ai ajouté le code à continuation :

wpml-config>
    <custom-fields>
        <custom-field action="ignore">above-sidebar</custom-field>
        <custom-field action="ignore">below-sidebar</custom-field>
        <custom-field action="ignore">content-with-sidebar</custom-field>
        <custom-field action="ignore">post-option</custom-field>
    </custom-fields>
</wpml-config>

- Puis, j'ai visité l'onglet Configuration du contenu multilingue.
- Désormais, la modification de la page original ne change pas le contenu de sa traduction.

Est-ce que cela résout votre problème ?

Documentation :
https://wpml.org/documentation/support/language-configuration-files/