Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 12 réponses, has 2 participants.

Last updated by Nohemi il y a 3 ans et 3 mois.

Assigned support staff: Andrés.

Auteur Messages
avril 13, 2017 à 12:27 #1253740

Nohemi

Hi,

I want to copy an ACF image field between all languages.

So i checked "Copy (from original to translation)" (see screenshot).

The field is copied but when i use

get_field('image')

the ID of the image is returned instead of an array.

This probleme have beend already reported here : https://wpml.org/forums/topic/huge-compatibility-problem-with-acf-pro/

Tested on a new WordPress with only WPML and ACF plugins installed.

Bonjour,

Je souhaiterais que la valeur d'un champ ACF de type image soit identique entre toutes les langues.

J'ai donc coché la case "copie de l'original à la traduction". (voir screeschot)

Le champ est bien copié mais au lieu d'avoir un tableau quand j'utilise get_field('image') comme sur la langue originale, j'obtiens l'ID de l'image.

Ce problème avait déjà été signalé ici : https://wpml.org/forums/topic/huge-compatibility-problem-with-acf-pro/

Testé sur un nouveau WordPress avec uniquement les plugins de WPML + ACF d'installés.

avril 13, 2017 à 12:58 #1253771

Nohemi

I forgot to precise : i get the ID on secondary languages. On the default language i get an array. (like I want)

I added a screenshot of ACF field settings. Like you see, return value is configured on array.

avril 13, 2017 à 3:13 #1253909

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Si je comprend bien, vous obteniez bien l'ID de votre image mais pas l'array, correct ?

1. Avez-vous traduit votre champ image ? Si c'est le cas, est-ce que les ajustements restent pareil ?

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

Cordialement,
Andrés

avril 13, 2017 à 3:49 #1253950

Nohemi

1. Pas sûr de comprendre car je ne veux justement pas le traduire mais qu'il soit copié entre les langues

Je suis déjà en mode debug et je n'ai pas vu d'erreur

Avez-vous essayé de reproduire le bug ?

Il suffit de créer un groupe sur ACF et de le lier au post type page par exemple.
Ensuite créer un champ de type Image. (en laissant tout par défaut)
Aller sur une page, remplir le champ dans la langue par défaut.
Puis aller sur "configuration du contenu multilingue", passer le paramètre pour ce champ sur "copie de l'original à la traduction"
Réenregistrer la page pour être sûr que le champ est bien copié.
Enfin ajouter

var_dump(get_field([nom_du_champ]));

dans le template de la page.

Quand je fais ça, j'ai bien un array sur la page de la langue par défaut mais j'ai un ID sur toutes les autres langues.

avril 14, 2017 à 12:29 #1254388

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

avril 14, 2017 à 4:16 #1254554

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre information. Pouvez-vous mettre à jour votre Advanced Custom Fields PRO à la version 5.5.11+ ?
hidden link

Cordialement,
Andrés

avril 19, 2017 à 6:50 #1256661

Nohemi

Hum, c'est déjà le cas non ?

avril 19, 2017 à 1:58 #1257162

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci d'avoir mis à jour votre ACF Pro.

Il fallait installer l'extension WPML Media Translation. Une fois installé, je suis allé à WPML > Traduction multimédia et dupliquer le contenu média.

Puis, j'ai traduit les options du ACF Pro en cochant les options de duplication de média depuis cette section.

Finalement, j'ai mis à jour vos pages et tout foncitonne correctement.

J'ai aussi créé un deuxième champ et il fonctionne correctement.

Est-ce que cela résout vos doutes ?

Documentation :
https://wpml.org/documentation/getting-started-guide/media-translation/

avril 19, 2017 à 2:59 #1257245

Nohemi

oui ça fonctionne mais vous avez modifié le paramètre "Comment traduire les publications et les pages". Vous êtes repassé en mode "Créer des travaux de traductions manuellement " alors que j'ai besoin que ça fonctionne en mode "Utiliser l'éditeur de traduction" car j'utilise un page builder (visual composer) sur mon site et j'aimerais profiter du nouveau système de traduction.

Si je passe en mode "Utiliser l'éditeur de traduction", que je supprime la traduction anglaise et que je la recrée, même avec WPML media, on n'a toujours que des ID : hidden link

avril 19, 2017 à 4:06 #1257313

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je viens de vérifier ce comportement. Par contre, si vous sauvegardez vos traductions une fois avec l'éditeur de traduction de WordPress, puis vous retournez au éditeur de WPML tout fonctionne correctement.

Si vous le souhaitez, vous povuez utilisez cette manipulation temporaire. Cela va a impliquer plus de temps developement.

Je vous tiens au courant des avances.

avril 20, 2017 à 7:03 #1257660

Nohemi

D'accord, j'espère que ça ne prendra pas trop de temps car ce n'est du coup pas très pratique pour l'instant.

avril 20, 2017 à 7:40 #1257697

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je viens d'avoir un feedback, pouvez-vous dupliquer vos pages, puis les marquer comme des pages independants ? De cette manière vous auriez l'information complete de l'image et pouvez utiliser l'interface de traduction de WPML.

avril 20, 2017 à 2:10 #1258158

Nohemi

Ah merci, c'est un peu plus pratique même si ce serait encore mieux de ne pas avoir à passer par cette "astuce".

Merci pour votre aide 🙂