Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Mots-clés : 

This topic contains 5 réponses, has 2 participants.

Last updated by Jamal il y a 3 mois et 1 semaine.

Assigned support staff: Jamal.

Auteur Messages
juillet 1, 2019 à 10:25 #4117799

pbraun

Je tente de : importer un module de la library (sauvé depuis une page Allemande) sur une page traduite en Allemand

URL de (mon) site Internet où le problème apparaît : not relevant

Je m'attendais à voir : le module au moment on j'appuie sur "Add from library"

À la place, j'ai obtenu : "You have not saved any items to your Divi Library yet. Once an item has been saved to your library, it will appear here for easy use."

Le module est bien enregistré dans la Library.

juillet 1, 2019 à 1:37 #4119435

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Avant de pouvoir investiguer cette erreur, je vous prie de mettre à jour les extensions WPML à leurs dernières versions.
https://wpml.org/fr/faq/comment-installer-wpml/

Je voudrais aussi comprendre mieux la manipulation que vous avez du faire pour atteindre ce résultat?

Avez vous traduit les modules de la Library en utilisant l'éditeur de traduction Classique, de la même manière qu'un post ou une page.
https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

Serait il possible d'enregistrer une courte vidéo des étapes à suivre pour reproduire cette erreur dans une nouvelle installation!
Voici un serveur de test que j'ai créé si vous voudriez bien y reproduire l'erreur. Et enregistrer la vidéo pour que je et nos développeurs eventuellement pourrions suivre pour reproduire l'erreur.
hidden link

Cordialement,
Jamal
Assistance WPML

juillet 3, 2019 à 11:46 #4135575

pbraun

Bonjour,

Voila le process que j'ai suivi:

1. J'ai créée ma page avec le Divi Builder
2. J'ai traduit cette en Allemand avec le Translator Manager
3. Etant donné que le module Divi Gallery n'apparaît pas dans le manager (et que j'ai besoin d'afficher d'autres photos dans ma gallery Allemande), j'ai modifier la page allemande avec le Divi Builder.
4. Une fois la gallery modifiée, et pour éviter de refaire cette manip à chaque fois que je modifie la page sur le manager car oui en cliquant sur "Save" dans le manager ca me remet la Gallery Française..., j'ai décidé de l'enregistrer dans la Divi Library sous le nom Gallery ALL et catégorie ALL.
5. Lorsque je souhaite l'intégrer dans une page Allemande, on me dit que je n'ai pas de Modules dans ma library. Et pourtant le dropdown pour filtrer selon les catégorie me montre bien toutes les catégories...

J'espère que c'est clair.
BTW ces modules qui n'apparaissent pas dans le manager c'est vraiment embêtant et contre productif. A chaque fois qu'on update les modules de la langue principale sont réinjectés dans la page. C'est infernal. Je ne sais pas comment gérer cette situation. Merci

juillet 4, 2019 à 11:14 #4142639

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour. C'est plus clair. Je pense que qu'il est possible que ça soit un bug de compatibilité. Pour pouvoir confirmer cela, nous aurons besoin de reproduire cela dans l'un de nos serveurs de test. Je viens de créer le site ci dessous, pourriez vous reproduire ce problème dessus.
hidden link
Une fois reproduit, je pourrais solliciter l'aide de notre équipe de compatibilité. Je vous prie de configurer WPML à l'instar de votre site, charger le thème Divi et essayer de reproduire l'erreur.

Pourriez vous enregistrer une courte vidéo à l'aide de Screencastify ou Loom pour qu'on puisse la partager avec les développeurs.

Je reste à votre disposition.

Cordialement,
Jamal

juillet 11, 2019 à 9:37 #4187967

pbraun

Bonjour,

J'ai record le processus = hidden link
Bon sur cet environnement le module "galery DE" s'affiche bien.. je ne comprends pas.
ND: dummy images

juillet 11, 2019 à 12:55 #4189897

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

La première différence que je notterais entre votre serveur et le serveur de test est les versions des extensions WPML. Sur le serveur de test, toutes les extensions WPML sont mise à jour à la dernière version.

Deuxième différence, et l'usage de plus d'extensions sur votre serveur que sur celui du test. Il se peut qu'une extension pose conflit. Cela pourrait être confirmer en désactivant toutes les autres extensions non WPML et basculer vers un theme par défaut. Si l'erreur est abscente, alors on réactivera un-par-un le thème et les extensions et vérifier à chaque fois quand est ce que l'erreur revienne pour savoir quel composant pose ce conflit.

Il est aussi possible que cela soit causé par des données non intègres, par exemple, le module qu'on vient de tester n'a pas eu les informations de langues pour que WPML puisse savoir si c'est en français et ou en allemand. WPML offre plusieurs actions de nettoyage qui peuvent corriger cela. Sur WPML->Assistance technique->Dépannage, section de nettoyage(cleanup). Noter bien qu'il faudrait faire une sauvegarde de base de données avant d'éxecuter ces actions.

Finalement, il est aussi possible qu'il y a des différences au niveau du serveur, par exemple, un CDN, un système de cache(Varnish, Memcache, etc.) qui soit à l'origine de ce dysfonctionnement. Il faudrait demander à votre administrateur système ou votre hébèrgeur à propose. Pour pouvoir exclure cette hypothèse, je pourrais créer un serveur de test sur notre plateforme et vous donner les instructions à suivre pour migrer votre site dessus, ensuite on testerait si l'erreur est aussi présente dans ce cas, si elle est pas présente, nous pourrons dire que votre serveur est à l'origine de ce dysfonctionnement. Si l'erreur existe aussi dans ce cas, on pourrait dire que c'est l'une des premières hypothèse.

Je reste à votre disposition.

Cordialement,
Jamal

Le sujet ‘[Fermé] Divi library items not showing in translated pages’ est fermé à de nouvelles réponses.