Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 7 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 1 mois.

Assigned support staff: Andrés.

Auteur Messages
septembre 24, 2018 à 7:46 #2759595

marcL-24

Hi all,

I just noticed that more than 1,900 translated pages of my website are not indexed by Google since they are considered as "Duplicate content". It concerns pages translated using WPML.

What could be improved to avoid this issue?

Thanks

septembre 24, 2018 à 1:17 #2760583

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous m'indiquer comment a été remarqué de ce comportement ou le genre d'alerte dont vous avez reçu ?

2. Pouvez-vous m'indiquer des pages qu'ont été marqués comme "contenu dupliqué" ?

Cordialement,
Andrés

septembre 24, 2018 à 3:43 #2761147

marcL-24

J'effectue le suivi de l'indexation Google depuis mon espace Google Webmaster depuis plusieurs années, et pour une raison qui m'échappe, environ 1920 pages de mon site wordpress ne sont toujours pas indexées pour la raison suivante :

"Page en double. L'URL envoyée n'a pas été sélectionnée comme URL canonique : l'URL fait partie d'un ensemble d'URL en double sans page canonique explicitement indiquée. Vous avez demandé que cette URL soit indexée, mais comme il s'agit d'un doublon et nous pensons qu'une autre URL serait une meilleure version canonique, nous n'avons pas indexé cette URL. Au lieu de cela, nous avons indexé la version canonique que nous avons sélectionnée. La différence entre ce statut et "Google n'a pas choisi la même page canonique que l'utilisateur" est la suivante : dans le cas présent, vous avez explicitement demandé l'indexation."

Ces pages ont été dupliquées via WPML et sont toutes des traductions des pages d'origines en français.
Exemples :
- hidden link
- hidden link
- hidden link

septembre 24, 2018 à 4:26 #2761254

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Vos pages ne sont pas de doublons et elles ont été correctement traduites. En plus, en regardant le code source, les étiquettes hreflang ont été correctement ajoutés.

Par contre, WPML n'ajoute pas des étiquettes pour l'URL canonique. Si vous souhaitez les ajouter et comme vous avez l'extension Yoast installé, vous pouvez utiliser la fonctionnalité que cette extension vous propose.

septembre 25, 2018 à 7:47 #2762881

marcL-24

Merci pour la réponse.

Comment expliquer que Google comprend les pages correctement traduites comme étant des doublons ?

Cordialement.

septembre 25, 2018 à 8:01 #2762898

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

D'après le message dont vous avez ajouté, l'erreur vient de manipulation effectué au moment d'ajouter des URL canoniques. Or, une fois cette problème soit résolu, Google ne devrait prendre vos pages comme des doublons non plus.

Cordialement

septembre 25, 2018 à 10:36 #2763410

marcL-24

Je n'ai pas ajouté ou spécifié d'URL canoniques. Dois-je le faire ? Si oui, comment ?

septembre 25, 2018 à 12:04 #2763664

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Comme WPML ne gère pas d'URL canoniques, il n'existe pas une option depuis notre plugin pour les modifier. Par contre, des extensions pour le SEO comme Yoast SEO, dont vous avez déjà installé, vous offre cette fonctionnalité.

Finalement, je vous recommande aussi de vous approcher chez Google et leur demander plus d'information sur l'erreur que s'affiche dans votre Google Webmaster.