Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This thread is resolved. Here is a description of the problem and solution.

Le problème : e tente de traduire mes groupes de champs afin qu'ils soient disponibles à la traduction et visibles dans mes pages traduites

La solution: - Désactivez l'extension WP-FACET.

This topic contains 9 réponses, has 2 participants.

Last updated by Andrés il y a 12 mois.

Assigned support staff: Andrés.

Auteur Messages
octobre 20, 2018 à 5:52 #2834441

amauryL

Je tente de : Traduire mes groupes de champs afin qu'ils soient disponibles à la traduction et visibles dans mes pages traduites

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : Les champs dupliqués en anglais pour mes groupes de champs

À la place, j'ai obtenu : Un groupe de champs vide

octobre 21, 2018 à 6:39 #2835832

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 256M
- WP Memory Limit 128M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

2. Après avoir incrémenté votre WP Memory Limit, que est-ce que se passe si vous cliquez sur le bouton "Écraser avec le contenu en Français ?

3. Essayer aussi le suivant :
- Allez au Bureau > Custom Fields.
- Changez de langue en cliquant sur le sélecteur de langue que se trouve sur la barre supérieur.
- Effacez le groupe de champs.
- Videz la Corbeille.
- Visitez votre groupe de champs.
- Cette fois au moment de le traduire, Dupliquez le groupe.

Cordialement,
Andrés

octobre 21, 2018 à 8:50 #2835956

amauryL

Merci pour l'aide,
j'ai augmenté la mémoire à 512mb sur le serveur et dans le wp-config.

Les étapes fonctionnent pour des groupes de champs qui ont de 1 à 3 champs à l'intérieur mais j'ai deux groupes qui ont respectivement 9 et 17 champs chacun et cela ne fonctionne toujours pas.

Merci pour l'aide

PS : J'ai essayé toutes les alternatives que vous avez mentionné.

octobre 22, 2018 à 6:38 #2836907

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci d'avoir partagé vos résultats.

D'arès vos commentaires, il semble que le problème peut être associé aux ressources disponibles de votre site car cela fonctionne lorsque vous traduisez certain groupes.

Pour cette raison, je viens de créer une installation WordPress de test. Vous pouvez y accéder en cliquant le lien à continuation :
hidden link

Une fois vous êtes sur le Bureau du site, installez votre ACF Pro et essayez de reproduire cette situation. De cette manière, s'il s'agit d'une bogue de WPML, je peut transmettre ce site de test à notre Équipe de compatibilité.

Note: vous n'avez qu'installer le thème/extension nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Finalement, si vous cherchez une solution rapide, n'hésitez pas à ajouter les champs manuellement.

Merci de votre aide,
Andrés

octobre 22, 2018 à 12:23 #2837947

amauryL

salut
J'ai essayé et tout a fonctionné sur votre site Web sandbox. Je ne comprends pas. Je vais faire un suivi avec mon fournisseur de serveur, peut-être qu'ils bloquent quelque chose?

Quels sont les requis pour WPML et la fonction Dupliquer?

De plus, j'ai remarqué une différence entre WPML sur Sandbox et mon site Web. S'il vous plaît voir les 2 captures d'écrans. Dans les paramètres, je n'ai que acf-field-group, alors que vous avez acf-field-group et acf-field.

Savez-vous comment puis-je avoir l'option comme vous?

En vous remerciant.
Amaury

octobre 22, 2018 à 2:33 #2838441

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci Amaury. Une autre différence que je vois est que vous n'avez pas installé la dernière version du ACF Pro dans le site test. Est-ce que le problème revient si vous faites la mise à jour dans notre site de test ?

octobre 23, 2018 à 1:08 #2840100

amauryL

J'ai mis à jour le plugin et cela fonctionne dans le sandbox, je fais un suivi avec l'hébergeur et je vous reviens.
Merci pour l'aide!

octobre 23, 2018 à 6:44 #2841095

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bon courage, je reste à l'attente de vos résultats.
Pour votre information, le forum français sera fermer jusqu'au lundi prochain.
Merci de votre compréhension.

octobre 23, 2018 à 12:44 #2842383

amauryL

My issue is resolved now. Thank you!
Finalement après avoir désactivé tous les plugins et les avoir réactivé un par un, j'ai finalement trouvé que c'est le plugin WP-FACET qui provoque ce pb : hidden link

Merci encore pour le bon support!

octobre 23, 2018 à 2:39 #2842975

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Super ! 🙂
Je vous souhaite une belle fin de journée.