Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 32 réponses, has 3 participants.

Last updated by Jamal il y a 6 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
mars 20, 2019 à 6:53

genevieveC-3

Je tente de : Lorsque l'on tente d'ouvrir la boîte des variations de produit d'un produit existant pour y modifier le prix, le toggle ne s'ouvre pas.... Exemple produit 9497

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : le toggle pour éditer mes variations.

À la place, j'ai obtenu : aucune action possible à mins d'ajouter une nouvelle variation.

mars 21, 2019 à 7:21 #3396051

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et tout semble de fonctionner correctement, pouvez-vous le vérifier ? Dans le cas contraire, pouvez-vous m'indiquer d'une manière détaillé comment reproduire le problème ?

Aussi, pouvez-vous vérifier si le problème persiste en désactivant WPML ?

Finalement, pouvez-vous mettre à jour votre version de WooCommerce ?

Cordialement,
Andrés

mars 21, 2019 à 1:42 #3405449

genevieveC-3

Bonjour Andres,

Le problème est effectivement causé par le plugin WPML Multilingual CMS.

J'ai désactivé tout les plugins et en pièce jointe, l'image de mon produit section variations AVANT d'activer WPML Multilingual CMS et la 2e image de mon produit APRÈS activation de WPML Multilingual CMS. J'ai également testé avec un autre produit pour ce test soit le 42546

Vous pouvez faire le test par vous-même. Woocommerce, WPML et WP sont tous jours.

mars 21, 2019 à 3:16 #3409469

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de vos commentaires, mais pouvez-vous m'indiquer étape par étape comment reproduire cette situation ?
Comme je vous ai indiqué antérieurement et comme s'affiche sur la capture d'écran antérieur, tout fonctionne correctement lorsque je visite votre produit. Je pense alors, que je travail sur le mauvais produit ou il faut effectuer une procédure en particulier.

Merci de votre aide.

mars 21, 2019 à 4:05 #3411343

genevieveC-3

Étape 1: désactiver votre plugin WPML Multilingual CMS
Étape 2: éditer le produit suivant hidden link
Étape 3: vous rendre dans la section Variations de la section Product data
Étape 4: vous y verrez les 3 variations que l'on peut éditer sans problème.
Étape 5: Réactivez votre plugin WPML Multilingual CMS
Étape 6: retourner sur l'édition du produit à la section Variations de la section Product data
Étape 7: vous y verrez que les variations n'y sont plus pour fin d'édition.

mars 21, 2019 à 4:25 #3412059

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Malheureusement vous êtes en train d'éditer ce produit et je n'ai pas pu y accéder.

1. Entre temps, j'ai visité des autres produits variables et tous fonctionnent correctement. Si le problème n'arrive que sur ce produit, pouvez-vous recréer un nouveau produit ?

2. Pouvez-vous enregistrer votre clé WPML ?

mars 21, 2019 à 4:28 #3412219

genevieveC-3

Je viens de sortir de ce produit. Quel produit avez-vous testé? Vous utilisez que browser? la création d'un nouveau produit n'est pas une solution. Nous avons plus d'une centaine de produits à modifier les prix.

Puis-je envoyer un enregistrement de mon écran?

mars 22, 2019 à 6:59 #3437863

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci, en effet, je peux voir le problème sur le produit indiqué. Par contre, tous les autres produits variables fonctionnent correctement. Je viens d'ajouter trois captures d'écran qui appartient à trois produits différents.

Comme cela n'arrive que dans un produit, je vous recommande de le recréer.
Si cela n'est pas une option pour vous, nous pouvons commencer une procédure de débogage.

Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).
https://wpml.org/documentation/support/debugging-wpml/

mars 22, 2019 à 2:30 #3441351

genevieveC-3

Je préfère régler le problème que de dire à mon client de refaire le produit à chaque fois... Clairement c'est un bug avec votre plugin suite aux updates et ce dernier arrive sur plus d'un produit de mon côté.

En modifiant la première ligne et ajoutant la deuxième, le site a planté:
define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Voici le lien du fichier debug.log: https://pastebin.com/WYkQctfC

mars 22, 2019 à 3:28 #3441927

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de partager votre information de débogage. Par contre, je ne vois pas des erreurs liés à WPML.

Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML est activé. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparaît, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

mars 25, 2019 à 2:28 #3454849

genevieveC-3

Bonjour

Voici réponse aux test:

- Seulement le paquet WPML est activé ainsi que Woocommerce et les variations sont toujours non visibles.
- Les variations ne sont pas plus visibles en changeant pour un thème par défaut.
- Le problème disparait seulement si on désactive WPML.

J'ai enregistré le tout. Avez-vous un endroit où je peux partager l'enregistrement en question?

Geneviève

mars 25, 2019 à 6:06
mars 25, 2019 à 6:08 #3457115

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Geneviève,

Pour investiguer cette situation je viens de vous envoyer un message privé avec des instructions pour créer un site de test.
- Pouvez-vous nous confirmer une fois la migration a été effectué ?
- Pouvez-vous ajouter une liste avec au moins 5 produits avec la même problématique ?

Cordialement

mars 27, 2019 à 8:25 #3475451

genevieveC-3

Bonjour,

J'ai tenté à 2 copier le site mais en vain.

Le problème varie selon les produits et est toujours présent. Essayez avec ces 2 produits: 18026 / 18000

mars 28, 2019 à 6:14 #3477197

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Dans ce cas, pouvez-vous me fournir un site de test ?

Cordialement

Le sujet ‘[Fermé] Édition des variations, le toggle ne s'ouvre pas on ne peut donc pas inscrire d’ est fermé à de nouvelles réponses.