Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 14 réponses, has 2 participants.

Last updated by Jamal il y a 6 months et 2 weeks.

Assigned support staff: Jamal.

Auteur Messages
février 26, 2020 à 8:15 #5568501

alainB-20

Bonjour,

J'ai mis à jour WPML à la dernière version, suite à cette mise à jour j'ai une erreur 404 sur la page d'accueil...

C'est une configuration multi-site. Lorsque je vais sur la page d'accueil kalambay.com/online je devrais être redirigé vers la page kalambay.com/online/fr/ mais ce n'est pas le cas et je me retrouve avec une erreur 404.

Par contre si j'entre manuellement l'adresse kalambay.com/online/fr/ l'accueil s'affiche correctement ! C'est simplement un problème de redirection. J'ai énormément cherché dans les docs/forums mais impossible de corriger le problème... Pouvez-vous m'aider ?

Meilleures salutations

Alain Bruchez

février 26, 2020 à 1:58 #5571813

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Alain,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je n'ai pas pu reproduire cette erreur. Quand je visite hidden link, je suis redirigé vers hidden link

Je dirais donc qu'il s'agit probablement d'un cache de redirection sur votre navigateur, ou que cette erreur se produit pour les visiteurs connectés.

Pourriez vous tester avec un autre navigateur ou une page de navigation privée?

Si le problème persiste, je vous prie de donner plus de détails sur votre site:
- Quelles versions des extensions WPML que vous utilisez?
- Quelle est l'URL du root site de votre installation multisite?
- Pourquoi chisissez vous d'avoir differentes valeurs pour les deux paramètres suivants:
--- SiteURL: hidden link
--- HomeURL: hidden link

Cordialement,
Jamal

février 26, 2020 à 2:35 #5572111

alainB-20

Bonjour Jamal,

Merci pour votre réponse.

J'ai utilisé une extension temporaire pour résoudre le problème. Je l'ai désactivée à l'instant pour que vous puissiez constater le problème.

Je viens de remarquer que j'ai le même problème avec une nouvelle page ...

Lorsque je veux accéder à la page hidden link, celle-ci devrait rediriger vers la page hidden link, mais ce n'est pas le cas, j’ai une erreur 404 qui apparaît...

J'ai vraiment l'impression que j'ai un souci de redirection.

J'utilise la dernière version de toutes mes extensions WPML.

WooCommerce Multilingual -> 4.7.9
WPML Multilingual CMS -> 4.3.8
WPML String Translation -> 3.0.7
WPML Translation Management -> 2.9.5

URL Root : kalambay.com
Site 1 : kalambay.com/online
Site 2 : kalambay.com/byb

Je n'ai pas choisi des valeurs différentes pour "SiteURL" et "HomeURL". Je ne trouve aucun endroit dans ma configuration le Home URL avec /fr/

Meilleures salutations,

ABclic
Alain Bruchez

février 26, 2020 à 3:31 #5572673

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Pourriez vous vérifier si l'option d'utiliser un dossier pour la langue par défaut est configurée, voir cet article https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/configuration-de-la-langue/repertoire-langue-pour-la-langue-par-defaut/

Si, elle est configuré, désactiver la et vérifier si elle corrige le problème.

Sinon, veuillez vérifier sur votre site de test si ce problème apparaît dans les cas suivants:
- Seuls les plugins WPML sont activés. Il nous dira s'il y a un problème d'interaction avec un autre plugin.
- Le thème est défini sur un paramètre par défaut de WordPress, tel que Twenty Fourteen. Il nous dira s'il y a un problème d'interaction avec votre thème.
- Si le problème disparaît, commencez par en activer un à la fois pour déterminer où l'incompatibilité est produite.

février 26, 2020 à 3:50 #5572707

alainB-20

Re,

Alors j'ai tenté de désactiver l'option d'utiliser un dossier pour la langue par défaut.

Le problème est inverse, tous les liens fonctionnent correctement, sauf la page d'accueil qui fait un 404.

Si je mets hidden link, je suis redirigé automatiquement sur https.//kalambay.com/online/fr/ exactement le contraire du problème que lorsque cette option est activée.

Voici une capture de la configuration de "base"

Meilleures salutations,

février 26, 2020 à 5:25 #5573371

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

J'aurais besoin d'accéder à votre site pour vérifier de plus prêt. Si vous êtes d'accord, je vous prie de prendre une sauvegarde de base de données et de partager les accés sur votre prochaine réponse. Votre prochaine réponse serait privé pour les raisons de sécurité.

février 26, 2020 à 5:45 #5573415

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Je viens de désactiver l'option "Utiliser le répertoire pour la langue par défaut" et vider le champ "Fichier HTML" qui contenait /fr et le problème semble être résolu.

Pourriez vous vérifier de votre coté pour confirmer.

février 26, 2020 à 6:24 #5573563

alainB-20

Malheureusment je désires garder le /fr/ .

Car des campagnes de pub on était faite avec ce prefix...

Dans le cas où ce n'est pas possible j'utiliserais un plugin de redirection mais j'aurais voulu eviter cette solution.

De plus si je coche "utiliser le répertoire pour la langue par défaut" le champs est toujours renseigné par "/fr"

Merci de votre réponse

février 26, 2020 à 6:57 #5573859

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Si vous voulez garder /fr/, il faut activer l'option, mais les pages françaises seront tous accessible sous /fr/ (/fr/abonnements au lieu de /abonnements).

Si par contre vous voulez avoir /abonnements /fr/ pour la page d'accueil, il faut désactiver l'option et, en effet, utiliser une extension pour faire la redirection de /fr/ vers /

pour le champs qui contient toujours "/fr", il faudrait qu'il contient un fichier html ou php au lieu de /fr.
Vous pouvez utiliser un fichier redirect.php avec le contenu suivant:

<?php
  
   header( 'Location: <em><u>hidden link</u></em>' ) ;
  
?>

Voir cette réponse de Vincenzo https://wpml.org/forums/topic/directly-redirect-to-language-specific-homepage/#post-585558

Mais dans ce cas toutes les pages françaises seront accessibles sous /fr/

Je reste à votre disposition.

février 26, 2020 à 7:07 #5573893

alainB-20

Je pense que je me suis mal exprimé.

Je désires que toute les pages ont le /fr/

février 26, 2020 à 7:25 #5573921

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Connectez vous par FTP ou utilisez une extension telle que WP File Manager to create a php file in the root folder of your site(where you have wp-config.php, wp-content folder, etc.).
Nommer ce fichier "redirect.php", et utilisez le code suivant dessus:

<?php
   
   header( 'Location: <em><u>hidden link</u></em>' ) ;
   
?>

Testez le en visitant hidden link, elle devrait rediriger vers hidden link

Ensuite activez l'option "Utiliser le répertoire pour la langue par défaut" et sur le champ de la root page ecrivez "redirect.php".
Sauvegardez le permaliens.

Si vous voulez que je le fasse pour vous, vérifier les accés FTP et dites le moi.

février 29, 2020 à 9:10 #5590651

alainB-20

Bonjour,

Pour moi le problème est toujours le même. Il y a un soucis de redirection. J’utilise votre plugin sur tous les sites de mes clients avec la même configuration et je n'ai jamais eu ce problème. Temporairement j'ai activée une extension de redirection afin de rendre le site utilisable. Je vais attendre la prochaine mise à jour en espérant que cela va résoudre le problème.

Merci du temps que vous aveu pris pour moi !

ABclic,

Alain Bruchez

février 29, 2020 à 2:08 #5591681

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Alain,

Je pense que j'ai fait une erreur sur le code du fichier redirect.php que j'ai proposé. Le code que j'ai proposé va malheureusement rediriger les requêtes de la page d'accueil de tous les sites de l'installation vers le site prinicipale comme suit:

- <em><u>hidden link</u></em>           ===>   <em><u>hidden link</u></em>
- <em><u>hidden link</u></em>  ===>    <em><u>hidden link</u></em>

J'ai créé une installation multisite en local pour vérifier une solution et la seule manière avec laquelle j'ai pu arriver à cette redirection:
hidden link ===> hidden link

C'est en utilisant une page WordPress pour la page racine/root et en utilisant une template spéciale pour faire la redirection.

Voici les étapes à suivre sur le site hidden link
1. Créer une template (page-root-redirect.php) sur le thème du site avec le contenu suivant:

<?php

/*
Template Name: Root redirect
*/
wp_redirect( home_url() );
exit;

2. Choisir l'option "Utiliser le répertoire pour la langue par défaut" et utiliser une page WordPress, voir capture attachée(page-racine.png). Il faut d'abord sauvegarder l'option avant de pouvoir créer la page.
3. Lors de la création de la page, choisir la templaète "Root redirect", voir capture attachée.(template-de-page.png).

Cela m'a permis d'avoir cela, voir cette courte video hidden link

Je vous prie de vérifier cette solution sur votre site.

Cordialement,
Jamal

mars 2, 2020 à 7:05 #5596975

alainB-20

Bonjour Jamal,

Merci infiniment d'avoir pris le temps pour effectuer ce test !

Effectivement, cette solution fonctionne. Mais comme j'ai le problème avec une autre page, le problème est à moitié corrigé. Lorsque j'écris hidden link une redirection devrait se faire vers hidden link, mais ce n'est pas le cas, j'ai une erreur 404...

Je ne veux pas vous faire perdre de temps, je vais utiliser le plugin de redirection qui fait bien son travail.

Meilleures salutations,

ABclic, Alain Bruchez

mars 3, 2020 à 3:45 #5609587

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Alain,

Il est attendu que hidden link retourne une erreur 404 si vous avez choisit d'utiliser la langue par défaut sur un répertoire. La seule solution possible et d'utiliser une redirection, avec un plugin ou une configuration sur le serveur(.htaccess).

Si la solution que j'ai proposé corrige le problème de la page d'accueil, je vous prie de marquer ce ticket comme résolu et d'ouvrir un nouveau ticket pour toute autre demande.

Cordialement,
Jamal