Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Our next available supporter will start replying to tickets in about 1.75 hours from now. Thank you for your understanding.

Marqué : 

This topic contains 25 réponses, has 2 participants.

Last updated by Max Kovalenkov il y a 2 months et 1 week.

Assigned support staff: Max Kovalenkov.

Auteur Messages
septembre 23, 2020 à 8:25 #7077329

julienL-44

Bonjour,

Sur mon site hidden link, j'avais déjà ouvert un ticket car j'avais une erreur 404 sur les catégories de la traduction.
Vous m'aviez indiqué d'aller dans Réglages, Permaliens puis de sauvegarder les réglages.
Cela avait réparé le pb mais il revient à chaque fois au bout de quelques jours.
Je suis obligé de resauvegarder à chaque fois.
Y a t il une solution plus durable?

Merci

Cdt

Julien

septembre 23, 2020 à 8:21 #7083917

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour,

Est-ce qu'il y a un façon fiable de reproduire ce comportement?

Quand il existe, est-ce que le problème est aussi visible sûr cette page? hidden link

Ça serait très utile si vous pouviez me fournir l'information du debug.log de WordPress.

Est-ce que vous pouvez ouvrir le fichier wp-config.php, trouver la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content s'il existe le fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans https://pastebin.com/ et me fournir le lien, cela serait très utile (c'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

https://wpml.org/documentation/support/debugging-wpml/

septembre 24, 2020 à 12:43 #7091319

julienL-44

Bonjour,
Merci pour votre réponse.
Non je n'ai pas ce problème sur cette page: hidden link
Le pb est uniquement sur la traduction en NL.

Voici le lien https://pastebin.com/1TjUS8uJ mais j'ai sauvegardé les permeliens et le pb n'y est pas actuellement, il reviendra probablement dans quelques jours.

Cordialement,

Julien

septembre 24, 2020 à 9:15 #7094553

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour,

Merc pour les réponses! Veuillez me faire savoir ici quand cela se répète. Nous pourrons au moins copier le site et essayer de le reproduire sur nos serveurs.

septembre 28, 2020 à 8:01 #7112201

julienL-44

Bonjour,

Ok merci. Pouvez vous laisser svp le ticket ouvert le temps que le pb revienne?

Merci

Cdt

Julien

septembre 28, 2020 à 1:29 #7115265

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour Julien,

Oui le ticket va rester ouvert pendant 2 semaines; après vous allez recevoir un avis par courriel - à ce moment-là il faudrait seulement poster une réponse pour le garder ouvert.

octobre 5, 2020 à 6:43 #7162023

julienL-44

Bonjour,

L'erreur est de nouveau là:
hidden link

Voici le lien pastebin:
https://pastebin.com/7x9UmGB9

Merci

Julien

octobre 6, 2020 à 3:12 #7174505

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour,

Désolé de savoir que le problème est de retour.

Veuillez essayer d'utiliser les options de nettoyage dans WPML > Assistance technique > la page de dépannage > section Nettoyage (depannage.png).

Vous verrez un bouton appelée "Synchroniser les taxonomies de publication".

Vous pouvez également utiliser les boutons Effacer le cache dans WPML et Supprimer les entrées fantômes des tableaux de traduction.

En fait ça pourrait être lié à une incompatibilité avec l'extension No Category Base, comme vous avez écrit ici: https://wpml.org/fr/forums/topic/erreur-404-categories/#post-5718453

Vous avez écrit que lorsque vous le désactivez, l'erreur 404 est corrigée. Est-ce toujours le cas? Si oui, nous pouvons essayer de le reproduire sur un serveur de test et le transmettre à notre équipe de compatibilité.

octobre 7, 2020 à 8:06 #7178771

julienL-44

Bonjour,

Merci pour votre réponse.

Les premières actions dans la section dépannage n'ont pas eu d'effet.

J'ai essayé de désactiver le plugin "No Category base" et cela a résolu le problème. Je l'ai réactivé ensuite et cela fonctionne tjs. Mais pour combien de temps... ;-)?

Cdt

Julien

octobre 7, 2020 à 2:55 #7182639

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour,

Pourriez-vous mettre à jour ces extensions: WPML Multilingual CMS, Yoast SEO Multilingual, WPML Translation Management, WPML String Translation, WPML Media.

Vous pouvez les télécharger tous en même temps dans Extensions > Ajouter > Commercial (plugins-commercial-tab-FR.png).

Ensuite, il y a un lien vers un site de test dans ma réponse privée ci-dessus. J'ai déjà installés WPML, Yoast SEO et No Category base. Veuillez le configurer de la même manière que sur votre site, puis ajouter et traduire une catégorie de la même manière que celle qui a été récemment cassée sur votre site. Nous allons essayer de reproduire ce problème.

octobre 7, 2020 à 3:37 #7183089

julienL-44

Bonjour,

Les extensions étaient déjà présentes et toutes à jour.

J'ai mis à jour sur le site test.

Merci
Cdt

Julien

octobre 7, 2020 à 4:03 #7183381

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Merci! Je vois que "No Category Base" n'est pas encore actif - pourriez-vous l'activer et configurer?

octobre 8, 2020 à 8:33 #7187563

julienL-44

Bonjour,

C'est fait.

Cdt

Julien

octobre 8, 2020 à 3:05 #7191525

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-05:00)

Bonjour,

Merci beaucoup! Pourriez-vous verifier une autre configuration sur votre site? C'est dans Yoast > Réglages SEO > Taxonomies > URL des catégories (yoast-seo-category-setting.png). Quel est le paramètre actuel?

octobre 9, 2020 à 7:56 #7196019

julienL-44

Bonjour,

J'ai "Conserver". Je pense que c'est vous qui m'aviez indiqué de mettre ça et d'installer ensuite le plugin "no category base"

Merci

Julien

Le sujet ‘[Fermé] Erreur 404 sur les catégories’ est fermé à de nouvelles réponses.