Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Mots-clés : 

This topic contains 23 réponses, has 3 participants.

Last updated by Jamal il y a 2 semaines.

Assigned support staff: Jamal.

Auteur Messages
septembre 27, 2019 à 7:35 #4652021

remyL-2

Bonjour,

Je rencontre un problème pour les articles traduits en anglais et en espagnol. J'ai affecté des étiquettes à mes articles en français, mais je ne parviens pas à les affecter à mes versions traduites.
Cette affectation doit-elle se faire automatiquement des articles en français vers les articles traduits ou cela demande-t-il une action manuelle ?
Lors de mes tentatives, des étiquettes se sont créées automatiquement avec des nombres en guise de nom (cf pièce jointe). Pourquoi ces étiquettes sont-elles créées automatiquement ?

Je vous remercie par avance.

Cordialement,

septembre 27, 2019 à 9:00 #4652423

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Si vous ajoutez des étiquettes à vos articles après les avoir déjà traduit, vous devez rafraîchir vos articles originaux et leur traductions pour les mettre à jour.

Pouvez-vous mettre à jour aussi vos traductions ?

Cordialement,
Andrés

septembre 27, 2019 à 9:10 #4652631

remyL-2

Merci pour votre message. Qu'entendez-vous par rafraîchir les articles ?

septembre 27, 2019 à 9:16 #4652651

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Par exemple :
- Ouvrez un article original.
- Ajoutez un espace vide dans le champ de contenu ou le titre.
- Enregistrez.
- Ouvrez sa traduction.
- Enregistrez au 100%.

Est-ce que cela fonctionne ?

septembre 27, 2019 à 9:30 #4652687

remyL-2

Je viens de tester mais cela ne fonctionne toujours pas.
Avant de recevoir votre message j'ai tenté autre chose : J'ai renvoyé en traduction la page qui me posait problème. Non seulement les étiquettes ne se mettent pas à jour mais en plus de cela, mes traductions anglaises et espagnoles sont désormais totalement en français... 🙁

septembre 27, 2019 à 9:40 #4652759

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

Après avoir modifié ces valeurs, essayons le suivant :
- Allez à WPML > Taxonomies translation.
- Vérifiez si l'option "“Update taxonomy hierarchy" est disponible.
- Si c'est le cas, essayez la synchronisation à nouveau.

septembre 27, 2019 à 10:00 #4653013

remyL-2

J'ai bien rajouté la ligne de code à la fin de mon fichier wp-config, mais je n'ai pas l'option "Update taxonomy hierarchy" disponible.
J'ai tenté autre chose entre temps. J'ai supprimé mon article en version anglaise afin de le retraduire depuis zéro. J'ai cliqué sur le + à coté de mon article en français, ce qui m'a ouvert l'outil de traduction classique de WPML. Or il ne me propose que 3 champs à traduire alors que j'ai de nombreux éléments sur ma page qu'il ne semble pas détecter pour la traduction.
Je précise que j'utiliser le divi builder, cela peut il avoir une incidence ?

septembre 27, 2019 à 10:35 #4653479

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

S'il vous plaît, essayez le suivant :
- Ouvrez un article original.
- Ajoutez un espace vide dans un champ créé avec Divi builder.
- Enregistrez.
- Ouvrez sa traduction.
- Enregistrez au 100%.

Cordialement

septembre 27, 2019 à 12:30 #4654119

remyL-2

J'ai déjà effectué cette opération précédemment comme vous me l'avez demandé plus haut. Je viens de le refaire mais cela ne fonctionne toujours pas. Est ce normal que l'on me propose uniquement de traduire le titre, un extrait et un champs spécial ? Le contenu de mon site ne semble pas détecté par WPML.

septembre 27, 2019 à 1:18 #4654419

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

septembre 30, 2019 à 8:15 #4662817

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos identifiants. Malheureusement ils ne fonctionnent pas, pouvez-vous le vérifier et éditer le message privé antérieur ?
Cordialement

septembre 30, 2019 à 8:20 #4662833

remyL-2

Je viens de modifier l'accès, vous pouvez réessayer, cela devrait fonctionner.

septembre 30, 2019 à 9:19 #4663283

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci, je viens de rentre dans votre site et je n'arrive pas à afficher les champs de traduction pour le contenu ajouté avec Divi. Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, J'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter. Les accès FTP sont sur le menu Sandbox, si vous en avez besoin.
hidden link

Une fois vous êtes sur le Bureau du site, installez votre thème Divi et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe de compatibilité.

Note: vous n'avez qu'installer le thème nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Cordialement

septembre 30, 2019 à 12:54 #4664677

remyL-2

Je viens d'installer le thème Divi, j'ai crée un article en Français. Ensuite j'ai créé des étiquettes de Pays et des catégories et leurs traductions respectives par le biais du traducteur de taxonomie.
Enfin, j'ai traduit mon article en anglais. Résultat, la page s'est bien traduite, mais j'ai toujours des numéro en guise d'étiquettes et mes catégories sont restées en français.

septembre 30, 2019 à 1:56 #4665121

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je ne suis pas sur de vous comprendre, pouvez-vous m'indiquer quelle situation voulez vous analyser, est-ce que vous avez deux problèmes différent dans votre site ?