Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 2.01 hours from now. Thank you for your understanding.

This topic contains 7 réponses, has 2 participants.

Last updated by joanneB-2 il y a 5 mois.

Assigned support staff: Noman.

Auteur Messages
mai 7, 2019 à 9:19 #3755831

joanneB-2

Hi,
I tried to follow the solution from the documentation you've sent me. I think I've found the right place, but when I click on "translations" nothing happens. So, I still have my problem.

Thanks for your feedback.

mai 7, 2019 à 9:28 #3755901

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

1. You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions. You can download it from your account: https://wpml.org/account/downloads/

2. In most cases a string is not fully enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set this variable in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

3. After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

4. Then please go to WPML >> String Translation and you will see newly enabled values at top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press Save button.

Thank you

mai 8, 2019 à 11:11 #3765825

joanneB-2

Hi,
I updated all WPML plugins, and set the MaxInputVars as indicated. So now, I've found the String Translations i'm looking for in the "Translate texts in admin screens" (as you see in attachment). But, when I go to WPML > String translations, I don't find them in the list to translate. What's wrong?

mai 9, 2019 à 7:12 #3773581

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

mai 9, 2019 à 12:05 #3775945

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have used alternate method to enable string translation as your site maxinputvars value is still same ‘1000’ as you can see in the attached screenshot.

I have fixed this issue by adding the following XML code:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_attitude-wpl">
            <key name="wpl_cta_button_text" /></key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and added button translation from WPML >> String Translation and now button showing correct translation in frontend as you can see in the attached screenshot.

Thank you

mai 9, 2019 à 12:28 #3776129

joanneB-2

Thank you for that!
Could you please do the same for the link?

mai 12, 2019 à 6:57 #3792489

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for delay, my off days are Friday and Saturday and now I am available and reply time will be shorter from now.

- I have fixed this issue by updating the following XML code:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_attitude-wpl">
            <key name="wpl_cta_button_text" />
            <key name="wpl_cta_button_url" /></key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section.
- I changed the string default language to French language by selecting “[theme_mods_attitude-wpl]wpl_cta_button_url” checkbox and selected new language from ‘Change the language of selected strings’ dropdown as you can see in the attached screenshot.
- Then I added button URL translation from WPML >> String Translation and now button showing correct translation in frontend as you can see in the attached screenshot.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Thank you

mai 13, 2019 à 8:58 #3796271

joanneB-2

It works perfectly now! Thanks a lot for your help!