Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur rencontre des problèmes de traduction sur la page d'accueil après la mise à jour WPML. Solution: - La page d'accueil et sa traduction n'était pas liées, il faut les lier. - La configuration de la page d'accueil n'était pas correcte sur Réglages->Lecture

L'utilisateur a préféré recréé la page depuis le début. Relevant Documentation: https://wpml.org/faq/how-to-link-already-translated-pages/

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 10 réponses, has 2 participants.

Last updated by annev-3 il y a 1 year.

Assigned support staff: Jamal.

Auteur Messages
novembre 19, 2019 à 10:53 #4970941

annev-3

Bonjour
J'ai traduit la page d'accueil de mon site FR en anglais, et j'ai bien deux pages en français et en anglais. Mais après mise à jour, dans mon menu admin/ Ma page en Français indique "modification de la traduction " et tous les champs sont vides et à recréer...
Si je passe en anglais, ma page Home en anglais existe bien mais n'a pas de traduction associée.
Cela pose un problème au niveau réglages/lecture qui indique que la page d'accueil n'existe pas ou n'est pas traduite.

URL de (mon) site Internet où le problème apparaît : hidden link
et en anglais : hidden link

Merci !

novembre 19, 2019 à 12:33 #4972069

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Nous avons recemment rencontré des erreurs similaires sur certaines hébergeurs(wordpress hébèrgé), est ce que votre site est hébèrgé ainsi? Chez quel hébèrgeur?

Je suggère de faire le suivant pour corriger le problème.
1. Ouvrez la homepage anglaise pour la lier à la page française en suivant cet article https://wpml.org/faq/how-to-link-already-translated-pages/
2. Aller sur Réglages->Lecture, changer la page d'acceuil et sauvegarder, puis remettre la page d'accueil est sauvegarder.

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

novembre 19, 2019 à 12:46 #4972257

annev-3

Bonjour
Merci beaucoup, mon hébergeur est privé : Syswing
Je ne trouve pas la page en français lorsque je fais la connexion...

novembre 19, 2019 à 12:50 #4972267

annev-3

Et l'icone de la page d'accueil en Français ne peut pas être modifié, il est grisé

novembre 19, 2019 à 1:42 #4972787

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pourriez vous m'accorder un accès temporaire sur votre site pour y voir de plus prés, j'ai activer l'espace privé pour partager les accès en toutes sécurité.

Cordialement,
Jamal

novembre 19, 2019 à 3:21 #4973837

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour les accès. Vous n'avez pas pu choisir la page d'accueil comme page originale de "Home" par ce qu'une traduction est en cours pour la page voir capture attachée.

Veuillez compléter cette traduction en premier lieux, ensuite supprimer l'ancienne page Home. Si le problème n'est pas complétement corrigé, veuillez faire le 2eme point suggéré:
2. Aller sur Réglages->Lecture, changer la page d'acceuil et sauvegarder, puis remettre la page d'accueil est sauvegarder.

Si le problème n'est pas corrigé, je me reconnecterais pour voir si je peux corriger le problème.

Cordialement,
Jamal

novembre 19, 2019 à 4:07 #4974121

annev-3

Merci, j'ai suivi votre process mais la page en anglais ne s'affiche plus

novembre 19, 2019 à 5:09 #4974627

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

J'ai vérifié sur votre site que les pages d'accueil sont bien liées. Que le paramètrage de la page d'accueil est correcte.
Quand je change le paramètrage de la page d'accueil, ça ne change pas à la première tentative, et ensuite ça s'enregistre.
Le problème persiste malgré ma modification, je pense donc qu'il s'agit soit d'un conflit de compatibilité ou d'un problème sur le serveur.

Pour vérifier la première hypothèse, veuillez vérifier sur votre site de test si ce problème apparaît dans les cas suivants:
- Seuls les plugins WPML sont activés. Il nous dira s'il y a un problème d'interaction avec un autre plugin.
- Le thème est défini sur un paramètre par défaut de WordPress, tel que Twenty Fourteen. Il nous dira s'il y a un problème d'interaction avec votre thème.
- Si le problème disparaît, commencez par en activer un à la fois pour déterminer où l'incompatibilité est produite.

Pour vérifier la deuxième hypothèse, je vous prie de suivre les instructions sur mon message privé(NOVEMBRE 19, 2019 À 5:09) pour migrer votre site sur notre plateforme.

Cordialement,
Jamal

novembre 19, 2019 à 5:25 #4974701

annev-3

Merci Jamal mais je ne peux pas faire tout ça malheureusement ! Je n'ai pas assez de temps ...
Je vais supprimer la page et la recréer... merci

novembre 19, 2019 à 5:26 #4974735

annev-3

My issue is resolved now. Thank you!