Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 16 réponses, has 2 participants.

Last updated by Andrés Il y a 1 an et 11 mois.

Assigned support staff: Andrés.

Auteur Messages
octobre 28, 2019 à 12:58 #4839671

davidB-169

En installant une copie de mon site capsunshop.ch en localhost, je constate de nombreux "Image : lien URL" à traduire que je ne trouve pas sur le site en ligne. Ces liens me posent problème depuis un moment.

Je peux les traduire depuis WPML -> Traduction de chaînes mais je dois constamment les mettre à jour manuellement dans la version Allemand et Anglais des pages concernées. Le fichier joint montre les liens disponibles dans la page "Bienvenue" en "localhost" qui ne sont pas disponible sur le site en ligne. Que faire?

Merci par avance
David

Capture d’écran 2019-10-28 à 13.52.22.jpg
octobre 28, 2019 à 4:04 #4841465

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour David,

Bienvenue à l'assistance technique de WPML.

Si le problème n'arrive que sur votre site en local, il peut se trouver que vous avez eu une soucis pendant votre migration. Vous pouvez ressayer et vérifier si le problème persiste.

Or, si après avoir essayé la migration, ces images ne se trouvent pas dans votre page mais elle affiche toujours ceux champs des traductions, vous pouvez essayer de la rafraîchir :
- Aller au Bureau > Pages.
- Ouvrez la page d'édition de la page originale.
- Assurez-vous que la traduction n'est pas "en cours" (icône en forme de roue).
- Si c'est le cas, ouvrez la traduction en cours, marquez-la comme Terminé au 100%
- Ceci devrait changer le status à "traduit" (icône crayon).
- Essayez de faire une légère modification de contenu dans la page originale, par exemple, ajoutez un espace vide dans le texte.
- Éditez la traduction encore une fois
Est-ce que cette fois pouvez-vous traduire vos contenus ?

Cordialement,
Andrés

octobre 29, 2019 à 8:47 #4844783

davidB-169

Merci André

Je suis repassé par la "Gestion de traduction" et me suit attribuée les pages à traduire. Certains liens sont apparûts dans les page ENG et DE. Mais il y a encore des liens de certains boutons qui ne sont pas visible et que je dois à chaque fois mettre à jour directement dans la page ENG et DE. Sous traduction de chaîne je ne le trouve pas non plus.

Même question pour le plug-in MailChimp for WP (MC4WP) pour traduire le formulaire. Je dois chaque fois entrer le short code du formulaire de la langue correspondante dans la page manuellement. Y-a-t-il un moyen de faire autrement? Je penses que cela revient au problème qui est ouvert chez votre collaborateur Jamal pour traduire le barre supérieur.

Merci pour votre prochaine réponse.
David

Capture d’écran 2019-10-29 à 09.20.29.jpg
Capture d’écran 2019-10-29 à 09.20.59.jpg
Capture d’écran 2019-10-29 à 09.22.35.jpg
octobre 29, 2019 à 3:16 #4849219

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Dans ce moment, je ne suis pas sur de comprendre votre problème. Pour isoler le problème, je vous prie d'ouvrir un nouveau ticket par rapport au MC4WP.

1. En retournant au problème initial, pouvez-vous confirmer d'avoir effectué les tests de ma réponse antérieur ?

2. Aussi, pouvez-vous m’éclaircir votre problématique ? Initialement j'ai cru avoir compris que votre problème était lié aux champs que s'affichent dans l'éditeur de traduction, par contre, dans votre dernière réponse il semble que le problème est que vous n'arrivez pas à trouver des champs à traduire.

Au même temps, si vous croyez que ce problème est lié au ticket ouvert avec mon collègue Jamal, vous pouvez attendre et vérifier si la solution de votre ticket initial, résout aussi votre problème.

J'attends votre confirmation.

Cordialment

octobre 30, 2019 à 9:23 #4853751

davidB-169

Bonjour,
Le problème est que certains liens ne sont pas visible dans la page traduction. Je dois les corriger manuellement dans les pages en ALL et en ANG.

J'ai procédé comme vous l'avez dit. J'ai modifié la page en FR ce qui indique des mises à jour en ENG et DE (image 01). Je clique sur le symbole roue ce qui ouvre la page de traduction (image 02). Mais certains liens ne sont pas présents. Par exemple dans l'image 02, sous LEARN MORE il devrait y avoir un lien. Mais il n'y ai pas. Je valide et fait Appliquer et Enregistrer et fermer. Le symbole indique maintenant un crayon comme quoi la traduction est terminée.
Les liens qui posent problèmes semblent liés à des modules créées à l'aide d'un plug-in appelé Essential Addons (voir images 03, 04, 05).
Si je les traduis depuis Traduction de chaînes, la modification ne semble pas être prise en compte et il faut chaque fois corriger les liens directement dans la page ENG et DE.

Merci de votre aide.

01.jpg
02.jpg
03.jpg
04.jpg
05.jpg
06.jpg
octobre 30, 2019 à 11:10 #4854861

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre explication et vos captures d'écran, finalement je comprends votre situation. 😀

Votre extension Essential Addons n'est pas dans notre liste de compatibilité. Cela n'implique pas forcément qu'il n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.
https://wpml.org/documentation/plugins-compatibility/

Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter. Les accès FTP sont sur le menu Sandbox, si vous en avez besoin.
hidden link

Une fois vous êtes sur le Bureau du site, installez votre extension et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe de compatibilité.

Note: vous n'avez qu'installer le extension Essential Addons nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Cordialement

octobre 31, 2019 à 8:38 #4861591

davidB-169

Bonjour Andrés

J'ai copié une partie du site de démonstration avec UpdraftPlus sur votre serveur de test. Mais j'ai l'impression qu'il va falloir modifier certaines tables de la base de données pour y accéder. Pouvez-vous le faire?

octobre 31, 2019 à 9:24 #4861945

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci pour votre aide, mais l'idée est de créer un nouveau site de test et pas de faire une migration :
- Installez l'extension Elementor et Essential Addons.
- Créez une page.
- Ajoutez le module que vous pose problème.
- Traduisez-le.
Est-ce que cette fois il fonctionne ?

Nouveau site de test :
hidden link

octobre 31, 2019 à 6:48 #4867001

davidB-169

Merci Andrés

J'ai installé le thème OCEAN, ainsi que Elementor et Essential Addons. J'ai créé la page de bienvenue (basic sans image). Vous constaterez que si certains liens sont traduisibles, ceux des boutons EN SAVOIR PLUS et l'icône du EA Team Member Social Profil par exemple ne sont pas traduisible dans la page de traduction.
Ainsi si je fais une mise à jour dans la page en FR, je dois aller remplacer manuellement les liens dans les pages ENG et ALL de mon site...

Merci par avance de votre aide
david

Capture d’écran 2019-10-31 à 19.42.50.jpg
Capture d’écran 2019-10-31 à 19.42.16.jpg
Capture d’écran 2019-10-31 à 19.42.09.jpg
novembre 1, 2019 à 7:55 #4868603

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide, David. Par contre :

1. Lorsque j'ouvre la page d'accueil, elle est vide. Avez-vous ajouté le module dont vous souhaitez faire traduction ?

2. Est-ce que le thème Ocean est absolument nécessaire pour reproduire cette situation ? Si ce n'est pas le cas, je vais l'effacer pour nous concentrer sur votre extension Essential Addons.

Cordialement

elementor-vide.png
novembre 1, 2019 à 8:46 #4868869

davidB-169

Bonjour

Si vous allez sous Pages -> Toutes les pages vous devriez trouver la page de test avec les modules à traduire.

Je laisserais le thème Océan à mon avis dans un premier. Mais à vous de voir.

Capture d’écran 2019-11-01 à 09.44.35.jpg
novembre 4, 2019 à 7:24 #4878261

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide. Je viens de visiter votre page de test et je vois plusieurs modules ajoutés et aussi leur traductions disponibles.

Comme tout semble de fonctionner correctement, pouvez-vous m'indiquer un seul module en particulier que ne fonctionnent pas ?

Comme votre plugin n'est pas compatible, et s'il s'agit de plusieurs modules, contactez à l’auteur de l'extension pour faire partie de notre programme de compatibilité Go-Global:
https://wpml.org/documentation/theme-compatibility/go-global-program/

novembre 6, 2019 à 8:08 #4895463

davidB-169

Merci

Par exemple le bouton EN SAVOIR PLUS et l'icône du chariot, le lien URL (LINK) n'est pas traduisible dans la page de traduction. Voir les print screen. Ces deux modules sont créées par le plug-in ESSENTIAL ADDONS pour ELEMENTOR: hidden link

Amicalement
David

Capture d’écran 2019-11-06 à 09.02.47.jpg
Capture d’écran 2019-11-06 à 09.02.31.jpg
Capture d’écran 2019-11-06 à 09.00.04.jpg
novembre 6, 2019 à 10:44 #4897115

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci pour les détails de contact que vous nous avez fourni et pour nous attirer l’attention sur ce sujet, David. Je vais envoyer les détails à notre Équipe de Compatibilité des thèmes et plugins, et ils vont contacter l'auteur.

S’il vous plaît, cette procédure peut prendre du temps car il dépend aussi de la vitesse que l'auteur réponds à nos efforts pour lui contacter. Il serait très important si vous essayez de contacter l'auteur en lui demandant de nous répondre.

Vous pouvez aussi lui demander de faire partie de notre programme Go Global, cela pourrait lui permettre de faire son thème compatible avec WPML. https://wpml.org/documentation/theme-compatibility/go-global-program/. Il pourrait aider à accélérer ce processus.

Cordialement

novembre 8, 2019 à 6:05 #4915781

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Je viens d'avoir un premier retour :
- Cherchez le fichier wp-content/plugins/essential-addons-for-elementor-lite/includes/Classes/WPML/Eael_WPML.php.
- Cherchez la ligne 24.
- Remplacez :

        $widgets['eael-creative-button'] = [
            'conditions' => ['widgetType' => 'eael-creative-button'],
            'fields' => [
                [
                    'field'       => 'creative_button_text',
                    'type'        => __('Creative Button: Text', 'essential-addons-elementor'),
                    'editor_type' => 'LINE',
                ],
                [
                    'field'       => 'creative_button_secondary_text',
                    'type'        => __('Creative Button: Secondary Text', 'essential-addons-elementor'),
                    'editor_type' => 'LINE',
                ]
            ],
        ];

Avec :

$widgets['eael-creative-button'] = [
            'conditions' => ['widgetType' => 'eael-creative-button'],
            'fields' => [
                [
                    'field'       => 'creative_button_text',
                    'type'        => __('Creative Button: Text', 'essential-addons-elementor'),
                    'editor_type' => 'LINE',
                ],
                [
                    'field'       => 'creative_button_secondary_text',
                    'type'        => __('Creative Button: Secondary Text', 'essential-addons-elementor'),
                    'editor_type' => 'LINE',
                ],
	            'creative_button_link_url' => array(
		            'field'       => 'url',
		            'type'        => __( 'Creative button URL', 'essential-addons-for-elementor-lite' ),
		            'editor_type' => 'LINK'
	            ),
            ],
        ];

- Essayez à traduire encore une fois le module Creative Button.
Est-ce que cette fois il fonctionne ?

Si ce n'est pas le cas, essayez encore cette procédure après avoir effectué les modification du code :
https://wpml.org/fr/forums/topic/image-lien-url-non-disponible-pour-traduction/

Cordialement