Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Je tente de traduire une image avec WPML Media Translation mais l'image n'est pas traduite et est toujours la version FR affichée.

La solution: - Allez au Bureau > Pages. - Ouvrez la page d'édition de la page originale. - Assurez-vous que la traduction n'est pas "en cours" (icône en forme de roue). - Si c'est le cas, ouvrez la traduction en cours, marquez-la comme Terminé au 100% - Ceci devrait changer le status à "traduit" (icône crayon). - Essayez de faire une légère modification de contenu dans la page originale, par exemple, ajoutez un espace vide dans le texte. - Éditez la traduction encore une fois

Documentation: https://wpml.org/documentation/getting-started-guide/media-translation/

This topic contains 28 réponses, has 2 participants.

Last updated by regisc-2 il y a 1 mois et 1 semaine.

Assigned support staff: Andrés.

Auteur Messages
septembre 3, 2019 à 5:57 #4506749

regisc-2

Je tente de : traduire une image avec WPML media translator

URL de (mon) site Internet où le problème apparaît :
hidden link

Je m'attendais à voir :

la bannière "colique" (ruban rose) traduit comme la version que j'ai mise dans le WPML media translator (meme ruban mais écrit "colic")
À la place, j'ai obtenu : l'image n'est pas traduite et est toujours la version FR affichée

septembre 4, 2019 à 4:57 #4508309

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Pouvez-vous m'indiquer d'une manière détaillé comment a été ajouté l'image dans la page originale ?

2. Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '256M');

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'à la valeur maximale possible.

Note: le minimum WP Memory Limit requis pour WPML (afin de fonctionner correctement avec un thème par défaut WordPress et sans autres extensions) est 128M.

Cordialement,
Andrés

septembre 4, 2019 à 12:46 #4511161

regisc-2

Bonjour,
J’ai fait les modifications demandées et modifié chez mon hébergeur le memory_limit de PHP à 256mo, puis ça a fonctionné une l’image colique, mais ça ne fonctionne à nouveau plus pour d’autres (dans ce cas j’ai tenté avec l’image Sirop guimauve, dont l’image anglaise est Marshmallow syrup)
Pour la manière dont l’image est ajoutée, c’est juste un module image dans divi

septembre 4, 2019 à 2:09 #4511855

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je ne suis pas sur de comprendre si vous souhaitez traduire le titre de l'image ou si vous êtes en train d'ajouter une image différent.

Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter. Les accès FTP sont sur le menu Sandbox, si vous en avez besoin.
hidden link

Une fois vous êtes sur le Bureau du site, installez votre thème Divi et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe de compatibilité.

Note: vous n'avez qu'installer le thème nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Cordialement

septembre 4, 2019 à 2:22 #4511991

regisc-2

j'ai ajouté l'image dans la page sample et je l'ai traduite dans WPML media translator par son équivalent traduit, mais ça ne semble pas fonctionner est-ce que ca aide?
ce que je veux faire c'est utiliser une image différente (la version FR est un ruban avec le nom du produit écrit en FR dedans, et la version EN est le meme ruban mais le nom écrit en EN dedans)

septembre 4, 2019 à 4:02 #4512735

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide. J'ai visité la page "Sample Page" est elle n'a pas été traduite, une fois c'est fait, elle affiche une image différent. Pouvez-vous le vérifier ?

Si cela fonctionne dans notre site de test, le problème pourrait venir de votre site. Pouvez-vous vérifier essayer le suivant :
- Allez au Bureau > Pages.
- Ouvrez la page d'édition de la page originale.
- Assurez-vous que la traduction n'est pas "en cours" (icône en forme de roue).
- Si c'est le cas, ouvrez la traduction en cours, marquez-la comme Terminé au 100%
- Ceci devrait changer le status à "traduit" (icône crayon).
- Essayez de faire une légère modification de contenu dans la page originale, par exemple, ajoutez un espace vide dans le texte.
- Éditez la traduction encore une fois
Est-ce que cette fois pouvez-vous traduire vos contenus ?

septembre 4, 2019 à 4:07 #4512745

regisc-2

ok merci j'ai fait tout ce que vous avez dit.
c'était bien terminé (icone crayon) mais j'ai malgré tout édité en ajoutant un espace inutile puis sauvé et là à présent l'image est mise à jour....
qu'est-ce que ça signifie? y a-t-il un problème de cache? (j'avais tenté de vider le cache de WP Super Cache, ainsi que testé sur un autre navigateur).

septembre 4, 2019 à 4:15 #4512785

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait ! 🙂
Je ne pense que le problème a été associé au WP Super Cache. Par contre, j'imagine que vous avez traduit votre image après avoir traduit votre page, donc, il fallait rafraîchir sa traduction.

Cordialement

septembre 4, 2019 à 4:17 #4512843

regisc-2

en fait non
j'ai déjà désactivé WP super cache, et le problème persiste. Le seul moyen est de, à chaque fois que je traduis une image, aller dans l'édition de la traduction de la page et faire appliquer (meme sans rienh changer) et là ça apparait sinon rien ne change

septembre 4, 2019 à 4:19 #4512845

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

En effet, comme j'ai fait mention dans ma réponse antérieur, comme vous avez traduit vos pages avant de traduire votre image, il faut suivre cette procédure.

Cordialement

septembre 4, 2019 à 4:21 #4512849

regisc-2

ah ok donc ça n'est pas un bug? dès qu'on traduit des images avec media transator, rien ne s'applique à moins qu'on fasse éditer la page sans rien changer ?? ça ressemble quand même à un bug ou c'est une faiblesse ergonomique non? quand on traduit une image on s'attend à ce qu'elle apparaisse, pas à devoir faire une manipulation technique vide de sens?enfin l'important est que ça fonctionne :;)

septembre 4, 2019 à 4:28 #4512885

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Lorsque vous traduisez une page, WPML garde des contenus et des images dans une sorte de "image virtuelle" de traduction, un paquet. Or, si vous décidez de changer d'image dans votre traduction, il faut rafraîchir la traduction de ce paquet pour le faire comprendre que vous avez change cette image.

Je comprends aussi l’embêtant de cette situation, mais par design, le but est de traduire des images, catégories, étiquettes, puis, traduire votre page.

Je vous invite à solliciter une demande de fonctionnalité dans le lien à continuation, cela pourrait nous aider à améliorer notre produit :
https://wpml.org/suggest-a-new-feature-for-wpml/

Cordialement

septembre 5, 2019 à 1:36 #4519615

regisc-2

ok merci
cependant, sur les autres pages de mon site, cette manipulation ne fonctionne pas.
exemple:
hidden link
j'ai traduit l'image ronde du thym (en anglais : THYME) et ensuite fait éditer la page et sauvegarder, mais malgré ça, l'image n'est pas mise à jour...
j'ai supprimé WP super cache aussi.
une idée?

septembre 5, 2019 à 3:15 #4520401

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Il s'agit aussi des images ajoutés avec le même module de votre thème Divi et avec la même procédure dont nos avons discuté antérieurement ?

Si ce n'est pas le cas, pouvez-vous reproduire ce comportement sur le site de test ?
hidden link

septembre 5, 2019 à 3:21 #4520493

regisc-2

oui,
meme procédure, module image