Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 1.14 hours from now. Thank you for your understanding.

This topic contains 9 réponses, has 2 participants.

Last updated by benoitF-4 Il y a 1 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
mai 7, 2019 à 1:29 #3758443

benoitF-4

Bonjour, voilà sur le front end je peux accéder à la version française de mes commandes (screen 1) mais en espagnol lorsque je clique sur "mis pedidos" je vois la page d'accueil mon compte (screen2).

Il semblerait que le soucis viens de : /wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php

Peux être faut t'il remplacer : $query_vars[ $endpoint_translation] = $endpoint_translation;

par : $query_vars[ $endpoint ] = $endpoint_translation;

Bonne journée

mai 7, 2019 à 4:17 #3760391

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je viens de créer un serveur de test, pourriez vous reproduire cette erreur? J'escaladerais votre suggestion à nos développeurs.
Utilisez le lien suivant pour vous connecter hidden link

Cordialement,
Jamal
Assistance WPML

mai 8, 2019 à 8:13 #3764453

benoitF-4

Bonjour, merci pour cela.
J'ai réussi à reproduire le bug sur l'interface de test.
Celui-ci est présent pour la langue française : hidden link
Tentez de cliquer sur "my orders" vous verrez, rien ne se passe.

Sur mon site en production ce bug est présent sur la langue espagnole.
Bon courage !

mai 8, 2019 à 10:48 #3765719

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre effort. Selon moi l'erreur n'est pas produite, comme vous pouvez le voir sur la video du lien ci dessous. Il fallait juste que je sauvegarde les permaliens sur Réglages->Permaliens.
hidden link

Il se peut qu'il y est quelque chose à corriger sur votre serveur. Pourriez vous élaborer sur le problème que vous rencontrez! Qu'est ce qui vous a obligé a implémenter le code de votre premier message?
Je reste à votre disposition.

Cordialement,
Jamal

mai 8, 2019 à 11:59 #3766351

benoitF-4

Merci pour votre réponse.
J'ai approfondi mes recherches et regardez, si j'enléve la traduction "mis-pedidos" dans string translation > WP Endpoints orders (screen 1)
La page va correctement s'afficher ! (screen 2) mais le liens sera moitier anglais motier espagnol : hidden link

mai 8, 2019 à 12:30 #3766561

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je viens de refaire votre test, j'ai remis la pas en Espagnol à "mis-pedidos".
Ensuite j'ai trouvé sur Traduction de chaînes qu'il y a déjà un endpoint enregistré avec la même chaîne. Voir captures attachées.

Même après suppressions de ces chaines, une d'entre elle revient toujours(mis-peidos.png), comme si elle est réenregistrée!

Je ne trouve encore pas ce qui peut poser ce problème. Je continue mes investigations et je reviens vers vous le plutôt possible.

Cordialement,
Jamal

mai 9, 2019 à 11:32 #3775605

benoitF-4

Bonjour,
Tout à fait et cela se produit également pour la traduction en Français.
Sur votre sandbox cela se produit également;

Bon courage, tenez moi au courant
Bonne journée

mai 10, 2019 à 9:04 #3782475

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je pense que ce problème survient juste sur votre site, nous n'avons pas pu le reproduire sur le serveur de test. Voir la page française, elle est généré sans problème
hidden link

Puisque je n'ai pas pu trouver la cause de cette erreur, j'ai escaladé le ticket à notre équipe 2nd Tier pour plus d'investigations, je reviens vers vous le plutôt possible.

Cordialement,
Jamal

mai 28, 2019 à 10:18 #3905581

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Selon notre 2nd Tier, cette erreur serait prinicpalement causé par un plugin de sécurité ou un plugin de cache.

Pourriez vous purger les caches et désactiver tout plugin de cache et de sécurité, purger aussi le cache de votre navigateur et essayer une deuxième fois.

Cordialement,
Jamal

mai 28, 2019 à 12:01 #3906573

benoitF-4

Hello, i finaly choice to keep the english slug for the spanish users, it's not realy important and it's work.
thanks