Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

Double article slug with Yoast SEO and Domain per language option activated

Solution (include the steps to follow here):

In file:

wp-content/plugins/sitepress-multilingual-cms/inc/wpseo-sitemaps-filter.php

I replaced line 48 from:

if ( $path && ( ! $home_url_parsed['path'] || $home_url_parsed['path'] != $path ) ) {

To:

if ( $path && ( ! $home_url_parsed['path'] || $home_url_parsed['path'] != $path ) && ! preg_match( '@'.$path.'$@', $home_url )) {

To avoid extra "path" adding.

Relevant Documentation:

https://onthegosystems.myjetbrains.com/youtrack/issue/wpmlcore-2604

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 18 réponses, has 4 participants.

Last updated by claraG il y a 4 years et 11 months.

Assigned support staff: Marcin.

Auteur Messages
janvier 22, 2016 à 10:22 #794084

claraG

Bonjour,

Depuis que je suis passée sur la dernière version du plugin Yoast SEO, j'ai une incompatibilité avec WPML qui engendre des problèmes sur mes permaliens.

Toutes les URLs de mes articles ont des alias en double, ce qui génère des erreurs 404 sur toutes mes pages.
Mes permaliens sont réglés sur le nom de l'article.

Exemples : hidden link au lieu de hidden link

Le seul moyen pour que mes liens marchent est soit de désactiver le plugin Yoast SEO, soit de désactiver WPML Multilingual CMS
Deux options que ne peux pas me permettre car j'ai absolument besoin de ces deux plugins.

Je suis sur la dernière version de WordPress et des deux plugins.

J'ai déjà ouvert un ticket chez Yoast, et après différents essais, nous n'avons pas réussi à résoudre le problème. Ils m'ont donc conseillé de vous contacter.

J'espère que vous pourrez m'aider. Je peux vous fournir des accès admin temporaire sur WordPress et sur le serveur si besoin.

Merci
Clara

janvier 22, 2016 à 1:45 #794324

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Clara,

Bienvenue à l'assistance technique de WPML.

De votre capture d'écran je pense que votre installation WordPress se trouve dans un repertoire /blog/ et peut-être cela peut créer des inconvenientes. Néanmoins, j'ai besoin de plus d'information pour cerner la cause et trouver une solution.

1. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
http://wpml.org/faq/provide-debug-information-faster-support/

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress. S'il vous plaît, lisez ces instructions:
https://wpml.org/documentation/support/debugging-wpml/
Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

Cordialement,
Andrés

janvier 25, 2016 à 9:35 #795325

claraG

Bonjour,

Comme demandé, j'ai indiqué les informations de débogage dans le champs prévu à cet effet.
Je vous confirme également que WordPress se trouve dans un répertoire /blog/ car il est géré sur le même serveur que d'autres applications non gérées sur WordPress. C'est comme cela depuis le début et nous n'avions eu aucun problème jusqu'à présent.

J'ai bien remplacé la ligne define(‘WP_DEBUG’, false); par les deux que vous avez indiquées.

Envoi, vous trouverez ci-dessous le lien pastebin avec le contenu du fichier debug.log
http://pastebin.com/ZS6hV4En

Merci
Clara

janvier 25, 2016 à 12:40 #795568

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de vos informations, Clara.

1. Est-ce que vous pouvez suivre cette procedure dans le cas qu’il s’agit d’un problème de cache:

1.1. Faites un backup complet de votre site.
1.2. Allez à :
- WPML > Assistance technique.
- Cliquez sur le lien de 'dépannage'.
- Cliquez sur le bouton 'Effacer le cache dans WPML’.
- Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'.
- Cliquez sur le bouton 'Configurer les informations linguistiques’.

3. Est- ce que vous pouvez vérifier si cette situation arrive quand:
- Tous les plugins que n'appartient pas à WPML sont désactivés. Cela va nous dire s’il y a un problème d’interaction avec un autre plugin.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

J'attend vos résultats,
Andrés

janvier 25, 2016 à 1:26 #795607

claraG

Bonjour,

J'ai suivi les étapes de dépannage, ça n'a rien changé.
Je vous ai dit dès mon premier message que le problème vient d'une incompatibilité avec Yoast SEO.
Si je reste sur mon thème et que je désactive Yoast SEO, tout fonctionne correctement donc le problème vient de ce plugin. J'ai déjà ouvert un ticket chez Yoast, et après différents essais, nous n'avons pas réussi à résoudre le problème. Ils m'ont donc conseillé de vous contacter.

Merci
Clara

janvier 25, 2016 à 5:22 #795830

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Est-ce que vous pouvez décrire de manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/"

janvier 25, 2016 à 7:38 #795928

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

En effet, j'ai pu reproduire ce comportement, Clara. Néanmoins, il n'est pas present si on utilise l'option des différents langues par repertoire.
Est-ce que vous pouvez installer l'extension Duplicator et créer une copie de votre site avec lui ? Du contraire, est-ce que vous pouvez me fournir un autre moyen de sauvegarde pour plus de tests en local ?
http://wordpress.org/plugins/duplicator/

D'un autre coté, je vous recommande d'effacer les extensions suivantes car elle ne sont plus nécessaires avec votre version de WPML :
- WPML Translation Analytics
- Installer

Cordialement,
Andrés

janvier 26, 2016 à 2:48 #796665

claraG

Bonjour,

Je ne souhaite pas utiliser de langues par répertoire, je fois conserver l'option actuelle.
J'ai supprimé les extensions qui n'étaient plus utiles.
J'ai téléchargé Duplicator mais je dois mettre à jour la version de PHP pour que cela fonctionne. Ce sera OK pour demain matin (heure de Paris).

Je vous renvoie un ticket dès que j'ai créé la copie du site avec Duplicator.

Merci
Clara

janvier 26, 2016 à 8:27 #797060

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Parfait, Clara.
J'attend vos nouvelles.
Andrés

janvier 28, 2016 à 1:46 #798856

claraG

Bonjour,

J'ai enfin pu créer la copie du site avec Duplicator.
Vous pouvez vous connecter 🙂

Merci
Clara

janvier 28, 2016 à 3:40 #798994

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Clara,

Je viens de remettre votre cas à notre support de deuxième niveau car il nous faut plus de temps de débogage. Je vous tiens au courant dès que j'ai des nouvelles.

Bonne journée,
Andrés

février 1, 2016 à 10:28 #801051

claraG

Bonjour,

Toujours aucune nouvelle de mon problème ?
J'ai aussi reçu un message du support de Yoast qui confirme le soucis de votre côté :

"Hi Clara,

Thank you for your patience while we investigated this issue. After reviewing the support request started with WPML, it appears this is due to a specific setting in WPML and they sent the issue to their second level support team. As this looks like it's something that WPML will need to fix on their side, we'll monitor the WPML support request for an outcome."

Merci pour votre retour,
Clara

février 2, 2016 à 11:14 #802299

Marcin

Dear Clara,

I am Marcin from 2nd tier support and I try to solve this issue.

Regards,
Marcin

février 2, 2016 à 11:40 #802335

claraG

Hi Marcin,

Here is a previous message you sent me (I don't know why it does not appear on the flow):

"Dear Clara,

I am Marcin from 2nd tier support and I hope I solve your issue. There was some problem with languages configuration.

I go to WordPress Admin -> WPML -> Languages and I re-save domains.

My changes:

- I removed last "/" from domains - it will be added and is not necessary.
- I changed german home, because we can not use protocol in this field.

Could you confirm, that now all works?

Regards,
Marcin"

Unfortunately, it still does not work. I always have problem with my article URL when Yoast SEO Premium is activated.

Thanks,
Clara

février 2, 2016 à 2:03 #802575

Marcin

Dear Clara,

I made a mistake, when I comment this thread previously and I decided to delete my answer, because it do not solve this issue.

I suppose we have small bug in WPML.

I made a quick fix on your site. In file:

wp-content/plugins/sitepress-multilingual-cms/inc/wpseo-sitemaps-filter.php

I replaced line 48, from:

if ( $path && ( ! $home_url_parsed['path'] || $home_url_parsed['path'] != $path ) ) {

To:

if ( $path && ( ! $home_url_parsed['path'] || $home_url_parsed['path'] != $path ) && ! preg_match( '@'.$path.'$@', $home_url )) {

And now all looks good. Could you confirm it works now?

And I escalate this issue to our developer team.

Regards,
Marcin