Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 9 réponses, has 2 participants.

Last updated by Andrés il y a 4 mois et 3 semaines.

Assigned support staff: Andrés.

Auteur Messages
mai 30, 2019 à 8:22

julienT-11

Bonjour,

Je tente de traduire le contenu de mon site avec WPML et l'éditeur de traduction et il se passe quelque-chose de vraiment bizarre.

Je ne peux utiliser l'éditeur de traduction, dès qu'il est activé le site devient super lent et la page est vide quand j'essaye d'accéder à la page WPML > Gestionnaire de traductions.

J'ai essayé de désinstaller complètement WPML, mais ça ne change rien.

mai 31, 2019 à 5:20 #3927781

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et tout semble de fonctionner correctement. Je suis allé à WPML > Gestionnaire de traductions et j'ai créé un traducteur pour l'utilisateur S2**** car il n'existait pas des autres.

Pouvez-vous mous me fournir plus de détailles ?

Cordialement,
Andrés

mai 31, 2019 à 1:48 #3930997

julienT-11

Bonjour Andrés,

Effectivement je ne sais pas ce que vous avez fait mais le site est beaucoup plus rapide et la page WPML > Gestionnaire de traductions s'affiche maintenant correctement. Alors qu'avant elle était vide et ne contenait aucun contenu et je ne pouvais donc rien faire. Pas une page blanche mais comme si l'onglet gestionnaire de traduction ne contenait simplement rien du tout. Je voyais la barre d'administration en haut et celle de gauche.

Ce n'est pas évident de fournir plus d'informations, j'avais seulement installé les plugins les uns après les autres : d'abord WPML, j'ai ensuite fait la configuration initiale pour configurer les langues. Ensuite J'ai installé et activé string translation et finalement translation manager. Et le site s'était mis à être très lent après l'activation du translation manager.

J'arrive maintenant à traduire mes pages, mais il se passe encore quelque-chose de bizarre. La première fois que je traduit ma page de français vers anglais, ma page anglaise est bien créé, mais la page originale est dupliquée 5 fois dans la langue d'origine (français).

Merci pour votre aide !

mai 31, 2019 à 1:56 #3931059

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci Julien, mais je ne suis pas sur de comprendre. Je viens de traduire la page "Camions neufs" et tout semble correct. Pouvez-vous le vérifier ou m'indiquer les étapes nécessaires à suivre ?

Cordialement

mai 31, 2019 à 2:02 #3931079

julienT-11

Voici une vidéo pour vous montrer, ce sera plus clair.
On dirait que c'est lors de l'enregistrement de la page qu'elle est dupliquée finalement.
hidden link

mai 31, 2019 à 3:08 #3931483

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de la vidéo. 🙂
Pouvez-vous désactiver WPML et essayer d'enregistrer votre page à nouveau ?

mai 31, 2019 à 3:12 #3931489

julienT-11

Ma page ne se duplique pas quand WPML est désactivé.

Mais par contre, comme je le montre dans la vidéo on dirait que la page est dupliqué pour chaque champs personnalisés que je décide de changer l'option pour copier ou traduire dans la metabox des options de traduction wpml.

Si je change les options pour 5 champs personnalisés et que j'enregistre avec le bouton "appliquer", j'obtiens 5 copie de ma page.

mai 31, 2019 à 3:14 #3931493

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je n'arrive pas à reproduire cette situation dans mon site de test. Essayons le suivant :
Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML et ACF Pro sont activés. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement

mai 31, 2019 à 3:47 #3931865

julienT-11

Alors j'ai fait plusieurs test sur une copie de mon site :

1 - Avec seulement les plugins WPML et ACF le problème persiste

2 - J'ai essayé ensuite en désactivant Advanced Custom Fields Multilingual seulement. Le problème n’apparaît plus.

J'ai déjà travaillé sur plusieurs sites avec ce thème et WPML et en général je n'installe pas le plugin ACF Multilingual, et je n'ai jamais d'erreurs.

3 - En changeant le thème Twenty Nineteen mais en gardant tous les plugins le problème ne survient plus.

Donc nous avons 2 cas qui résolvent le problème.
Mais le plugin ACF Multilingual est seulement pour aider à traduire les groupes de champs c'est bien ça ? Donc je n'en ai pas vraiment besoin.

mai 31, 2019 à 3:57 #3931895

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de partager vos résultats. 🙂
Notre extension ACF Multilingual vous aide à traduire des groupes et des champs personnalisés. Vous pouvez toujours tenté de le désactiver et voir si la traduction de vos ACF fonctionne correctement.

Si ce n'est pas le cas, je viens de créer une installation WordPress de test. Vous pouvez y accéder en cliquant le lien suivant :
hidden link

Une fois vous êtes sur le Bureau du site, installez votre ACF Pro et essayez de reproduire cette situation. De cette manière, je peut transmettre ce site de test à notre Équipe de compatibilité.

Note: vous n'avez qu'installer le extension ACF Pro nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.