Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Mots-clés : 

This topic contains 3 réponses, has 2 participants.

Last updated by Jamal il y a 4 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
juillet 3, 2019 à 9:56 #4134333

Harold

J'ai créé un nouveau custom post type.
Je créé un nouveau post dans la langue par défaut.
Lorsque que je traduis ce contenu le sélecteur de langue n'est pas disponible en front pour voir la traduction.
Pour cela il faut que j'aille sauvegarder dans les paramètres Custom taxonomies à chaque fois (le paramètre est déjà sur "translate" avant de sauvegarder).
Je voudrai que ce paramètre soit pris en compte pour chaque nouveau post (je ne peux pas aller sauvegarder le paramètre à chaque fois).
Merci de votre retour

URL de (mon) site Internet où le problème apparaît :

Je m'attendais à voir :

À la place, j'ai obtenu :

juillet 3, 2019 à 10:07 #4134485

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Vous pouvez configurer le mode de traduction pour le Custom Post Type sur WPML->Paramètres->Traduction de type de contenu.

J'espère que cela répond à votre question. Sinon, je vous prie de m'accorder un accès temporaire sur votre site pour pouvoir vérifier cela de plus prés.

Pourriez vous aussi fournir les informations de débogage en suivant cet article.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Jamal
Assistance WPML

juillet 3, 2019 à 10:30 #4134919

Harold

Pouvez-vous être plus précis ? Je n'ai pas Paramètres dans WPML.

juillet 3, 2019 à 3:48 #4138005

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Voir la capture attachée pour le paramètrage de la traduction des custom post types. Vous n'avez peut être pas le menu paramètres, par ce qu'il s'agit d'une installation Multisite our que vous manquez les permissions nécessaires.
https://wpml.org/documentation/support/wpml-admin-capabilities/

Vous pouvez aussi configurer le mode de traduction des custom post types à travers un fichier de configuration sur votre thème ou à travers WPML->Paramètres->Configuration XML personnalisée (Onglet), si bien sur vous avez le menu Paramètres.
https://wpml.org/documentation/support/language-configuration-files/#custom-types

Je reste à votre disposition.

Cordialement,
Jamal

Le sujet ‘[Fermé] La configuration de traduction des custom post type n'est pas conservée’ est fermé à de nouvelles réponses.