Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Missing pages and error 404 when trying to visit pages in the other languages.

Solution: This might happen if you have set WP_HOME and WP_SITEURL in your wp-config.php file. WPML uses by default the value stored for these settings in the database -> in the table wp_options. WPML will not scan and use the value that you have overridden in wp-config.php

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 5 réponses, has 3 participants.

Last updated by George Botsev il y a 4 years et 9 months.

Assigned support staff: George Botsev.

Auteur Messages
avril 18, 2016 à 10:32 #863261

evelineS

Sur mon site, wordpress est installé dans un dossier "wordpress". J'ai configurer wordpress comme ceci : Adresse du site:"www.lindicepensable.ch" Adresse d'installation de wordpress:"www.lindicepensable.ch/wordpress" directement dans wp-config.php.
Dans "index.php" j'ai "require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' );".
Tout fonctionnait bien jusqu'à l'installation de WPML. mes url's enyoyaientt bien à l'adresse "lindicepensable.ch" sans le sous dossier "/wordpress". Maintenant lorsque je sélectionne une autre langue, celui-ci envois le visiteur à "www.lindicepensable.ch/wordpress/en" au lieu de "lindicepensable.ch/en" pour la version anglaise. Une fois sur la page d'accueil correspondant à la langue, les autres lien fonctionnent bien sans "/wordpress/".
Merci de bien vouloir me donner un petit coup de main.

avril 18, 2016 à 12:22 #863388

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Eveline,

Bienvenue à l'assistance technique de WPML.

1. C'est probable que l'option ' Langues différentes dans les répertoires' ne fonctionne pas avec cette configuration. Pouvez-vous essayer l'option 'Nom de la langue ajouté comme paramètre' et vérifiez si cette situation change ?

2. Est-ce que vous pouvez incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 256M ?
Vos valeurs actuelles sont:
- MemoryLimit 128M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Parfois, ces ajustements sont bloqués par votre service d'hébergement et vous devez leur contacter directement. N'hésitez pas à incrémenter ces valeurs jusqu'au maximum permis.

Note: le minimum WP Memory Limit requis pour WPML pour fonctionner correctement avec un thème par défaut WordPress et sans d'autres extensions est 128M.

Cordialement,
Andrés

avril 19, 2016 à 6:09 #863988

evelineS

Merci pour votre réponse rapide.

1. J'ai changé l'option pour "Nom de la langue ajouté comme paramètre", mais cela ne fonctionne pas mieux. J'ai toujours le dossier d'installation qui apparait dans l'url et qui génère cette erreur 404.

2. J'ai pu changer MemoryLimit au niveau de mon hébergeur et l'ai augmenté jusqu'à 256mo.
J'ai également changé le WP Memory Limit pour min 128M et max 256M, J'éspère que cela suffit.

Pas de changement pour le point 1.

avril 19, 2016 à 8:36 #864095

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Est-ce que vous pouvez décrire de manière détaillée comment répliquer ce comportement et aussi comme vous avez configuré votre installation pour diriger de wordpress vers la racine du site ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/"

avril 20, 2016 à 8:07 #865058

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de vos informations. J'ai pu répliquer ce comportement lié à la page d'accueil, néanmoins sur les pages traduites comme 'Édition', cette configuration fonctionne normalement.

Je vais transmettre votre cas à notre support de deuxième niveau car il a besoin de plus de temps de débogage.

Merci de votre comprehension.
Andrés

avril 20, 2016 à 1:04 #865411

George Botsev
Supporter

Languages: Anglais (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello, I am George from second tier support.

I visited your site and fixed the issue.

The problem was this:
in wp-config.php:
define('WP_HOME','hidden link...................ch');
define('WP_SITEURL','hidden link....................ch/wordpress/');
in the database:
homeurl:hidden link....................ch/wordpress/
siteurl:hidden link....................ch/wordpress/

WPML reads only the value that is supplied in the database, so fixing this - fixed the issue.

avril 26, 2016 à 2:22 #869375

evelineS

Merci beaucoup !!
Cela a résolu plus d'un problème !! Avant je n'avais pas l'autorisation de voir des prévisualisation de page ou d'article.