Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 16 réponses, has 3 participants.

Last updated by P-Derathe il y a 4 years et 6 months.

Assigned support staff: Andrés.

Auteur Messages
février 28, 2016 à 4:43 #825321

P-Derathe

I am trying to: Change the flags

URL of (my) website where problem appears:
hidden link

I expected to see: Parameters in the "flag column"

Instead, I got: nothing ! 😉

Steps to duplicate the issue: always

Merci pour votre aide

Salutations

Pascal

février 29, 2016 à 7:18 #825486

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

Bienvenue à l'assistance technique de WPML 🙂

1. Est- ce que vous pouvez vérifier si cette situation arrive quand:
- Tous les extensions qui n'appartient pas à WPML sont désactivés. Cela va nous dire s’il y a un problème d’interaction avec un autre plugin.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress. S'il vous plaît, lisez ces instructions:
https://wpml.org/documentation/support/debugging-wpml/
Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

Cordialement,
Andrés

mars 2, 2016 à 4:56 #828444

P-Derathe

Bonjour Andres

Pour commencer voici le "debug" de WPML
[removed]

1° ) Quand j'ai désactivé tous les plugins sauf "WPML Multilingual CMS" les "flags" n'apparaissent toujours pas dans la page "edit languages" hidden link

2°) je n'ai pas d'autre theme disponible que DIVI (qui est un theme réputé cf hidden link ) disponible pour ce site

3°) j'ai modfié le wp-config.php et mis les lignes
define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

4°) Il existe un debug.log dans wp-content
je le copie ci-dessous car iol est assez court (et que je ne comprends pas ce que "pastebin.com" signifie)

[02-Mar-2016 16:52:29 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'TB_Autocomplete' does not have a method 'activation_hook' in /var/www/html/pica.net/wp-includes/plugin.php on line 525
[02-Mar-2016 16:52:29 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'TB_Autocomplete' does not have a method 'deactivation_hook' in /var/www/html/pica.net/wp-includes/plugin.php on line 525

Salutations

Pascal Derathé

mars 3, 2016 à 8:56 #828881

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

Merci de vos informations.

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/"

Cordialement,
Andrés

mars 3, 2016 à 12:02 #829080

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Malheureusement, il semble qu'il existe un problème avec vos identifiants WordPress, pouvez-vous les vérifiez et ajouter aussi les identifiants FTP ?

Merci de votre aide,
Andrés

mars 3, 2016 à 1:39 #829199

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide, Pascal.

J'ai installé une copie de votre site en local et j'ai pu afficher correctement le bouton de changement des drapeaux. Cependant je peux voir clairement le problème sur votre site.

En regardant la copie du fichier debug.log que venait avec cette copie, j'observe cet erreur constant du jour d'hier:

02-Mar-2016 20:35:35 UTC] PHP Fatal error:  Call to private method WPML_Language_Resolution::get_referrer_language_code() from context 'SitePress' in xxx/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2328

Néanmoins, cet erreur n'est plus present sur mon installation.

Je voudrais accéder à votre information de debug et constater si cette erreur est toujours presente dans votre installation et pour cela j'ai besoin de votre information FTP.

J'attend votre retour. Le prochain message sera privé.

Cordialement,
Andrés

mars 4, 2016 à 12:10 #830095

Yvette
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/Madrid (GMT+02:00)

Bonjour.

Andrés est en vacances et je vais gérer votre billet jusqu'à son retour .

Je demande votre patience pendant que je me informer sur le problème et de trouver le temps de travailler sur ce billet parmi mes autres tâches existantes .

Vous pouvez préférer attendre Andrés pour revenir le lundi , s'il vous plaît laissez -moi savoir si tel est le cas .

Je vous remercie.

mars 4, 2016 à 1:15 #830164

P-Derathe

Bonjour Yvette
Si Andres revient lundi 8 mars, ça peut attendre son retour

Cordialement

Pascal

mars 7, 2016 à 8:42 #831316

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

J'espere que vous avez eu un excellent weekend. Je reste à l'attente de la création de une compte FTP pour continuer.

Bonne journée,
Andrés

mars 7, 2016 à 9:16 #831364

P-Derathe

Bonjour Andres

Je n'oublie pas, mais mon technicien a eu un souci familial et a dû s'absenter.. dès qu'il revient (demain j'espere) on crée le compte FTP

Cordialement

Pascal

mars 7, 2016 à 9:34 #831384

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je suis désolé de cette situation, Pascal.
Je laisse votre prochain message marqué comme privé.

Cordialement,
Andrés

mars 11, 2016 à 8:41 #835542

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

Je suis désolé mais j'ai besoin de votre aide. J'ai désactivé et effacé vos extension WPML et WPML Sticky Links et maintenant je n'ai peux pas télécharger des nouvelles copies:
1. Si j'essai de les télécharger depuis la section de plugins, je sui renvoyé vers un repertoire /uploads/.
2. Si je le fait par FTP, ils ne sont pas reconnu par WordPress.

Pouvez-vous télécharger des nouveaux copies pour ces deux extensions?

Merci de votre aide.
Cordialement,
Andrés

mars 11, 2016 à 2:22 #835878

P-Derathe

Hello Andres

Je viens de reinstaller wpml 3.3.6 et Stycky links

mars 14, 2016 à 9:39 #836930

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

J'espère que vous avez eu un bon weekend.

Après cette manipulation votre problème semble d'être résolu, désormais je peux accéder aux téléchargement des drapeaux depuis l'édition de langues de WPML. Est-ce que c'est votre cas aussi ?

Cordialement,
Andrés

mars 14, 2016 à 1:35 #837206

P-Derathe

Bonjour Andres

Il semble que la réinstallation de WPML ai résolu le probleme car je peux désormais gérer les drapeaux dans l'interface de gestion de WPML.

Cordialement

Pascal