Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur n'avait pas la traduction de son dernier article sur le blog anglais. Solution: L'utilisateur avait une mauvaise configuration des pages blogs, après rectification des soucis liée à la page blog et au sélecteur de langue. Il faudrait configurer l'option " Copier la date de publication vers les traductions" sur WPML->Paramètres->Synchronisation des publications et des pages.

Marqué : 

This topic contains 9 réponses, has 3 participants.

Last updated by Jamal il y a 6 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
février 26, 2019 à 4:26 #3246100

alinam-2

Je tente de : traduire en EN un post / article que je viens d'écrire en FR

URL de (mon) site Internet où le problème apparaît :
hidden link

Je m'attendais à voir ma page traduite et publiée dans le blog après avoir validé la traduction.

À la place, j'ai obtenu :
1. l'adresse URL du site n'est pas modifiée / traduite, comme c'était le cas avant la dernière MAJ (type polinacouture.com/en/?p=55555)
2. dans le tableau de bord / articles / en anglais, le post traduit en EN est indiqué comme "brouillon" alors que la traduction est intégralement faite

février 27, 2019 à 6:27 #3248554

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

- Allez au Tableau de bord > articles.
- Cliquez sur le sélecteur de langue de la barre supérieur et passez à l'anglais.
- Ouvrez votre traduction.
- Publiez-le.
Est-ce que cette fois il fonctionne ?

Cordialement,
Andrés

février 27, 2019 à 12:34 #3250113

alinam-2

Bonjour,
quand je fais cela, d'abord, je vois l'article traduit en anglais avec le statut brouillon (image issue39a).
Quand je clique sur "modifier", il me signifie que je n'utilise pas le traducteur WPML (image issue39b)
Si je force la publication, il est bien marqué comme "publié", mais n'apparait pas dans la page de blog:
hidden link
Avant, quand je validais la traduction, il était automatiquement publié dans le blog, d'ailleurs, l'article que j'avais traduit précédemment ne date que du 11 février ... je ne sais pas où il met l'article en fait .... pourtant, les 2 articles sont bien liés dans le commutateur de langue ...
Cordialement,

février 28, 2019 à 2:17 #3255660

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Andrés est en congé, je suis Jamal, et je vous aiderais à trouver une solution.

Il me semble que la page hidden link est filtré par la catégorie par la catégorie "the-magazine", quand j'essaye de basculer vers le français en utilisant le sélecteur de langue, le lien semble pointer sur hidden link mais je suis redirigé vers la page d'accueil.

Je pense que le blog français sur hidden link n'est pas filtré par catégorie. Le sélecteur par contre pointe sur la page anglaise hidden link
Je dirais donc qu'il y a un souci de traduction de page qu'il faut régler. Le sélecteur de page française pointe sur la page anglaise, le sélecteur sur la page anglaise pointe sur une autre page.

Cela étant peut être different du fait que le post français et anglais n'ont pas la même date de publication. Mais cela devrait être paramétré sur WPML->Paramètres.
Pourriez vous m'accorder un accès temporaire à votre site pour voir cela de plus près. J'ai activé l'espace prive pour cet effet.

hidden link

Cordialement,
Jamal
Assistance WPML

février 28, 2019 à 2:41 #3255869

alinam-2

Bonjour,
Je vous les ai déjà communiqués via le post ci-dessous et vous venez de vous connecter sur mon site il y a quelques minutes
je me demande finalement si les pb ne sont pas liés .....
https://wpml.org/fr/forums/topic/les-mises-a-jour-de-medias-ne-sont-pas-dupliques-sur-la-traduction/
Sinon, pour précision: j'ai renommé le blog en magazine via le menu. Faudrait peut-être essayé de refaire le menu EN en re-choisissant blog?
En tout cas, tant que ces 2 pb ne sont pas résolus, je n'interviens pas sur le site
Cordialement,

février 28, 2019 à 3:33 #3256268

alinam-2

Bonjour,
je viens de remarquer que tous les liens dans ma boutique en EN, toutes les catégories étaient "cassées" ... ce qui vaut aussi pour les posts !

février 28, 2019 à 3:34 #3256269

alinam-2

je ne vois pas trop ce qui a pu faire cela, si ce n'est pas les mises à jour des derniers jours

février 28, 2019 à 3:57 #3256395

alinam-2

My issue is resolved now. Thank you!

février 28, 2019 à 4:02 #3256448

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pour la date qui n'a pas été synchronisée entre l'article originale et sa traduction, il faudrait configurer l'option " Copier la date de publication vers les traductions" sur WPML->Paramètres->Synchronisation des publications et des pages.
Je n'ai pas changé ce paramètre, je vous laisse décider si vous vouliez l'utiliser ou non.

Pour le problème de sélecteur de langue, j'ai édité la page en ne rien changeant, j'ai enregistré la traduction, puis j'ai "Effacer le cache dans WPML" sur WPML->Assistance Technique->Dépannage.
Le problème me semble maintenant résolu, l'article est bien présent sur la page blog sur les deux langues. Pourriez vous vérifier de votre coté.

Je reste à votre disposition.

Cordialement,
Jamal
Assistance WPML

février 28, 2019 à 4:15 #3256475

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Je n'ai pas pu lire votre dernier message, alors que j'étais entrain de vous répondre. Le ticket a été réouvert par l'occasion. Je vais le marquer comme résolu. N'hésitez pas à le réouvrir, si vous jugiez que mon assistance n'a pas aider.

Cordialement,
Jamal
Assistance WPML