Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 7 réponses, has 2 participants.

Last updated by jamieA-2 il y a 2 ans et 3 mois.

Assigned support staff: Yvette.

Auteur Messages
août 10, 2017 à 5:58 #1339605

jamieA-2

Bonjour !

J'ai plusieurs taxonomie personnalisé.
J'ai déja traduit les termes de chacune de mes taxonomie (voir img1)

Dans mes post, j'utilise le champs ACF taxonomies.
J'ai traduit mon groupe de champs ACF en anglais. Lorsque je duplique un post en anglais (duplicata) le contenu des autres champs ACF se duplique bien, mais pas le contenu de mes champs de type Taxonomie (voir img2, img3, img4).

Pouvez-vous m'aider ?

Merci !

août 10, 2017 à 7:43 #1339687

Yvette
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/Madrid (GMT+01:00)

Bonjour.

Je vais vous aider. Je voudrais tout d'abord m'assurer d'avoir compris le problème. Je comprends que lorsque vous doublez une publication, les champs ACF sont présents, mais l'affectation / la valeur n'est pas copiée.

Cela peut être dû aux options de translation que vous avez définies pour ces champs.

Si vous allez dans la section Configuration du contenu multilingue de votre publication d'origine, pouvez-vous voir quelles valeurs d'option de traduction sont définies pour ces fichiers?

Si vous souhaitez que le champ soit présent et que la valeur soit copiée - les options de traduction doivent être définies sur "Copier". (Voir image) D'après ce que vous décrivez, je soupçonne qu'ils sont actuellement configurés sur "Translate".

Voici plus sur ce sujet:
hidden link

J'attends vos commentaires.

août 10, 2017 à 7:50 #1339695

jamieA-2

Bonjour Yvette,

Oui, vous avez bien compris le probleme.
Le probleme se produit uniquement pour les champs de type Taxonomie.

Je joints une image de la configuration du contenu multilingue de la publication. L'option copier est bien sélectionner.

merci 🙂

août 11, 2017 à 7:26 #1339961

Yvette
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/Madrid (GMT+01:00)

Bonjour et merci,

Veuillez également poster une capture d'écran de:

1. la définition ACF originale et traduite de ce domaine.

2. l'option de traduction pour le champ système associé.

3. la manière dont cette valeur apparaît dans la vue éditeur de la publication d'origine où la valeur est attribuée ainsi que la vue éditeur de l'article traduit où la valeur est manquante.

Je vais ensuite essayer de reproduire le problème sur mon propre système

Merci

août 11, 2017 à 1:35 #1340278

jamieA-2

Merci Yvette,

Je ne suis pas certains d'avoir joint toutes les bonnes captures d'écran. S'il vous manque quelque chose n'hésitez pas.

img 1 : Mon champs ACF en francais
img2 : Mon chaps ACF en anglais
img3 : Les configuration de traduction des taxonomie
img 4 : Mes configuration de traduction pour les publications personnalisé
img5 : Comment s'affiche le champs dans l'édition du mon post en francais
img6 : Comment s'affiche le champ dans l'édition de mon post en anglais
img7 : L'option de traduction pour ce champs

Merci 🙂

août 11, 2017 à 2:23 #1340332

Yvette
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/Madrid (GMT+01:00)

Merci bien!

(1) l'information technique de l'installation
Se il vous plaît suivez les instructions : http://wpml.org/faq/provide-debug-information-faster-support/

(2) l'accès temporaire à votre système
Je demande si vous pouvez faciliter l'accès à votre système temporairement ( wp-admin et FTP ) . Si ça pouvais être un système de test où le problème a été reproduit - mieux. Vous trouverez les champs nécessaires pour faciliter un tel accès dans la zone juste en dessous des commentaires lorsque vous laisser votre prochaine réponse. L'information sera privée. Cela signifie que les données seront visibles seulement entre vous et moi.

août 13, 2017 à 4:56 #1340994

Yvette
Supporter

Languages: Anglais (English ) Espagnol (Español )

Timezone: Europe/Madrid (GMT+01:00)

Bonjour.

Je vous remercie pour l'information du système, que je vois maintenant, j'aurais dû demander plus tôt. Il semble que vous n'avez pas installé ou activé le plugin WPML + ACF.

Installez et activez le plugin requis pour que WPML fonctionne avec ACF. J'espère que cela résoud votre problème.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Vous pourriez également noter que vous n'avez pas encore augmenté la quantité minimale de mémoire PHP attribuée à WordPress à partir des 40M par défaut. Le minimum requis pour une opération WPML normale est de 128M.
https://wpml.org/home/minimum-requirements/

Vous pourriez également faire cela. Permettez-moi de savoir s'il y a encore des problèmes après avoir effectué ces deux actions.

août 14, 2017 à 12:11 #1341635

jamieA-2

Ca fonctionne !

Merci !