Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : Je n'arrive pas à avoir la barre des langues (drapeau) dans la barre du menu.

La solution: - Allez à WPML > Languages > Menu language switcher. - Sélectionnez l'option pour afficher le sélecteur dans votre menu.

Documentation: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/ https://wpml.org/documentation/getting-started-guide/translating-menus/

This topic contains 7 réponses, has 2 participants.

Last updated by Andrés il y a 2 mois et 4 semaines.

Assigned support staff: Andrés.

Auteur Messages
juillet 17, 2019 à 11:56

misonaM

Bonjour

Je n'arrive pas à avoir la barre des langues (drapeau) dans la barre du menu. Et pourtant j'ai bien paramétré WPML.

Site : hidden link

juillet 18, 2019 à 5:03 #4234989

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et vous n'avez pas sélectionnez l'option pour afficher le sélecteur dans votre menu ( capture 1 ) et vous n'avez pas traduit votre menu ( capture 2 ).

Une fois, vous sélectionnez une option d'affichage dans WPML > Languages > Menu language switcher, tout fonctionne correctement ( capture 3 ).

Je vous recommande de suivre les liens suivants pour traduire votre menu et ajouter un sélecteur de langue:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/
https://wpml.org/documentation/getting-started-guide/translating-menus/

Cordialement,
Andrés

juillet 18, 2019 à 9:34 #4236777

misonaM

Bonjour

Merci de votre réponse. J'ai bien paramétrer la partie langues (voir capture33), aussi la partie menu (voir capture44), et j'ai toujours une seule langue qui apparait(voir capture55).

juillet 18, 2019 à 10:48 #4237665

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait, on avance doucement. Cette situation arrive car vous n'avez pas toujours traduit vos pages, une fois soit fait, les drapeaux dans des autres langues vont apparaître.

Cordialement

juillet 18, 2019 à 10:56 #4237807

misonaM

La home page est bien traduite voir capture

juillet 18, 2019 à 11:45 #4238201

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Votre page d'accueil affiche des signes plus en face, cela veut dire que la page n'a pas été traduite. Lorsque une page est traduite, elle affiche un crayon ( c'est le cas pour la page no title ).

Pouvez-vous traduire votre page d'accueil en suivant notre tutoriel ?
https://wpml.org/documentation/getting-started-guide/

juillet 18, 2019 à 1:23 #4239059

misonaM

Problème résolu, le + et le crayon ne s'affichait pas avant, je crois que c'est un problème de cache - Merci pour votre aide

juillet 18, 2019 à 3:08 #4239971

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait ! 🙂
Belle journée.