Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 8 réponses, has 2 participants.

Last updated by Andrés il y a 2 ans et 9 mois.

Assigned support staff: Andrés.

Auteur Messages
mars 3, 2017 à 3:06 #1221966

cedricB-11

Bonjour,

Les drapeaux des autres langues ne s'affichent pas sur mon site.

La langue par défauts est "L'anglais" j'ai donc juste le drapeau anglais d'affiché pourtant dans le backoffice wordpress j'ai bien les 5 autres langues qui déroulent lorsque je survol avec la souris.

Faut-il absolument que toutes les pages du sites soient traduite dans une langue pour le drapeau de celle-ci s'affiche ou cela est dû à un paramétrage?

Pour information je n'ai traduit aucune pages du site, juste quelques mots pour voir.

Merci d'avance.

mars 3, 2017 à 3:21 #1221973

cedricB-11

J'ai effectué un test, l'affichage fonctionne en "Main Menu" mais pas en "Top Bar Menu"

Merci d'avance.

mars 3, 2017 à 4:07 #1222006

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Ne ne suis pas sûr de comprendre votre situation, mais le sélecteur de langue de WPML vous offre deux options:
- Cacher la langue: le drapeau va s'afficher seulement s'il existe toujours une traduction.
- Lien vers l'accueil de la langue pour les traductions manquantes.

Avez-vous traduite les pages où vous voudriez afficher le sélecteur de langue ? Si c'est le cas, et le sélecteur n'affiche toujours pas le drapeau, est-ce que vous pouvez suivre cette procédure :

1. Faites un backup complet de votre site.
2. Allez à :
- WPML > Assistance technique.
- Cliquez sur le lien de 'dépannage'.
- Cliquez sur le bouton 'Effacer le cache dans WPML’.
- Cliquez sur le bouton 'Supprimer les entrées fantômes des tableaux de traduction'.
- Cliquez sur le bouton 'Configurer les informations linguistiques’.

Cordialement,
Andrés

mars 6, 2017 à 12:50 #1223239

cedricB-11

Bonjour,

Merci pour votre réponse, pour être plus précis le selecteur de langues affiche uniquement l'anglais lorsque je le place dans le top bar (Les autres drapeux ne se déroulent pas en dessous du drapeau anglais) par contre lorsque je le place dans le main menu il affichent bien toutes les langues (les autres drapeaux se déroulent bien en dessous du drapeau anglais).

Merci d'avance.

mars 6, 2017 à 1:47 #1223307

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Je viens de visiter votre site mais malheureusement je n'arrive pas à visualiser votre sélecteur de langue. Pouvez-vous l'ajouter à nouveau ?

mars 6, 2017 à 5:54 #1223616

cedricB-11

Bonjour,

D'accord, je viens de l'ajouter.

Pour une question de confidentialité, pouvez-vous supprimer votre imprimécran du site.

Merci.

mars 7, 2017 à 8:04 #1223972

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Je viens de supprimer la première capture d'écran.

D'un autre côté, le problème vient de votre thème. Il ne permet pas d'afficher de menu hover dans le barre supérieur. Pouvez-vous aller à WPML > Languages > Options du sélecteur de langue > CSS additionnel et ajouter le CSS à continuation comme une solution temporaire :

.top-bar .menu .sub-menu {
    display: block;
    position: absolute;
    z-index: 99999;
    background: #000;
    padding: 1em 2em;
}

.menu-item-has-children:hover .top-bar .menu .sub-menu {
    display: block;
}

.top-bar .menu .menu-item-has-children li.wpml-ls-item {
    display: block;
    float: none;
    padding-left: 0;
}

Documentation:
https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/configuration-de-la-langue/selecteur-de-langue-personnalise/

mars 7, 2017 à 8:59 #1224036

cedricB-11

Bonjour,

Je viens d'ajouter le code dans WPML > Languages > Language switcher options > CSS additionnal mais le résultat est toujours identique.

Merci d'avance.

mars 7, 2017 à 9:19 #1224060

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/