Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 13 réponses, has 3 participants.

Last updated by Andrés il y a 3 mois et 3 semaines.

Assigned support staff: Andrés.

Auteur Messages
juin 21, 2019 à 4:22 #4068315

Fabrice

Je tente de : Activer le plugin WPML sur un WordPress Multisite

URL de (mon) site Internet où le problème apparaît : local

Je m'attendais à voir : Plugin activé

À la place, j'ai obtenu :

L’extension n’a pas pu être activée, car elle a déclenché une erreur fatale.
( ! ) Fatal error: Uncaught Error: Call to undefined function WPML\Container\alias() in /Users/thierry/Documents/RS/CLIENTS/EN-COURS/edeis/edeis-1906-corpo/www/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 171
( ! ) Error: Call to undefined function WPML\Container\alias() in /Users/thierry/Documents/RS/CLIENTS/EN-COURS/edeis/edeis-1906-corpo/www/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 171
Call Stack
# Time Memory Function Location
1 0.0001 416096 {main}( ) .../plugins.php:0
2 0.7950 17166376 plugin_sandbox_scrape( ) .../plugins.php:175
3 0.7951 17167904 include( '/Users/thierry/Documents/RS/CLIENTS/EN-COURS/edeis/edeis-1906-corpo/www/wp-content/plugins/sitepress-multilingual-cms/sitepress.php' ) .../plugin.php:2141

juin 21, 2019 à 4:58 #4068625

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Pourriez vous détailler la procédure que vous avez suivi? Avez vous essayer d'activer WPML sur le réseau ou sur un site ? Sur quel site vous avez essayé d'activer WPML?

Pourriez vous aussi décrire votre installation Multisite? Utilisez vous des sites sur des répertoires ou avec des sous domaines?

Merci,
Jamal
Assistance WPML

juin 24, 2019 à 7:35 #4075039

Fabrice

Bonjour, installation d'un WP neuf téléchargé sur leur site (5.2.2)
Activation du WP Multisite
Ajout du plugin WPML sur le site admin pour l'activer sur le réseau, et là erreur ci-dessus.
J'ai tenté avec seulement le thème nineteen et aucun autre plugin activé, même chose.
Je n'ai pas plus d'info que le retour d'erreur donné ci-dessus.

juin 24, 2019 à 9:23 #4075947

Fabrice

Précision, je suis en dev local sur ma machine.

juin 24, 2019 à 10:13 #4076287

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Comme Jamal n'est pas disponible, je voudrais prendre votre cas.

Pour l'instant, je n'arrive pas à reproduire votre cas, donc il semble lié à votre environnent.

1. Si vous essayez l'activation de WPML sur un site (pas un multisite) dans votre environnent, cela fonctionne correctement ?

2. Pour pouvoir vous aider plus rapidement, j’ai activé l’information de debug pour ce ticket. Merci de regarder ce lien pour savoir comment obtenir plus d’information de votre site et nous la fournir.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Cordialement,
Andrés

juin 24, 2019 à 10:17 #4076303

Fabrice

Seulement sur ce site, on utilise WPML régulièrement pour d'autres sites, mais c'est la première fois en multisite.
Je ne peux donner les infos de débogage car je ne peux pas activer WPML

juin 24, 2019 à 10:37 #4076533

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Pouvez-vous nous indiquer si votre version de PHP est supérieur au 5.6 ?
Si c'est le cas, pouvez-nous fournir un environnement où reproduire cette situation ?

juin 24, 2019 à 10:45 #4076633

Fabrice

Mac OS 10.14.5
Apache Version Apache/2.4.39 (Unix) OpenSSL/1.0.2s PHP/7.3.6
Apache API Version 20120211
PHP 7.3.6 (cli) (built: May 31 2019 23:38:25) ( NTS )
Mysql 8.0.15

Wordpress 5.2.2 FR

juin 24, 2019 à 10:46 #4076685

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci, pour pouvoir avancer, pouvez-nous fournir un environnement où reproduire cette situation ?

juin 24, 2019 à 10:51 #4076705

Fabrice

Je ne peux pas vous donner un accès à distance à ma machine 🙁

juin 24, 2019 à 11:00 #4076735

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je comprends bien mais je n'ai pas une manière de reproduire cette situation. Je vais consulter avec nos développeurs mais sans un site de test ou un environnent pour le reproduire je ne peux que vous recommander de créer un nouveau multisite et essayer d'installer votre WPML à nouveau. Vous pouvez aussi essayer de créer un site sur votre serveur et vérifier si le problème persiste.

Je reviens dès que j'ai des nouvelles.
Cordialement

juin 24, 2019 à 1:18 #4077443

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Sans un environnement où reproduire cette situation, nous pouvons pas vous aider. Pour cette raison je viens de créer un site de test dans notre serveur Cloudways.

Les instructions pour la migration se trouvent sur le message privé antérieur.

Cordialement

juin 24, 2019 à 3:45 #4078405

Fabrice

Après beaucoup de tests, si j'installe le WP avec PHP 7.1 tout fonctionne, même si je passe ensuite en php 7.3
Par contre si j'installe WP en PHP 7.3, j'ai l'erreur lorsque j'active WPML sur le réseau.
Pour le moment, je fais donc l'installation en PHP 7.1 pour pouvoir avancer.

juin 24, 2019 à 8:46 #4079737

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre feedback, Fabrice. Pour l'instant, je continue sans pouvoir reproduire cette situation.

N'hésitez pas de me tenir au courant dès que la migration a été finalisé

Cordialement