Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 12 réponses, has 2 participants.

Last updated by Jamal il y a 8 months et 3 weeks.

Assigned support staff: Jamal.

Auteur Messages
février 1, 2020 à 9:19 #5403645

carinev-2

Bonjour,
Après avoir traduit taxinomies et slugs (dans chambres/attributes du plugin gérant les locations vacances) j'ai les liens vers les localisations qui ne fonctionnent pas.
Par ex. hidden link devrait diriger vers une page avec toutes les locations vacances disponibles à Solenzara mais dirige vers une 404.
Sur mon site test (dev.corsicacasa.com) les réglages sont identiques et ça fonctionne.
Je n'ai pas d'erreur dans 'error logs' et tout est à jour.
J'utilise le theme Booklium avec Motopress Hotel Booking.
J'ai également un souci avec le paramétrage des medias : je ne peux pas cocher la case 'Définir les informations linguistiques pour le média existant' (voir fichier joint).
Pour le moment, je traduis seulement le theme et les extensions pour pouvoir mettre en ligne la version française. Je traduirai le contenu par le suite.
Je vous remercie par avance pour votre aide,
Bien cordialement,
Carine

février 1, 2020 à 11:38 #5403971

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Pourriez vous fournir les informations de débogage en suivant cet article.
https://wpml.org/fr/faq/comment-fournir-des-informations-de-debogage-pour-une-assistance-plus-rapide/

Pourriez vous sauvegarder les permaliens et vérifier si le lien retournera toujours une erreur 404?

Si cela ne vous aide pas, veuillez vérifier sur votre site de test si ce problème apparaît dans les cas suivants:
- Seuls les plugins WPML sont activés. Il nous dira s'il y a un problème d'interaction avec un autre plugin.
- Le thème est défini sur un paramètre par défaut de WordPress, tel que Twenty Fourteen. Il nous dira s'il y a un problème d'interaction avec votre thème.
- Si le problème disparaît, commencez par en activer un à la fois pour déterminer où l'incompatibilité est produite.

Pour le second point, l'option est désactivée, probablement, par ce que les images existantes ont déjà les informations linguistiques définis.

Cordialement,
Jamal

février 1, 2020 à 12:56 #5404195

carinev-2

Bonjour Jamal,
Merci pour la rapidité de votre intervention.
J'avais déjà réenregistré les permaliens, mais cela n'a rien changé.
Sur le site test (dev.corsicacasa.com) tout fonctionne et les plugins/theme sont les mêmes.
Par contre, quand j'active le theme générique (sur corsicacasa.fr), le lien fonctionne (sauf que je n'ai pas les annonces correspondantes du coup). Mais je n'arrive pas à comprendre pourquoi sur le site dev.corsicacasa le lien fonctionne aussi avec Booklium.
Je pense que j'ai loupé quelque chose au niveau du paramétrage sur corsicacasa.fr, mais je n'arrive pas à voir à quel endroit. J'ai déjà vérifié plusieurs fois.
Merci pour votre aide,
Bien cordialement,
Carine

février 1, 2020 à 1:44 #5404363

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Pourriez vous m'accorder un accès temporaire à votre site pour vérifier cela de plus prés, il se peut que je trouve quelque chose. J'ai activé l'espace privé pour partager les accès en toute sécurité. Veuillez faire une sauvegarde de base de données.

février 1, 2020 à 4:13 #5404797

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

J'ai activé le mode déboggage et désactiver toutes les extensions sauf la Réservation d'hotel, le lien hidden link

Pourriez vous me dire quelle page devrait retourner ce lien?

Si vous désactiver effectivement WPML, qu'est ce que ce lien afficherait?

Cela m'aiderait à comprendre mieux le problème et trouver rapidement une solution.

février 3, 2020 à 5:10 #5414725

carinev-2

Bonjour Jamal,
J'ai trouvé la solution, tout fonctionne bien maintenant.
J'ai tout recommencé depuis le début en ce qui concerne les "attibuts", et notamment les localisations.
Par contre, impossible de rectifier une traduction : j'ai ajouté par erreur un s à localisation au niveau du singulier et impossible de rechanger la traduction.
J'ai changé de langue pour essayer de le faire mais j'ai beau changer, le s revient toujours.
Pouvez-vous regarder si vous trouvez la solution et si oui m'expliquer la marche à suivre ?
Merci beaucoup pour votre aide,
Bien cordialement,
Carine

février 4, 2020 à 9:01 #5418625

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Carine,

Je vois 3 strings sur votre capture d'écran, de quelle string voudriez vous enlever le (s)? De toutes?
Sur le front, pourriez vous me dire ou vous voyez ce (s), dans les URLs ou sur les chaînes de la page?

Cordialement,
Jamal

février 4, 2020 à 9:17 #5418785

carinev-2

Bonjour Jamal,

Il s'agit du premier (avec singular) qui devrait-être au singulier.
Aucune idée ou se trouve le string au niveau des chaines de la page...:)
Merci !!

Cldt, Carine

février 4, 2020 à 9:37 #5418963

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Merci Carine,

Vous avez dit Par contre, impossible de rectifier une traduction : j'ai ajouté par erreur un s à localisation au niveau du singulier et impossible de rechanger la traduction.
Pourriez vous me dire ou vous avez ajouter le (s)? je veux dire sur quelle page vous aviez pu configurer le mot localisations?
J'avais cherché sur les options sans rien trouver, pourriez vous m'aider à voir ou?

Cordialement,
Jamal

février 4, 2020 à 9:50 #5419073

carinev-2

C'est dans taximonies > localisation (voir copie d'écran) : le singulier/pluriel n'est pas respecté et je n'arrive pas à le changer. Il doit y avoir un moyen tout simple mais lorsque j'essaye ça revient toujours comme c'est sur la copie d'écran 🙂

Merci !

février 4, 2020 à 2:19 #5422115

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Si j'ai bien compris, vous voulez que l'adresse suivante fonctionne sans le (s):
- Actuellement: hidden link
- Attendu: hidden link

Corrigez moi si je me trompe.

Il faut changer la traduction du slug sur WPML->Paramètres->Traduction de taxonomies. Voir capture attachée.
Pour le changer pour l'anglais, il faudrait que trouve au niveau du code comment le slug est enregistré pour cette taxonomy. J'aurais besoin de prendre une copie du plugin ou de votre site pour pouvoir faire une recherche sur tous les fichiers en masse.

J'ai corrigé le slug pour le français, maintenant est accessible sur hidden link

Je reste à votre disposition.

février 4, 2020 à 3:22 #5422637

carinev-2

Merci beaucoup Jamal ! Et merci pour votre patience ! Demain matin je dois changer le ndd corsicacasa.fr par corsicacasa.com. Je vous ferai signe quand tout sera en ordre afin que vous puissiez faire les copies qu'il vous faudra. Bien cordialement, Carine

février 4, 2020 à 4:25 #5423269

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Avec grand plaisir!
Pour le moment, me mettrais le ticket en attente de votre retour, il devrait rester ouvert pour 3 semaines.

Le sujet ‘[Fermé] Lien qui ne fonctionne pas après traduction des taximonies/slugs’ est fermé à de nouvelles réponses.