Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Le problème : J'ai créé un système de filtrage pour filtrer mes CPT selon certains critères. Tout fonctionne bien en français (le français est la langue par défaut de mon site), en revanche, en anglais, après le filtrage, les informations remontent en français.

La solution: - Allez à WPML > Langues > Filtrage de langues pour les opérations AJAX - Cochez l'option à continuation : x Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Marqué : 

This topic contains 2 réponses, has 2 participants.

Last updated by yann-andreK Il y a 10 mois.

Assigned support staff: Andrés.

Auteur Messages
février 5, 2021 à 4:21 #8018869

yann-andreK

Bonjour,

Je vous contacte pour un problème auquel je fais face sur mon site web. En effet, sur certaines pages, j'ai créé un système de filtrage pour filtrer mes CPT selon certains critères. Tout fonctionne bien en français (le français est la langue par défaut de mon site), en revanche, en anglais, après le filtrage, les informations remontent en français. (exemple : hidden link )La plupart sont des pages créés dans un thème enfant, et la requête a été faite à la main. Pourtant, le problème est la même sur cette page : hidden link
Cette page a été faite en utilisant JetEngine et JetSmartFilters combinés à Elementor.

Pourriez-vous m'aider svp ?

Yann

février 8, 2021 à 7:11 #8028735

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Yann,

Bienvenue à l'assistance technique de WPML.

Il semble que votre système de filtrage utilise du Ajax pour télécharger vos articles, pouvez-vous activer l'ajustement à continuation :
- Allez à WPML > Langues > Filtrage de langues pour les opérations AJAX
- Cochez l'option à continuation :
x Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX

Cordialement,
Andrés

février 8, 2021 à 8:50 #8029295

yann-andreK

Bonjour Andrés,

Merci beaucoup ! Finalement c'était tout simple, mais en tout cas cela a fonctionné !
C'est parfait !