Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 6.20 hours from now. Thank you for your understanding.

This topic contains 10 réponses, has 2 participants.

Last updated by Andrés il y a 2 ans et 3 mois.

Assigned support staff: Andrés.

Auteur Messages
juillet 12, 2017 à 12:22 #1317725

constantinS-4

Quand je traduit les pages sur mon site, j'ecrit la traduction a droite, et ensuite je coche les cases de traduction, mais quand je click sur terminée, la page se charge à l'infinie, et je doit la quitter. Sur wordpress mes pages ne sont pas cochée sauvegardée, mais en réalité ils sont, et la traduction est faite. Ca m’embête que je doit quitter les pages a chaque fois, et que je les vois pas traduite sur wordpress. En plus quand j'effectue la traduction, a gauche (langue principale) ne s'affiche pas la dernière version.

hidden link

juillet 12, 2017 à 1:27 #1317815

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je comprend bien votre sentiment, surtout si vous avez déjà traduit vos contenus. On va regarder s'il existe une erreur ou une incompatibilité :

1. Pouvez-vous vérifier s'il existe une erreur dans la console de votre navigateur quand vous cliquer sur le bouton "enregistrer et fermer" ?

2. Est- ce que vous pouvez vérifier si cette situation arrive quand:
- Toutes les extensions qui n'appartient pas à WPML sont désactivés. Cela va nous dire s’il y a un problème d’interaction avec un autre plugin.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement,
Andrés

juillet 12, 2017 à 1:52 #1317845

constantinS-4

Je ne peut pas faire ça. Mon site est on, il y a du trafic, et je ne sait pas travailler en stage. (duplication de site).

juillet 12, 2017 à 3:03 #1317939

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Je comprends bien votre situation, mais je vous suggère la création d'un site de test, c'est toujours la meilleure manière de faire des mises à jour. Vous pouvez aussi implémenter un système de backup automatique.

1. En retournant à votre problème, avez-vous regarder votre console de votre navigateur comment indiqué antérieurement ?

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

Cordialement,
Andrés

juillet 16, 2017 à 11:25 #1320295

constantinS-4

Je vient de regarder la console, pas d'erreur, ni quand je sauvegarde, ni avant. C'est juste marquée que JmQmigrate est instalée.
J'ai tout fait pour le debug, voici le lien: https://pastebin.com/GQT9uhCz
Petit info hors poste, mais je vient de voir aussi que dans les attributions de certains produits, je ne voit pas l’intégralité des attributions, certains ne s'affichent pas. J'ai eu ce souci quand il y a eu la grosse mise a jour de woocommerce, mais tout allez bien depuis.

juillet 17, 2017 à 10:30 #1320660

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de votre feedback. D'après votre information de débogage, ils existent plusieurs erreurs en provenant de votre extension Redsys WooCommerce, donc il peut s'agir d'un problème de compatibilité avec cette extension.

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

juillet 17, 2017 à 5:12 #1321166

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Comme malheureusement vous n'avez pas ajouté vos identifiants FTP, j'ai du créer une copie de votre site.

J'ai installé l'extension Duplicator mais il n'a pas fonctionné dans votre environnement. Puis, j'ai installé l'extension All in one WP Migration.

Pour l'instant je vois qu'il existe une erreur :

[17-Jul-2017 16:32:24 UTC] PHP Fatal error:  Uncaught exception 'WC_Data_Exception' with message 'Adresse de messagerie non valide' in xxx/woocommerce/includes/abstracts/abstract-wc-data.php:698
Stack trace:

Cela semble associé exclusivement à WooCommerce et une fois on désactive cette extension tout fonctionne correctement. Je suis en train de consulter cette situation et je reviens dès que j'ai des nouvelles car il semble que ce problème est associé à WooCommerce et pas à WPML.

Est-ce que si vous désactivez temporairement WooCommerce, pouvez-vous finir la traduction de vos pages ?

juillet 17, 2017 à 5:28 #1321175

constantinS-4

Il m'est impossible de desactiver Woocommerce, puisque je vais perdre de l'argent, ma boutique est en ligne. Le bussines prime sur la traduction. Je peut faire les traductions, mais il ne me les montre pas dans wordpress, même si ils s'affichent dans le site.

juillet 17, 2017 à 5:34 #1321179

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Comme je ne peux pas vérifier le comportement expérimenté en local et vous n'avez pas un site de test cela va prendre plus de temps de débogage.

Je reviens dès que j'ai des nouvelles.

juillet 18, 2017 à 8:30 #1321628

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

J'ai créé un site de tests dans notre serveur auquel vous pouvez accéder en ajoutant la ligne suivant dans votre fichier host et avec vos identifiants :
74.50.54.120 lidiacrochettricot.andres.host
Vous êtes bienvenue à tout modifier et effectuer vos tests.

Ici, j'ai pu réduire le problème à l'extension WooCommerce Product Bundles, une fois elle désactivez tout fonctionne normalement.

Cette situation a déjà été identifié et transmis à nos développeurs. Pour l'instant comme solution temporaire vous pouvez utiliser l'éditeur native de WordPress à la place. Vous pouvez l'activer depuis:

- WPML > Gestion de traduction > Configuration du contenu multilingue
- Comment traduire les publications et les pages
x Créer des travaux de traductions manuellement

Documentation:
https://wpml.org/fr/documentation-6/traduire-vos-contenus/utiliser-la-gestion-de-traduction-de-wpml/

août 17, 2017 à 11:41 #1345217

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Je viens d'avoir un feedback de nos développeurs et ce problème devrait d'être résolu avec la dernière version de WooCommerce Multilingual.

Pouvez-vous faire un backup de votre site et faire la mise à jour de cette extension ? Est-ce que cela résout votre problème ?

Cordialement,
Andrés