Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Le problème : La mise à jour en FR se fait mais pas dans les autres langues. Une erreur de Cross-origin apparait dans l'inspecteur d'élément.

La solution: - Activez l'ajustement CORS dans votre serveur. - Vérifiez vos ajustements W3TC et ses limitations au niveau d’écriture .htaccess.

Mots-clés : 

This topic contains 8 réponses, has 2 participants.

Last updated by vincentH-17 il y a 6 jours et 6 heures.

Assigned support staff: Andrés.

Auteur Messages
octobre 8, 2019 à 1:02 #4715675

vincentH-17

Je tente de : Mettre à jour mes posts dans les versions étrangères

URL de (mon) site Internet où le problème apparaît : Le site est multi domaine (un domaine par langue) :
FR : hidden link
DE : hidden link
EN : hidden link
ES : hidden link
NL : hidden link

La mise à jour en FR se fait mais pas dans les autres langues. Une erreur de Cross-origin apparait dans l'inspecteur d'élément.

Je précise que je suis sous la dernière version de WordPress (Gutenberg) et que mes plugins WPML sont à jours.

octobre 8, 2019 à 1:21 #4715783

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Cette erreur est lié au CORS, pouvez-vous l'activer depuis votre serveur ?
hidden link

Je vous recommande aussi de vérifier vos ajustements W3TC et ses limitations au niveau d’écriture .htaccess.

Cordialement,
Andrés

octobre 9, 2019 à 8:52 #4720867

vincentH-17

Bonjour Andrès,
J'ai déjà ajouté cette ligne à mon fichier .htaccess :
Header set Access-Control-Allow-Origin "*"

J'avoue ne pas comprendre pourquoi le CORS me bloque.

octobre 9, 2019 à 1:33 #4723415

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Je viens de visiter votre site et l'erreur est disparu. Pouvez-vous mettre à jour vos contenus ?

Si ce n'est pas le cas, dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML est activé. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparaît, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

octobre 9, 2019 à 2:51 #4723877

vincentH-17

L'erreur n'intervient que sur l'administration. Pas sur le site en lui même.

Je ne peux pas mettre à jour mes posts dans les langues étrangères ET avec l'éditeur Gutenberg. J'ai un type de post "articles" avec l'éditeur classique et j'arrive à mettre à jour mon contenu.

J'ai essayé beaucoup de solution via htaccess afin de définir un Access-Control-Allow-Origin mais rien n'y fait.

Je vais essayer de désactiver des extensions dès demain. Notamment le plugin de cache.

octobre 9, 2019 à 2:58 #4723891

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait, j'attends vos résultats.

octobre 10, 2019 à 1:04 #4730619

vincentH-17

Bonjour Andrés,
Le problème venait de mon plugin de cache.

Le problème est maintenant résolu.

octobre 10, 2019 à 1:14 #4730795

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Super ! 🙂
N'hésitez pas à fermer ce ticket et en ouvrir un nouveau si vous avez besoin de plus d'assistance.

Cordialement

octobre 11, 2019 à 2:13 #4739495

vincentH-17

My issue is resolved now. Thank you!