Passer au contenu Passer à la barre latérale

Ce sujet est résolu. Voici une description du problème et de la solution.

Problème :
Le client rencontre une erreur 500 lors de la modification du contenu de son site en allemand. Après avoir désactivé tous les plugins, il a identifié que le plugin SureRank était la cause du problème. Une mise à jour récente de SureRank semble avoir résolu le problème.
Solution :
Nous avons suggéré de poursuivre le débogage en vérifiant les configurations du serveur et en désactivant temporairement tous les plugins à l'exception de WPML et Divi pour éliminer tout conflit avec des plugins tiers. Voici les configurations serveur recommandées :

memory_limit = 512M<br />max_execution_time = 300<br />max_input_time = 300<br />max_input_vars = 10000<br />post_max_size = 128M<br />upload_max_filesize = 128M

Si le problème persiste ou si cette solution ne s'applique pas à votre cas, nous vous recommandons de vérifier les problèmes connus, de confirmer que vous avez installé les dernières versions des thèmes et plugins, et d'ouvrir un nouveau ticket de support ici.

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

Ce sujet contient 9 réponses, a 1 voix.

Dernière mise à jour par ludovicdind Il y a 4 mois et 1 semaine.

Assisté par: Ilyes.

Auteur Messages
Avril 16, 2026 à 7:49 am #17972970

ludovicdind

Bonjour, lorsque je veux modifier le contenu de ce site en allemand, j'ai cette erreur 500 qui arrive. Donc impossible de modifier le contenu dans une langue secondaire. Le support de Divi 5 et le support du serveur ne pensent pas que le problème vient de chez eux, donc je pose cette question ici au support WPML pour savoir s'il y a quelque chose à faire du côté du plugin pour résoudre ce bug.

Avril 16, 2026 à 9:00 am #17973422

ludovicdind

Suite à l'erreur, j'ai ce petit message de WPML (voir image) qui apparaît et lorsque je clique sur corriger, tout passe en vert mais ça ne règle pas le bug.

CleanShot 2026-04-16 at 10.58.26@2x.png
Avril 16, 2026 à 10:25 pm #17975518

Ilyes
Supporter

Les langues: Anglais (English ) Français (Français ) Arabe (العربية )

Fuseau horaire: Pacific/Easter (GMT-06:00)

Bonjour,

Cette traduction a-t-elle été créée à l'aide de l'éditeur WPML ou via la traduction automatique ? Si c'est le cas, vous ne devriez pas pouvoir la modifier à l'aide de votre constructeur de site. Lorsque vous créez une traduction avec l'ATE (éditeur avancé) ou via la traduction automatique, les éléments sont liés les uns aux autres ; les modifier ultérieurement via l'éditeur Divi rompt ce lien et pourrait entraîner des problèmes et la perte de votre traduction.

À moins que vous n'ayez créé les traductions manuellement à l'aide de divi 5, auquel cas il pourrait y avoir un véritable conflit si vous obtenez des erreurs.

Sinon, rendez-vous dans WPML > Assistance (support) et vérifiez si une configuration est signalée en rouge ou s'il y a un message d'erreur.

Avril 17, 2026 à 4:12 pm #17977245

ludovicdind

Bonjour,
Je vous confirme avoir créé ces traductions manuellement avec l'éditeur WordPress. Sur Divi 4, je fonctionne exactement de la même manière et je n'ai jamais eu ces erreurs. C'est pour ça que je soupçonne un conflit entre WPML et Divi 5.

CleanShot 2026-04-17 at 18.06.49@2x.png
Avril 17, 2026 à 7:47 pm #17977524

Ilyes
Supporter

Bonjour,

J'aimerais vous demander un accès temporaire au wp-admin et au FTP de votre site de test, ce qui me permettra de trouver ces informations pour vous,

Merci de me fournir les étapes à suivre pour reproduire le problème.

Il est important de noter que vous devez sauvegarder votre site et votre base de données avant de procéder, et vous pouvez utiliser un plugin comme Duplicator à cette fin. Voici un lien vers ce plugin : http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire ci-dessous, n'entrez pas vos informations d'identification, car elles seront exposées publiquement :

lien caché

Pour des raisons de confidentialité et de sécurité, veillez à ce que votre réponse soit privée.

Avril 20, 2026 à 10:55 pm #17982245

Ilyes
Supporter

Bonjour,

Pourriez-vous réessayer maintenant ? J'ai appliqué une correction dans le dossier wp-content/mu-plugin ; c'est une solution qui a fonctionné pour un autre client qui avait le même problème.

J'ai essayé de modifier la page d'accueil en allemand et elle s'est enregistrée sans problème.

Si le problème persiste, merci de me décrire les étapes exactes permettant de le reproduire,

Faites-moi savoir si cela a fonctionné,

Avril 21, 2026 à 2:19 pm #17984619

ludovicdind

Bonjour,
J'ai essayé, mais j'ai toujours le même problème. J'ai aussi modifié les limites PHP, mais ça ne résout pas le problème.

J'ai fait une vidéo du problème. Vous trouverez la vidéo sur le FTP dans le dossier uploads > 2026.

Avril 22, 2026 à 4:14 pm #17988496

Ilyes
Supporter

Bonjour,

J'ai pu accéder au serveur FTP, mais l'interface d'administration de WordPress n'est actuellement pas accessible (tout le site, en fait), et j'obtiens l'erreur suivante :

Erreur fatale : la taille de mémoire autorisée de 134217728 octets est épuisée (tentative d'allocation de 10485760 octets) dans /home/clients/65feadab2ca165c26ae6614313f2e570/sites/vistonia.ch/ wp-content/themes/Divi/includes/builder/functions.php à la ligne 10459

Erreur fatale : la taille de mémoire autorisée de 134217728 octets est épuisée (tentative d'allocation de 10485760 octets) dans /home/clients/65feadab2ca165c26ae6614313f2e570/sites/vistonia.ch/ wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-non-persistent-cache.php à la ligne 13

Il semble que la mémoire de votre site soit épuisée, probablement à cause d'un bug qui s'est coincé dans une boucle.

Avez-vous une idée de ce qui a pu causer cela ? Est-ce lié à ce problème avec Divi 5 ?

J'aimerais beaucoup avoir accès à l'espace d'administration, ce qui me permettrait de faire une copie de votre site et de déboguer le problème localement sans affecter votre site en ligne.

Avril 23, 2026 à 11:16 am #17990021

ludovicdind

Bonjour,
Petit problème côté serveur. C'est réparé et vous devriez avoir accès maintenant à l'admin.

Avril 25, 2026 à 12:50 am #17994108

Ilyes
Supporter

Bonjour,

Après avoir poursuivi le débogage, le problème ne se reproduit pas sur le site local, comme vous pouvez le constater ici : lien caché

Et sur le site en production, l'erreur ne se produit pas systématiquement ; parfois, l'enregistrement fonctionne, ce n'est donc pas un problème récurrent.

De plus, aucune erreur de débogage n'est enregistrée sur votre serveur.

J'ai également pu constater que le site renvoyait une erreur 500, ce qui est généralement lié à des problèmes de ressources ou à une erreur de boucle,

Tout cela me porte à croire qu'un plugin tiers est en cause, principalement lié au cache ou au pare-feu (ce qui explique pourquoi Divi 5 fonctionne correctement en local)

Voici ce que nous devons tester ensuite :

1- Demandez à votre hébergeur de vérifier que les valeurs sont suffisamment élevées, au minimum :

memory_limit = 512M
max_execution_time = 300
max_input_time = 300
max_input_vars = 10000
post_max_size = 128M
upload_max_filesize = 128M

2- Pourriez-vous désactiver temporairement tous les plugins à l'exception de WPML et DIVI, puis refaire le test ? Je souhaite éliminer tout conflit éventuel avec des plugins tiers.

Je peux effectuer ces modifications pour vous, mais vous devez d'abord sauvegarder votre site et me le confirmer.

Faites-moi savoir si je peux procéder à votre place.

Avril 27, 2026 à 3:36 pm #17997576

ludovicdind

Bonjour,
J'ai désactivé tous les plugins et j'en suis arrivé à la conclusion que SureRank était la cause du problème. Il y a eu une nouvelle mise à jour aujourd'hui du plugin SureRank qui semble avoir réglé ce bug. Je n'ai pas réussi à reproduire le bug depuis cette mise à jour donc je peux dire que le problème est résolu.
Un grand merci pour votre aide !