Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Mots-clés : 

This topic contains 17 réponses, has 2 participants.

Last updated by melissaK-2 il y a 2 mois et 2 semaines.

Assigned support staff: Andreas W..

Auteur Messages
juillet 1, 2019 à 3:25 #4120807

melissaK-2

Tell us what you are trying to do?

My translated page have a different template depending on the language.
The initial template is like reduced in the translated version

As you can see on the picture it is the original template reduced with margins which I cannot edit with elementor. It's like if it's more compact that before.

What can I do to have the original template integrated within the translated version?

juillet 1, 2019 à 4:17 #4121129

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please increase your PHP Memory Limit to 512M and the WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 128M
WP Memory Limit 128M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

The PHP Memory Limit will need to be changed inside of the php.ini file or by using the .htaccess-file.
hidden link

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000 or higher.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.3.5.

In case of any doubt please contact your hosting provides and ask for assistance.

If this will not solve the issue proceed as followed:

Please disable any additional plugin that is not related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results.

Kind regards
Andreas

juillet 2, 2019 à 9:15 #4125255

melissaK-2

Hello,

I have changed everything you told me but it's still not working.

My translated template is remaining the same

best regards

MK

juillet 2, 2019 à 4:40 #4128801

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

juillet 3, 2019 à 3:53 #4138043

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just connected to your site and I can not seen any differencies inside the layout of the translated pages.

hidden link

and

hidden link

Could it be that the issue has been solved?

Kind regards
Andreas

juillet 5, 2019 à 3:59 #4152641

melissaK-2

The problem is solved for the about page but remains with the translated categories such as:
hidden link
hidden link
hidden link and
hidden link

it should have this template:
hidden link

but it's not applying. Why?

Thank you for your help.

Melissa Kerr

juillet 5, 2019 à 4:14 #4152791

melissaK-2

Also:
the translation of my categories in store in french work. But not the main name.
-STORE- should become -BOUTIQUE- as I did mention in the translation but does not apply.
Same thing with the label "product categories" should become "catégories de produits" but isn't being translated in the french version, as well as the category "boucle d'oreilles" under the single product are written as "boucle d&#039" instead of "boucle d'oreille". I think there is a bug with the product categories template and store template in french version.

Also I have noticed a big "SEARCH" on top of the search bar which wasn't there before I started using WPML plugin. How can I remove it?

juillet 5, 2019 à 9:42 #4154015

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have been working on your site. It seems all the issues are solved now.

Go to Elementor -> Templates -> WooCommerce Builder. Here zou translate the category page templates. In some cases here the checkboxes for duplicating the MEdia Attachments was not marked inside of the language settings in the right sidebar.
This is why the images did not appear in the translated French pages.

The categories can be translated at WPML -> Taxonomy Translation. The french product category for earrings has been changed into "Boucles d´oreille" as using a single quote caused an issue.

I hope this is a suitable solution for you?

Further, at WPML -> Taxonomy Translation such attributes and categories can be snychronized, and I completed all available tasks.

More options you can find at WooCommerce -> WooCommerce Multilingual -> Status. Click here the option "troubleshooting" in the right corner and run the options once you realize that store content is not synced properly.

The string "Search" belong sto Widget titles and such text, as also text in headers, footers and theme and plugin options are need to be translated with String Translation. See screenshot.

Let me know if you need any further assistance.

Kind regards
Andreas

juillet 5, 2019 à 9:46 #4154039

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

*STATUS UPDATE*

juillet 6, 2019 à 9:14 #4155443

melissaK-2

Thank you so much for your help. You have solved a few of my problems 🙂

I can see now that the translated version has the right template, I managed to apply it to the submenus in french and to the link buttons on the first page. However if I go to the french version of my store, -STORE- still doesnt translate to french and once I click on the product categories on the woocommerce sidebar, the wrong template applies again to all categories. Or if I am on the english version of e.g "earrings" and then click to french, it also turns to the wrong template. I dont know why? I tried to remove the product categories widget and insert it again, still doesnt work.

Thank you for you help,

Best regards,

Melissa Kerr

juillet 6, 2019 à 9:25 #4155481

melissaK-2

One last thing for the big "search" on top of the search bar, I don't want it translated I want it removed how can I do that? It didnt appear before I used WPML.

I am talking about the big SEARCH / RECHERCHE in black not in red.

Thank you very much

Best regards,

Melissa Kerr

juillet 6, 2019 à 10:01 #4155589

melissaK-2

Sorry, I have realized there is another problem with the translated categories template.

In the english version everything is right, but then if I click on the submenu e.g "colliers" category, all the products are displayed within the category and not only the Necklaces. It seems like the french version doesnt detect which products have to go where, it doesnt make the difference between categories and they all appear everywhere. What can I do? 🙁

Thank you for your help!

Best regards,

Melissa Kerr

juillet 6, 2019 à 10:28 #4156453

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

About the WooCommerce Builder Tempaltes. Do I understand right, that these templates are based on the plugin DT WooCommerce Page Builder For Elementor?

Please install the currenlty used theme and the plugin(s) necessary to recreate the issue onto the following test site:

One Click Login: hidden link

Leave me a short notification once the components are installed and I will proceed with further testing. Possibly this issue will need to be escalated to our compatibility team.

The Search title is part of any WordPress Search Widget. You should be able to edit the title at Appearance -> Widgets. Simply delete it in order to not show any title on Fornt-end.

The issue about product not appearing correctly on the template categorz page might be realted to plugin compatibility. I will take it in consideration while testing the theme and plugins.

Kind regards
Andreas

juillet 7, 2019 à 10:26 #4157573

melissaK-2

Hello,

I have installed my plugins and theme 🙂
Yes I use the page builder DT woocommerce, I think it is compatible with WPML but it might encouter a few bugs for applying translated templates. Do you think we will be able to fix it?

Thank you so much for your help!

Best regards,

Melissa Kerr

juillet 8, 2019 à 4:52 #4164419

Andreas W.
Supporter

Languages: Anglais (English ) Espagnol (Español ) Allemand (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In fact when going to hidden link I can see that the products apepar mixed up.

I am not sure why it behaves like that but anyway, if you use the menu all products appear ordered and this issue should not affect any customers.

As I am not familiar with the DT WooCOmmerce Page Builder I would kindly like to ask to recreate the prudct category template for further testing or provide detailed steps in order to recreate the issue.

You can access the site here:

hidden link

Kind regards
Andreas