Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Our next available supporter will start replying to tickets in about 3.58 hours from now. Thank you for your understanding.

This topic contains 7 réponses, has 2 participants.

Last updated by Andrés il y a 4 months.

Assigned support staff: Andrés.

Auteur Messages
mai 21, 2020 à 12:17 #6186343

carl-philippeN

Hi there,

I changed my langue page configuration for Different languages in directories, it used to be set as Language name added as a parameters. Once I changed, all my pages where not indexable. Its a big problem because I lost all my organic traffic!

I tried to understand what caused the problem and it's seems caused by a cannonical error.
Here's the error from my SEO tool : We have found a Canonical Meta Tag, but it points to a different URL. This means that this page will not be indexable.
in response header: Not Set
In Meta Tags: hidden link

I read everything on canonical and tried every solution that I found on your forum but I wasn't able to fix the problem.

Can you check my website and help me with this?
As mentionned it's very urgent because most of my pages are not indexable anymore.

Thank you

mai 21, 2020 à 2:41 #6187517

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

WPML n'ajoute pas des balises Canonical donc je ne pense pas que cette situation est associé à notre extension.

Par contre, il peut s'agir que la redirection selon la langue du navigateur peut affecter votre indexation chez Google. Dans le lien à continuation vous pouvez trouver une information beaucoup plus détaillé sur cette situation :
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

Pouvez-vous aller à WPML > Langues > Redirection selon la langue du navigateur et la désactiver ?
Puis, allez chez Google Webmaster et faites un crawl de vos site. Depuis quelques jours, Google devrait l'avoir corrigé.

Cordialement,
Andrés

mai 21, 2020 à 3:20 #6187851

carl-philippeN

Bonjour Andrés,
Merci pour votre retour!
Avant de vous contacter, j'avais pris le temps de bien lire sur le sujet et j'avais déjà essayé de désactiver la langue du navitageur. Malheureusement cette technique n'a pas maché.
Suite à votre commentaire, j'ai désactivé YOAST qui était susceptible de générer des balises canonical, mais j'ai toujours le même problème d'indexaction, il n'a rien qui est indexé!!
D'avance, merci pour votre aide.

mai 21, 2020 à 3:31 #6187987

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

D'après votre information de débogage, la redirection est toujours activé dont je vous recommande de la désactiver à nouveau, indexer votre site et attendre quelques jours.

En tout cas, je viens de visiter votre site à nouveau et les balies hreflang sont bien installés. Par contre, la balise canonical est toujours là et je vous répète que WPML n'ajouter pas cette étiquettes, donc je vous recommande d'investiguer votre installation.

Cordialement

mai 21, 2020 à 3:44 #6188037

carl-philippeN

Bonjour Andrés,
Vous me demmandez d'investiguer mon installation?
Si jen suis ici c'est que j'ai tout essayé et que j'ai besoin de votre aide et non pas me faire dire de revérifier mon installer.

Tout d'abord, j'ai déjà essayé il y a quelques jours de changer la redirection, voilà pourquoi je l'ai remis activé. Je peux vous assurer que cela n'est pas le problème.

Initialement, j'ai configuré le site en utilisation l'option : Language name added as a parameter (hidden link - Anglais)

C'est lorsque j'ai changé pour l'option suivante que les problèmes ce sont mis a découler : Different languages in directories ((hidden link - Français, hidden link - Anglais))

C'est comme si il a encore un lien avec les anciennes URLs (?lang=en) et les nouvelles /en, ce qui explique le lien canonical.

Bref, pouvez-vous investiguer de votre côté?

mai 22, 2020 à 9:40 #6193789

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je comprends votre sentiment mais ces changements au niveau de redirection et format d'URL prennent du temps à se mettre à jour. Je vous recommande d'attendre quelques jours et, surtout, de ne pas remettre la redirection.

Je viens de vérifier à nouveau et les balises hreflang sont correctement installés et, je répète, les balises canonical ne font pas partie de WPML.

Or, j'ai aussi visité l'URL et comme attendu, il affiche une erreur 404 :
hidden link

Vous pouvez aussi ajouter de redirections pour vos anciens liens du format ?lang=en, surtout si votre ancien site a été fortement indexé dans le passé.

Cordialement

mai 22, 2020 à 4:28 #6197131

carl-philippeN

Bonjour Andrés,
J'ai enlevé la redirection et également enlever YOAST. Après une journée, tout est rentré en ordre et les pages étaients bien indexées. Par contre, aussitôt que j'ai remis YOAST, mon problème est revenu comme avant et l'ensemble de mes pages n'est plus indexé.
Bref, il semble avoir un conflit entre Yoast et WPML.
Avez-vous une idée de la cause?
Merci!

mai 25, 2020 à 7:44 #6207583

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Dans ce moment vous avez un autre ticket dans le forum anglais. Pouvez-vous fermer un parmi les deux et continuer avec l'autre.

Cordialement