Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 12 réponses, has 3 participants.

Last updated by Patrick il y a 6 ans et 1 mois.

Assigned support staff: Riccardo Strobbia.

Auteur Messages
novembre 17, 2013 à 7:26 #293530

Patrick

Bonjour,

J'obtiens une page 404 lorsque j'accède la page produit de mon site WordPress / WPML / Woocommerce.
Le problème survient lorsque je change la langue de base de traduction des strings du thème : hidden link pour anglais.

J'ai installé un thème anglais sur mon wordpress et je voudrais traduire les différentes strings. Le select étant sur français, mais le thème en anglais je n'ai pas l'option de traduire en français et j'ai des messages d'avertissement. hidden link

Est-ce que vous avez une idée de la cause du problème?
les plugins sont tous à jour hidden link

Merci

Patrick

novembre 17, 2013 à 9:53 #293564

Harshad

Dear Patrick,

As its weekend, our French supporters are not available, I will further assist you in English.

Can you please try this:
go to wordpress admin -> wpml -> support, Click on the troubleshooting link at the bottom of the page.

On troubleshooting page
1) Click "Remove ghost entries from translations table" button.
2) Click "General clean up" button.
3) Click "Set language information" button.

Also try to resave your permalinks from Settings -> permalinks.

novembre 18, 2013 à 4:36 #293728

Patrick

Hi Harshad,

I did all you asked and I'm still getting 404 on product pages.

Thank you

Patrick

novembre 18, 2013 à 6:16 #293741

Harshad

Dear Patrick,

I have enabled private details box, which will ask you for ftp and wordpress admin details, Please fill in the information which will help me to further investigate on your issue(s).

décembre 2, 2013 à 4:38 #300534

Patrick

Here you go

décembre 2, 2013 à 4:44 #300537

Patrick

You will need to change the language setting and browse the product page to see the problem.

hidden link

I also get an error on the brand pages Catchable fatal error: Object of class WP_Error could not be converted to string in /server/path/sitename/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 8316

décembre 2, 2013 à 8:25 #301095

Riccardo Strobbia

Cher Patrick,

il semble que vous avez un problème pour afficher "product-categoryt" slug et vous manquez d'une traduction pour elle.

S'il vous plaît, essayons de définir ce en anglais et en enregistrer de nouveau la structure de permalien.

Ensuite, essayez de faire une traduction de la catégorie de produit limace et voir ce qui se passe.

Merci, meilleurs salutations
Riccard

décembre 3, 2013 à 3:59 #301197

Patrick

english? your french is hard to understand

décembre 3, 2013 à 9:53 #301365

Riccardo Strobbia

Dear Patrick,

it seems to me you have a problem with the 'product-category' slug - it is defined in Woocommerce permalink settings as the product category base "product-" in english language - and that you are missing a translation for it.

I would try to change the string language to english, make a translation in french for the base slug - e.g. "produit-" - and save the permalink structure again to refresh it.

Can you make a try and tell me what happens?

décembre 3, 2013 à 9:53 #301366

Riccardo Strobbia

Dear Patrick,

it seems to me you have a problem with the 'product-category' slug - it is defined in Woocommerce permalink settings as the product category base "product-" in english language - and that you are missing a translation for it.

I would try to change the string language to english, make a translation in french for the base slug - e.g. "produit-" - and save the permalink structure again to refresh it.

Can you make a try and tell me what happens?

décembre 3, 2013 à 11:58 #301471

Patrick

Hello Riccardo,

I tryed what you suggested and it's still giving me 404

In the mean tim I made a video to explain the exact problem :

hidden link

The theme is in english but the site think it's in french so it's offering to translate in english something that is already in english. I would need to set translation option (the language in which the strings are written in) to english to be able to fill the french translation of the theme correctly. But I get a 404 on my product page.

décembre 3, 2013 à 12:19 #301483

Riccardo Strobbia

Cher Patrick,

the string language "must" be set to english.

I see that the permalinks are working with:

hidden link
hidden link

but the button to access categories in your slider is set to:

hidden link
hidden link

I attached a screen showing the settings you want to change to achieve what you're looking for.

You should set those records accordingly or change the link to which the category button is pointing otherwise it will never work - in fact the url is broken in both languages.

I think it is not specific WPML issue rather than a Woocommerce permalink settings issue.

I also noticed you have a problem in the category in the right sidebar for english.

Please try to set your permalinks to work properly in the main language and then translate the slug accordingly if needed.

Thanks, best regards
Riccardo

décembre 4, 2013 à 12:49 #302246

Patrick

Hi, I'm not sure if you changed something on my side I haven't.. But it's working now

I changed the links on the slides.

Thank you