Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 10 réponses, has 2 participants.

Last updated by maxenceS il y a 1 mois.

Assigned support staff: Andrés.

Auteur Messages
septembre 18, 2019 à 11:14 #4600139

maxenceS

Je tente de : Installer WPML

URL de (mon) site Internet où le problème apparaît : http://gotoski.snowskut.com/wp-admin/admin.php?wpml-ls-refresh-on-browser-back-button=no&languages_order%5B%5D=en&languages_order%5B%5D=fr&link_empty=0&copy_parameters=&additional_css=&migrated=0&statics%5Bfooter%5D%5Btemplate%5D=wpml-legacy-horizontal-list&statics%5Bfooter%5D%5Bdisplay_flags%5D=1&statics%5Bfooter%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bfooter%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bfooter%5D%5Bdisplay_link_for_current_lang%5D=1&wpml-ls-static-footer-colorpicker-preset=&statics%5Bfooter%5D%5Bbackground_normal%5D=&statics%5Bfooter%5D%5Bborder_normal%5D=&statics%5Bfooter%5D%5Bfont_current_normal%5D=%23444444&statics%5Bfooter%5D%5Bfont_current_hover%5D=%23000000&statics%5Bfooter%5D%5Bbackground_current_normal%5D=%23ffffff&statics%5Bfooter%5D%5Bbackground_current_hover%5D=%23eeeeee&statics%5Bfooter%5D%5Bfont_other_normal%5D=%23444444&statics%5Bfooter%5D%5Bfont_other_hover%5D=%23000000&statics%5Bfooter%5D%5Bbackground_other_normal%5D=%23ffffff&statics%5Bfooter%5D%5Bbackground_other_hover%5D=%23eeeeee&statics%5Bpost_translations%5D%5Btemplate%5D=wpml-legacy-post-translations&statics%5Bpost_translations%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bpost_translations%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bpost_translations%5D%5Bdisplay_before_content%5D=1&statics%5Bpost_translations%5D%5Bavailability_text%5D=This+post+is+also+available+in%3A+%25s&statics%5Bshortcode_actions%5D%5Btemplate%5D=wpml-legacy-horizontal-list&statics%5Bshortcode_actions%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bshortcode_actions%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bshortcode_actions%5D%5Bdisplay_link_for_current_lang%5D=1&wpml-ls-in-shortcode-actions-colorpicker-preset=&statics%5Bshortcode_actions%5D%5Bbackground_normal%5D=&statics%5Bshortcode_actions%5D%5Bborder_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_current_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_current_hover%5D=&statics%5Bshortcode_actions%5D%5Bbackground_current_normal%5D=&statics%5Bshortcode_actions%5D%5Bbackground_current_hover%5D=&statics%5Bshortcode_actions%5D%5Bfont_other_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_other_hover%5D=&statics%5Bshortcode_actions%5D%5Bbackground_other_normal%5D=&statics%5Bshortcode_actions%5D%5Bbackground_other_hover%5D=&_icl_nonce_gts2=c7562da218&_wp_http_referer=%2Fwp-admin%2Fadmin.php%3Fpage%3Dsitepress-multilingual-cms%2Fmenu%2Flanguages.php&submit_setup_wizard=0

Je m'attendais à voir : La suite de l'installation

À la place, j'ai obtenu : Une page blanche sans message d'erreur

septembre 19, 2019 à 8:48 #4602715

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

1. Allez à :
- WPML > Assistance technique.
- Dépannage.
- Réinitialiser.
x Réinitialiser et désactiver WPML
- Redémarrer la procédure d'installation.
Est-ce que cette fois vous pouvez finir l'installation de WPML ?

2. Si cette procédure ne fonctionne pas, il serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).
https://wpml.org/documentation/support/debugging-wpml/

Cordialement,
Andrés

septembre 19, 2019 à 8:56 #4602759

maxenceS

Hi,

Reset change nothing.

Here is the logs : https://pastebin.com/i1wZDmRz

But it seems that there is nothing linked to WPML problem in it.

Thank you

septembre 19, 2019 à 2:06 #4605871

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour, s'il vous plaît, essayez le suivant :
- Désactivez tous vos autres plugins et ne laissez pas que WPML.
- Activez un thème par défaut de WordPress.
- Essayez à réinitialiser votre WPML.

Est-ce que cette fois il fonctionne ?

septembre 19, 2019 à 2:13 #4605997

maxenceS

Il semble que ça venait de mon thème puisque le changement sur un thème natif à WordPress a permis la poursuite de l'installation. J'ai terminé celle-ci puis réactivé mon thème, ça devrait fonctionner maintenant étant donné que l'installation a pu être terminée avant ?

septembre 19, 2019 à 2:21 #4606167

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait !

Cela dépend si l'erreur vient de votre thème parent Pasadena ou de votre thème enfant de tu genre d'erreur.

Je vous recommande de garder l'information de dépuration activé et réactiver le thème.

Cordialement

septembre 20, 2019 à 2:31 #4613015

maxenceS

Le problème semble bien venir de mon thème enfant, quand j'active le thème parent tout fonctionne. Comment je peux régler ce problème ? Quelle est l'origine ?

septembre 20, 2019 à 2:35 #4613019

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Je vous recommande d'activer votre information de débogage pour afficher l'erreur :
https://wpml.org/fr/forums/topic/page-blanche-installation-passage-detape-3-a-4/

Aussi, vous pouvez commencer à commenter/effacer ligne par ligne du code à mesure de votre thème enfant jusqu'à trouver la partie que vous pose problème.

Cordialement

septembre 20, 2019 à 2:37 #4613025

maxenceS

Il semblerai que ça vienne de l'ajout d'un fichier JS effectué dans le thème enfant, je vais entourer son ajout par une condition s'assurant que nous ne sommes pas sur l'administration, merci pour votre rapidité de réponse.

septembre 20, 2019 à 2:42 #4613033

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Super ! 🙂
N'hésitez à fermer ce ticket et en ouvrir un nouveau si vous avez besoin d'assistance.
Je vous souhaite un bon weekend!

septembre 20, 2019 à 2:44 #4613035

maxenceS

My issue is resolved now. Thank you!