Sauter la navigation

Ce sujet est résolu. Voici une description du problème et de la solution.

Problem:
The client is experiencing a 404 error when trying to access password-protected pages on their WordPress site using WPML.

Solution:
We attempted to reproduce the issue on a test site without success, indicating that the problem is not due to WordPress password protection and WPML compatibility. We then:
1. Deactivated all plugins related to Simple membership without success.
2. Deactivated Locotranslate to check for a conflict with translation plugins.
3. Switched the theme to WP 2019, which resolved the error.
Upon inspecting the client's parent theme's functions.php file, we found a custom function named wpb_password_post_filter at line 472. Commenting out this function resolved the 404 error. This function is not part of WordPress or WPML, so we advised the client to either remove or modify it and to contact the theme's author for further assistance.

Please note that this solution might be irrelevant if it's outdated or not applicable to your case. If you're still facing issues, we highly recommend checking related known issues at https://wpml.org/known-issues/, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. If the problem persists, please open a new support ticket with us.

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

Marqué : 

Ce sujet contient 4 réponses, a 2 voix.

Dernière mise à jour par Nicolas Viallet Il y a 1 mois et 3 semaines.

Assisté par: Nicolas Viallet.

Auteur Articles
février 21, 2024 à 10:20 am #15326843

maximeM-18

Dites-nous ce que vous essayez de faire.
J'ai intégré la solution wpml sur mon site wordpress en production help.openbee.com, j'ai le français par default et l'anglais. J'ai choisi d'utilisé les urls comme dossiers c'est à dire même les urls de la langue par default commencent par /fr/,
Je découvre que les pages protégées par mot de passe retournent une erreur 404.
En décochant, depuis les paramètres WPML l'option "Autoriser la connexion et les pages d’inscription" tout le site n'est plus accessible et retourne une erreur 500. Alors j'ai remis l'option et le .htacess pour le remettre en marche.
J'héberge chez O2swith, je pense que le serveur est sur NGINX. Je n'ai pas encore demandé à l'hébergeur d'ajouter les rules indiquées dans la documentation. Je ne compte pas traduire les pages d'authentification et inscription.
Pouvez-vous m'aider à résoudre l'accès aux pages protégées par mot de passe sans avoir recours à traduire les pages d'inscription et authentification ni changer les rules du serveur s'il vous plait?
j'attire votre attention que je préfère régler d'abord ce problème sur la meme installation en préprod sur lien caché

Suivez-vous une documentation quelconque ?
J'ai suivi ce ticket pour essayer de résoudre le problème, mais ce dernier persiste :
https://wpml.org/forums/topic/issue-in-a-password-protected-page/

Y a-t-il un exemple similaire que nous pouvons examiner ?
Cette page de test est protégée par mot de passe et retourne une erreur 404.
le mot de passe est : wpml
lien vers la page : lien caché

Quel est le lien vers votre site ?
lien caché

Je suis à votre disposition pour toute autre information ou accès au site web.

février 21, 2024 à 3:48 pm #15329246

Nicolas Viallet
Supporter

Les langues: Anglais (English ) Français (Français )

Fuseau horaire: America/Lima (GMT-05:00)

Bonjour,

Merci d'avoir contacté le support de WPML. Je ne pense pas que vous ayez la même configuration que le ticket mentionné. Il s'agissait d'un champ ACF alors que sur votre site je pense que vous utilisez un plugin dédié "Simple membership plugin" ou l'option de WordPress par défaut.

Pourriez vous me dire comment vous protégé cette page? Est-ce que c'est l'option par défaut de WP ou ce plugin?
S'il s'agit du plugin, pourriez vous me dire comment vous configurez cette option (une capture d'écran peut aider à comprendre). Est-ce que c'est un champ lorsque vous éditez la page ou est-ce que c'est dans les paramètres du plugin?

février 22, 2024 à 8:43 am #15331788

maximeM-18

Bonjour,

Oui j'utilise "Simple membership plugin" en général pour la gestion d'accès à plusieurs pages depuis la même page concernée. J'ai en même temps d'autres pages qui ne sont pas protégées par "Simple membership plugin" (voir capture 1) mais protégés par mot de passe avec le système WordPress (voir capture 2) et ces pages là qui retournent une erreur 404 au lieu d'afficher le champs d'insertion du mot de passe. Lorsque j'enlève la protection par mot de passe et je les rends publiques, elle s'affichent bien.
Cette protection par mot de passe, avec l'existance du "Simple membership plugin" fonctionne comme il faut avant mise en place de WPML.
J'ai désactivé "Simple membership plugin" pour voir si le souci est bien lié à ce plugin, même souci.

J'ai un préprod pour des Tests, je peux vous envoyer un accès admin pour voir si besoin.
Je reste à votre disposition pour de plus amples informations.

Elyes Z.

capture-02.jpg
capture-01.jpg
février 22, 2024 à 12:25 pm #15333466

Nicolas Viallet
Supporter

Les langues: Anglais (English ) Français (Français )

Fuseau horaire: America/Lima (GMT-05:00)

Bonjour,

Merci pour ces tests et clarification. Je veux bien un accès pour regarder cela de plus près.

J'ai activé un champ privé pour votre prochaine réponse où vous pourrez partager ces informations de manière confidentielle avec notre support. Ne partagez pas votre propre compte admin, créez un nouveau compte que vous pourrez éliminer une fois l'assistance terminée.

IMPORTANT: Avant de continuer, faites un backup complet de votre site et base de données.

février 22, 2024 à 9:14 pm #15335619

Nicolas Viallet
Supporter

Les langues: Anglais (English ) Français (Français )

Fuseau horaire: America/Lima (GMT-05:00)

Bonjour,

- Après avoir constaté le problème j'ai essayé de le reproduire sur un site test sans succès donc le problème n'est pas dû à WordPress password et WPML.
- J'ai ensuite désactivé tous les plugins de Simple membership sans succès
- Puis Locotranslate pour voir si c'était un conflit entres plugins de traduction
- Enfin j'ai changé votre thème pour le thème de WP 2019 et l'erreur à disparue

En inspectant le code de votre thème parent j'ai trouvé dans le fichier functions.php ligne 472 une fonction 'wpb_password_post_filter'

Si je commente cette fonction je n'ai plus l'erreur 404.

Il s'agit d'une fonction personnalisée qui ne fait partie ni de WP ni de WPML, je vous laisse donc voir si vous devez la supprimer ou la modifier pour que le site fonctionne correctement. Je vous conseille de contacter l'auteur de ce thème pour reporter ce problème.

screenshot-2024.02.22-16_06_44.png
février 23, 2024 à 1:22 pm #15337908

maximeM-18

En effet cette fonction ajoutée ilya quelques jours seulement pour cacher les pages protégées par mot de passe dans les résultats de recherche.

Je confirme que c'est résolu.
Merci pour votre réactivité.

Elyes Z.

maximeM-18 a confirmé que le problème avait été résolu sur 2024-02-23 13:22:22.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.