This thread is resolved. Here is a description of the problem and solution.

Le problème : Quand j'essaie d'accéder à mon blog en anglais, je tombe sur une erreur 404.

La solution: - Allez à Yoast premium settings > Redirections. - Effacez vos redirections.

Documentation: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Mots-clés : 

This topic contains 10 réponses, has 2 participants.

Last updated by Andrés il y a 2 ans et 9 mois.

Assigned support staff: Andrés.

Auteur Messages
juin 27, 2017 à 8:25 #1307024

Josee Lamarre

I am trying to:
see my translation from my blog page in german into my blog page in english
URL of (my) website where problem appears: hidden link
I expected to see:
my blog page post at this working properly
Instead, I got: error

Steps to duplicate the issue:

juin 28, 2017 à 6:35 #1307155

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Josee,

Bienvenue à nouveau.

En visitant votre Blog en anglais, je vois que l'URL que affiche est hidden link à la place de hidden link

1. Pouvez-vous vérifier qu'il ne s'agit pas d'une redirection en provenant de l'extension Redirection ?

2. Pouvez-vous vérifier que l'élément du menu et sa traduction pointent correctement vers
hidden link?

Cordialement,
Andrés

juin 28, 2017 à 6:46 #1307162

Josee Lamarre

Bonjour Andrés,

J'ai fais la vérification et il n'y a pas de redirection dans ce cas. Par contre j'ai trouvé la dite page dans Redirections 404. Je viens de tenter une redirection par la suite vers la bonne adresse. Mais aucun changement sur ma page. Voir screen shot:

juin 28, 2017 à 7:55 #1307229

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Quand un survole le lien du menu Blog, on peut voir comme l'URL point vers hidden link. Cependant au moment de cliquer, on est redirigé immédiatement vers hidden link.
Je vous recommande vérifier encore une fois vos redirections hidden link.

Dans le cas contraire, après avoir effectué un backup :
Est- ce que vous pouvez vérifier si cette situation arrive quand:
- Toutes les extensions qui n'appartient pas à WPML sont désactivés. Cela va nous dire s’il y a un problème d’interaction avec un autre plugin.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement,
Andrés

juin 28, 2017 à 8:17 #1307256

Josee Lamarre

J'ai vérifier les rédirections et comme au début tout est ok.
Intéressant de voir que quand je désactive les extensions maintenant il n'apparait plus d'erreur mais maintenant une page vide et comme url hidden link. Ce nom d'url était la page de mon ancien blog.
C'est en réactivant l'extension Yoast que le problème revient à l'url hidden link et ensuite en la réactivant le problème reste.

juin 28, 2017 à 8:29 #1307265

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de ces informations. L'extension Yoast SEO Premium offre aussi une section de redirections. Pouvez-vous vérifier ces ajustements ?

Cordialement,
Andrés

juin 28, 2017 à 9:20 #1307324

Josee Lamarre

Dans les redirections de toast j'ai trouver ceci (voir screenshot) mais je ne sais pas trop ce que je dois changer...

juin 28, 2017 à 10:37 #1307413

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

juin 28, 2017 à 12:30 #1307524

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos identifiants. Je viens d'effacer vos redirections comme indiqué antérieurement et tout fonctionne correctement.

Cordialement,
Andrés

juin 28, 2017 à 12:34 #1307528

Josee Lamarre

Merci beaucoup Andrés, vous m'AVEZ AIDÉ énormément!

Bonne journée

juin 28, 2017 à 12:53 #1307542

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Parfait ! 🙂
Je vous souhaite une belle journée,
Andrés