Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Marqué : 

This topic contains 8 réponses, has 2 participants.

Last updated by Max Kovalenkov il y a 4 weeks et 1 day.

Assigned support staff: Max Kovalenkov.

Auteur Messages
septembre 17, 2020 à 9:05 #7034207

Claudiu Sirbu

Bonjour,

J'ai ajouté une nouvelle page en passant par le menu WP > Page > et en cliquant que le crayon d'édition de la page correspondante à la langue souhaitée. Ayant fait la même manipulation que pour toutes nos autres pages, je ne devine pas la raison de cette situation.

Après traduction à 100% depuis l'editeur WPML, la page reste en français.
Je pensais avoir trouvé la réponse à mon problème ici https://wpml.org/fr/forums/topic/the-translated-page-does-not-appear/, mais après édition du XML j'ai toujours le problème.

Ceci ne fonctionne donc pas (et que j'ai laissé en place pour le moment).
<wpml-config>
<gutenberg-blocks>
<gutenberg-block type="core/html" translate="1">
<xpath>/*</xpath>
</gutenberg-block>
</gutenberg-blocks>
</wpml-config>

La page FR est :
hidden link

La page RO est celle qui pose problème
hidden link
(seul un champ a bien pris en compte la traduction)

J'ai activer le "Assistance Installer". Je sais pas si je dois faire plus pour vous permettre l'accès.

septembre 17, 2020 à 7:53 #7040379

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-04:00)

Bonjour,

L'extension WRC Pricing Tables Ultimate n'est pas dans notre liste de compatibilité:

https://wpml.org/documentation/plugins-compatibility/

Cela n'implique pas forcément qu'elle n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.

Pourriez-vous contacter l'auteur de l'extension pour savoir s'il est compatible avec le WPML?

Je crains que le bloc wpml-config ne soit pas utile dans ce cas. Vous pouvez l'enlever en toute sécurité.

septembre 17, 2020 à 9:33 #7040653

Claudiu Sirbu

Bonjour Max,

Oui oui bien entendu ! pas de problème avec le plugin, je n'attends pas qu'il soit reconnu par WPML.
Il s'ajoute avec un "short code" et je sais que je dois le faire séparément (en dehors de WPML (comme je l'ai déjà fais sur la page EN)). Oublions la table de prix.

Le reste de la page hidden link a été traduit à 100% avec l'éditeur WPML et pourtant les informations ne remontent pas (à part 1 bloc)

Si en revanche vous indiquez que cela génère un blocage (ce qui me surprendrait puisque je n'ai pas rencontré le problème avec les autres langues) je ne comprends pas ce que vous sous entendez par "enlever le bloc wpml-config en tout sécurité".

Mon problème reste malheureusement entier.

septembre 18, 2020 à 9:18 #7048745

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-04:00)

Bonjour,

Merci pour les informations!

Afin de mieux cerner le problème, je vais avoir besoin d'accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.

Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

Important:Avant de procéder, assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site! Vous pouvez utiliser une extension comme All-in-One WP Migration:
hidden link

Si vous ne voyez pas ce formulaire, ne publiez pas vos identifiants car cette information sera publique.

Sécurité au moment de fournir l'information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

septembre 22, 2020 à 2:42 #7070801

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-04:00)

Bonjour,

Merci! J'ai cloné et renommée la page "Tarifs" (avec l'extension Yoast Duplicate Post), puis je l'ai publiée et elle fonctionne bien; les blocs package-string-XX ne sont pas là (traductions-dans-l-editeur.png). Je ne suis pas sûr de ce qui est arrivé à la page originale.

Comme solution de compromis, vous pouvez remplacer l'ancienne page par la nouvelle: finalisez la nouvelle page et toutes les traductions, après supprimez la page existante (et videz la corbeille), puis renommez la nouvelle page pour qu'elle porte le même nom, "Tarifs".

septembre 22, 2020 à 8:22 #7073285

Claudiu Sirbu

J'ai fais exactement ce que vous m'avez dit de faire.
J'avais peur que cela casse les associations entre les page et c'est précisément ce qui est arrivée.

Je m'explique, je n'ai plus de problème pour lequel je vous contactais, par contre lorsque je suis sur la page tarif (RO) et que je clique pour le changement de langue, je ne suis pas redirigé vers la bonne page associée à la langue désirée ... En fait si on considère que chaque page a un ID unique, c'est assez logique que la chaîne soit brisée !

Une solution, un compromis, mais je suis un peu plus perdu encore maintenant.
Et la lenteur de vos réponses est difficile à supporter.

Je pense que je vais mettre mon dernier backup et me contenter de mettre à jour depuis l'éditeur de page ...

septembre 22, 2020 à 8:47 #7073339

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-04:00)

Bonjour,

Dans votre message du 17 septembre, vous avez écrit:

> Le reste de la page /ro/preturi/ a été traduit à 100% avec l'éditeur WPML et pourtant les informations ne remontent pas (à part 1 bloc)

J'ai supposé que c'était votre problème: certaines chaînes traduites n'apparaissent pas sur le site. Je suis désolé si j'ai mal compris.

> lorsque je suis sur la page tarif (RO) et que je clique pour le changement de langue, je ne suis pas redirigé vers la bonne page associée à la langue désirée

Quand je suis sur cette page: hidden link

...si je clique sur le drapeau anglais, je suis redirigé vers cette page: hidden link

...si je clique sur le drapeau espagnol, je suis redirigé vers cette page: hidden link

...si je clique sur le drapeau français, je suis redirigé vers cette page: hidden link

Ça fonctionne bien. Veuillez me faire savoir si je ne suis pas au bon endroit.

septembre 22, 2020 à 9:45 #7073573

Claudiu Sirbu

Oui oui c'est normal que ela fonctionne : c'est parce que j'ai remis mon backup de l'heure précédente, et que j'ai fini par faire la traduction directement depuis l'éditeur du thème.

La manipulation que vous m'avez indiquée a permis d'avoir la page tarifs RO fonctionnelle mais à partir de là, je n'avais plus aucun drapeau en haut de la page ! le dispositif était raccordé à "tarif test" ... bref, nous ne pouvons pas nous permettre de perdre une semaine sur une si petite chose.

Nous avons donc opté pour la solution la plus simple et parfaitement fonctionnelle.
L'éditeur WPML fait perdre plus de temps qu'il n'en fait gagner au final (sans compter les confusions, ou les subtilités du thème graphique qui ne sont pas respectées.

Merci pour la double réponse de ce soir qui était plus rapide que l'attente de > 24/48h.
Si nous rencontrons d'autres problèmes, nous ne manquerons pas de venir solliciter votre aide.

Bien cordialement.

septembre 22, 2020 à 9:59 #7073581

Max Kovalenkov
Supporter

Languages: Anglais (English ) Français (Français ) Russe (Русский ) Portugais - du Brésil (Português )

Timezone: America/Toronto (GMT-04:00)

Merci pour cette mise à jour et encore une fois, désolé pour la confusion! Nous serons heureux de vous assister pour toute autre question.