Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 5 réponses, has 2 participants.

Last updated by Andrés il y a 4 ans et 1 mois.

Assigned support staff: Andrés.

Auteur Messages
juillet 17, 2015 à 12:19 #661516

thierryK-3

Bonjour,

nous avons remarqué que le paramètre

lang=xx

n'était pas bien placé dans les urls des pages "Custom post type".

voir picture.

Nous avon désactivé l'ensemble des plugins, celui qui semble posé probléme est le suivant : Custom Post Type Permalinks

Nous pouvons fournir un accès Admin à notre backoffice de preprod, ainsi qu'un accès FTP aux sources.

Merci d'avance,

Tk.

juillet 17, 2015 à 1:12 #661558

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Thierry,

Bienvenue au forum de WPML,

Comme vous vez déjà identifié le problem, je vais simuler cette comportement avec mon installation er je reviens vers vous vite.

Cordialement,
Andrés

juillet 17, 2015 à 2:56 #661630

thierryK-3

Super, merci.

Je reste à l'écoute.

Tk.

juillet 17, 2015 à 4:01 #661677

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

J'ai pu dupliquer cette situation et effectivement il existe un problème de compatibilité avec ce plugin.
Pour continuer avec le debug, est-ce que je peux vous demander l'objectif de l'utilisation de cette plugin?
Cela m'aidera à expliquer au equipe de compatibilité votre situation et trouver une solution si possible.

Je reste a l'attente a vos commentaires.
Andrés

juillet 17, 2015 à 4:08 #661681

thierryK-3

Notre site comporte un historique important, il a été construit avec ce plugin ( custom post type ), et les urls référencées sont composées de la catégorie et du slug.
Nous ne pouvons donc pas désactiver le module posant problème.

Pour ce qui est de l'option pour switcher de langue, nous sommes obligés d'utiliser le paramètre ?lang=xx , encore une fois à cause de l'historique du site. Les autre options ne sont pas utilisables pour nous.

Actuellement la seule manière de faire avec ce bug, est l'utilisation de quelques lignes dans un .htaccess qui déplace le paramètre en fin d'url ( redirection 301 ) . Mais ce n'est pas satisfaisant et durable.

Bonne fin de journée,
Tk.

juillet 17, 2015 à 5:36 #661726

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci pour les détails de contact que vous nous avez suministré et pour nous attirer l’attention sur ce sujet.
Je vais renvoyer les details a notre Equipe de Compatibilité des themes et plugins, et ils vont contacter l’author.

S’il vous plaît, ce processus peut prendre du temps car il depend aussi de la vitesse que l’author réponds à nos efforts pour lui contacter.

Il serait très important si vous essayez de contacter l’author de votre parte en lui demandant de nous répondre. Vous pouvez aussi lui demander de faire partie de notre programme Go Global, cela pourrait lui permettre de faire son plugin compatible avec WPML. https://wpml.org/documentation/theme-compatibility/go-global-program/. Cela pourrait aider à accélérer ce processus.

Nous allons fermer ce ticket mais nous allons le garder dans nos registres. Vous serez notified au moment que nous aurons la coopération de l’author dans ce processus.

Le sujet ‘[Fermé] Paramétre lang mal placé dans l'url ( Custom post type )’ est fermé à de nouvelles réponses.