Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Mots-clés : 

This topic contains 9 réponses, has 2 participants.

Last updated by philipped-14 il y a 2 semaines et 6 jours.

Assigned support staff: Andrés.

Auteur Messages
novembre 3, 2019 à 6:28 #4877413

philipped-14

Je tente de : starting a search on users

URL de (mon) site Internet où le problème apparaît : pit.mkpbe.org

Je m'attendais à voir : hidden link{user-name}

À la place, j'ai obtenu : hidden link{user-name}

novembre 4, 2019 à 2:14 #4881947

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Votre extension Ajax Search Pro n'est pas dans notre liste de compatibilité. Cela n'implique pas forcément qu'il n'est pas compatible mais que notre équipe n'a pas effectué les tests correspondants.
https://wpml.org/documentation/plugins-compatibility/

Il semble que votre cette extension utilise du Ajax pour télécharger vos articles, pouvez-vous activer l'ajustement à continuation :
- Allez à WPML > Langues > Filtrage de langues pour les opérations AJAX
- Cochez l'option à continuation :
x Stocker un cookie linguistique pour prendre en charge le filtrage de langue pour AJAX

Est-ce que cette fois il fonctionne ?

Cordialement,
Andrés

novembre 7, 2019 à 10:36 #4904907

philipped-14

Bonjour,
J'ai activé l'option comme indiqué. Cela semble fonctionner pour les résultats de type articles et groupes mais pas pour les liens vers un profil d'un user.
Bien à vous

novembre 7, 2019 à 10:54 #4905057

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter. Les accès FTP sont sur le menu Sandbox, si vous en avez besoin.
hidden link

Une fois vous êtes sur le Bureau du site, installez votre extension Ajax Search Pro et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe de compatibilité.

Note: vous n'avez qu'installer le extension nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Cordialement

novembre 11, 2019 à 4:16 #4926561

philipped-14

Bonjour

J'ai installé ajax search pro sur votre sandbox et testé le plugin: l'erreur est toujours présente: pas de problème quand la langue est celle par défaut du site (english) mais elle apparaît quand je change de langue: le "/" est doublé dans une autre langue que celle par défaut

test: home page (j'ai créé une page "ajax" et j'y ai mis un shortcode vers le plugin; je tape "test" comme mot de recherche et je trouve un groupe que j'ai créé: le plugin trouve le groupe "test" mais le lien vers le groupe est bon en english mais pas bon en french et spanish

novembre 11, 2019 à 4:51 #4926739

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci de votre aide. J'ai installé aussi notre BuddyPress Multilingual car vous ne l'avez pas installé. Je viens de mettre à jour tous nos extensions car pendant ces jours nous avons eu plusieurs change. Par contre, votre extension Ajax Search Pro n'est pas à jour.

Pouvez-vous installer une nouvelle version de cette extension ?

Cordialement

novembre 11, 2019 à 8:27 #4928033

philipped-14

j'ai mis à jour le plugin ajax

novembre 11, 2019 à 8:36 #4928101

philipped-14

bonjour,

en fait le problème n'est pas lié au plugin "ajax search pro" en particulier: j'ai le même problème en utilisant la fonction recherche (la loupe en haut à droite) de buddypress: le lien vers un profil d'un utilisateur est correct dans la langue par défaut du site (hidden link{username} mais dans une autre langue, cela ne fonctionne pas: le lien est erroné: j'ai hidden link{username} alors que je devrais avoir hidden link{username}

--> 2 erreurs dans la traduction du lien: un "/" de trop et utilisation du répertoire de la langue par défaut au lieu de sa traduction

novembre 12, 2019 à 9:35 #4930181

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Merci de votre aide mais je n'arrive pas à reproduire ce problem sans votre
Ajax Search Pro
. Lorsque j'ai saisi "test" et je n'ai aucun résultat.

Pouvez-vous m'indiquer les étapes à suivre ?

Cordialement

novembre 19, 2019 à 8:09 #4975619

philipped-14

Bonjour,

Vous avez essayé avec ma fonction "recherche" de buddypress? (la loupe en haut à droite de la page): et en effectuant une recherche voir le lien hypertexte généré dans une autre langue que la langue par défaut