Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 3 réponses, has 2 participants.

Last updated by Noman il y a 2 mois et 3 semaines.

Assigned support staff: Noman.

Auteur Messages
juillet 27, 2019 à 10:56 #4294197

jaumeA

Je tente de : Activer mon plugin CSM

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : Activated

À la place, j'ai obtenu :
Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/vhosts/skyfallxperience.net/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php on line 810

juillet 28, 2019 à 5:59 #4294873

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. I am going to answer this in English, I hope that is ok, if you still need help in French please let me know.

Could you please follow below steps and let me know how it goes?

1. Please take your full site backup.

2. Deactivate the existing WPML plugin.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder, NOT the database records.

4. Download the updated plugins from our servers (https://wpml.org/account/downloads/) and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

- We have another user who was able to solve the same issue like this (Summary at top):
https://wpml.org/forums/topic/site-down-parse-error-syntax-error/

Thank you

juillet 28, 2019 à 7:19 #4294925

jaumeA

Hi Norman and thanks for your message.
I deleted all WPML plugins OK, and downloaded again the files from the WPML website, then uploaded them again and still have the same message for WPML Multilingual CMS.
I can activate the other plugins -though they cannot run, the only that causes an issue is WPML Multilingual CMS
Attached the exisiting plugins installed.
Any suggestion?
Thanks

juillet 28, 2019 à 10:20 #4295391

Noman
Supporter

Languages: Anglais (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow below steps and let me know how it goes?

1. Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

2. Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

3. Also make sure you are using an updated version of the theme and plugins.

4. Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/
5. Please delete all sorts of caches on your site / server cache (if any) / plugin cache / CDN cache (if any), clear browser cache and see if this resolves your issue.

6. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

Le sujet ‘[Fermé] Plugin could not be activated because it triggered a fatal error.’ est fermé à de nouvelles réponses.