Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 6.60 hours from now. Thank you for your understanding.

Mots-clés : 

This topic contains 6 réponses, has 2 participants.

Last updated by Jamal il y a 6 mois et 1 semaine.

Assigned support staff: Jamal.

Auteur Messages
mars 18, 2019 à 6:31 #3372385

frederic

Hi, when I translate pages (build with Elementor) with the new WPML translation editor, everything seems to be fine, but nothing appears on front-end.

Even if the translation is complete, every checbox checked, the page won't load the translations on front-end.

I'm probably doing something wrong, but I can't see why.

Thanks,
Fred.

mars 19, 2019 à 8:21 #3376293

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

According to the debug informations, you are using Translation Management, please make sure that the page translation is not already taken by another translator. Once a translation is taken by a translator, no other translators can edit it until it is completed or resigned by the first Translator.

If the page is using a global Elementor template, this needs to be translated too. See this section of our article.
https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates

If this is not the case. Can you try to delete the translation and start over. Go to Pages->all pages, and click on the secondary language(english), delete the page and remove it completely from trash then try to translate it again.

I hope this helps. Let me know what you get, and feel free to use french if you would like.

Best regards,
Jamal
WPML Support

mars 19, 2019 à 9:13 #3376835

frederic

Bonjour Jamal,
merci pour votre aide.

J'ai effacé la traduction, vidé la corbeille, refait la traduction mais toujours rien.
Je n'ai pas d'autre plugin de traduction.

Est-il possible que ce soit un conflit avec "l'ancien WMPL" et le nouvel outil de traduction ?

Sur le screen joint : quand je passe à la version anglaise du site et que je clique sur une page voilà ce que j'ai

mars 20, 2019 à 6:01 #3392193

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci pour votre retour, et toutes nos excuses pour la réponse tardive.

La capture que vous avez attachée est une alerte que WPML affiche pour que vous choisissiez votre éditeur de traduction préféré. Cela est très utile dans le cas d'usage de "Page builders" tel que Elementor. Pour Elementor, la meilleure préféré est l'éditeur classique.
Pour certains page builders qui ne sont pas complètement intégré avec WPML, l'éditeur natif WordPress devient la meilleure option.

Pour revenir au problème que vous rencontrez, pourriez vous une page qui bogue et m'accorder un accès temporaire pour voir ce que je peux faire. J'ai activé l'espace privé pour partager les accès en toute sécurité. Veuillez faire une sauvegarde de votre site.

Cordialement,
Jamal

mars 29, 2019 à 3:36 #3492659

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Pourriez vous préciser quelle page est ouverte sur ATE ?
Je viens de tester avec la page Activités, en effet je constate le problème, même si je termine la traduction de la page sur l'éditeur classique, la page en front est toujours en français.
Mais je vois que 3 autres pages sont bien traduites.

Elementor est compatible avec WPML, Jupiter est aussi compatible avec WPML et nous avons même de la documentation en anglais.
https://wpml.org/documentation/plugins-compatibility/elementor/
https://wpml.org/documentation/theme-compatibility/how-to-create-multilingual-sites-using-jupiter-theme-and-wpml/

Je soupçonne qu'il y a probablement un conflit avec d'autres plugins notamment celui du cache WP Rocket. Et là aussi je suis confus, puisque WP Rocket est compatible avec WPML, il se peut qu'il y est autre chose. Je vous prie alors de faire les tests suivant:
- Test sur une nouvelle page.
Essayer avec une nouvelle page en ajoutant un minimum de block elementor.

- Test avec le minimum d'extensions.
1. Désactvier le maximum de plugin possible, ne garder que Elementor et les plugins WPML.
2. Créer une nouvelle page, puis traduire la page jusqu'a atteindre 100%.
Vérifier si l'erreur est toujours présente sur cette nouvelle page ou non?

Si l'erreur n'est pas présente alors c'est du à une autre extension. Réactivez les extensions 1-par-1 pour détecter celle qui pose ce problème.

Je reste à votre disposition.

Best regards,
Jamal

avril 12, 2019 à 11:39 #3598381

frederic

Bonjour Jamal, et merci. Les pages traduites l'ont été manuellement sous elementor. Je vais essayer de désactiver les plugins un par un pour voir. (pardon pour le délai de réponse j'ai d'autres projets en cours)

avril 12, 2019 à 2:15 #3599809

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Merci pour votre retour.

Ne vous excusez pas, nous somme à votre service. Je reste à votre disposition.

Jamal

Le sujet ‘[Fermé] Problem between elementor pro and translation editor’ est fermé à de nouvelles réponses.