Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur n'arrivait pas a utiliser les couleurs des attributs sur la page produit traduite. Solution: 1. Configurer les deux meta-terms "product_attribute_color" et "order_pa_couleurs" sur "Copier" sur WPML->Paramètres->Traduction des méta-termes personnalisés. 2. Réenregistrer les couleurs en utilisant la fonction de modification rapide pour forcer WPML à copier la couleur de l'attribut sur l'anglais.

This topic contains 4 réponses, has 2 participants.

Last updated by barbaraW-6 il y a 6 jours et 6 heures.

Assigned support staff: Jamal.

Auteur Messages
octobre 3, 2019 à 2:16 #4688589

barbaraW-6

Je tente de reproduire exactement le même affichage que sur les pages françaises d'origine. J'ai installé le plugin Variation Swatches pour les variations produits. Le plugin fonctionne parfaitement en Français. Voir la capture des paramètres de cet attribut Couleurs (tri personnalisé ; pas le nom, pas l'ID)

URL de (mon) site Internet où le problème apparaît : hidden link
hidden link

Je m'attendais à voir les images et couleurs dédiées aux variations s'afficher, et dans le même ordre que sur le site en Français.

À la place, j'ai obtenu : dans la traduction en Anglais, les titres des variations s'affichent correctement au survol, mais les images des couleurs ne s'affichent pas : toutes les images sont identiques : blanc encadré... et apparemment les titres des vignettes sont dans l'ordre des noms de couleurs, pas dans l'ordre indiqué par le tri personnalisé.

octobre 3, 2019 à 4:43 #4689887

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Je pense qu'il y a deux problème ici:
- Affichage des bonnes couleurs sur la langue secondaire.
- L'affichage des couleurs dans le bon ordre dans la langue secondaire.

Je pense que le premier problème pourrait être corrigé en synchronisant l'assignation des taxonomies couleurs pour les produits. Vous pouvez le faire sur WooCommerce ->WooCommerce Multilingual->Attributs.

Le deuxième problème peut être un conflit de compatibilité qu'on devrait reproduire sur une nouvelle installation pour le confirmer.

De toutes façons, j'aimerais pouvoir accéder à votre site et analyser ce problème de plus. Pourriez vous m'accorder un accès temporaire à votre site pour vérifier cela de plus prés. J'ai activé l'espace privé pour partager les accès en toute sécurité. Veuillez faire une sauvegarde de base de données.

Cordialement,
Jamal

octobre 9, 2019 à 3:07 #4723919

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,
Malheuresuement, je n'arrive pas à me connecter avec les accès fournies, je n'ai pas testé le FTP mais je ne pense pas qu'on en a besoin pour le moment.

Cordialement,
Jamal

octobre 10, 2019 à 10:04 #4729019

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Merci. J'ai pu me connecter et configurer le meta-term "product_attribute_color" et "order_pa_couleurs" sur "Copier" sur WPML->Paramètres->Traduction des méta-termes personnalisés, voir capture attachée(attribute-color.png).
Ensuite j'ai réenregistré les couleurs en utilisant la fonction de modification rapide(attribute-color-quick-edit.png) pour forcer WPML à copier la couleur de l'attribut sur l'anglais. Cela a corrigé le problème(product-colors.png).

Je reste à votre disposition.

Cordialement,
Jamal

octobre 10, 2019 à 1:06 #4730701

barbaraW-6

Problème résolu rapidement et efficacement grâce à un super conseiller!