Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 8 réponses, has 2 participants.

Last updated by Andrés il y a 1 month et 2 weeks.

Assigned support staff: Andrés.

Auteur Messages
juin 22, 2020 à 4:53 #6428535

ludovicA-2

Je tente de : faire fonctionner la redirection automatique de la langue du navigateur "Français canada" vers la page hidden link de mon site, lors de la première connexion (ou en navigation privée). La navigateur est google chrome, il est paramétré avec "français (Canada)" comme unique langue.

URL de (mon) site Internet où le problème apparaît :
hidden link
hidden link
hidden link

Je m'attendais à voir :
Une redirection vers la page d'accueil France (Canada) > hidden link

À la place, j'ai obtenu :
Une redirection vers la page d'accueil France (France) > hidden link

juin 23, 2020 à 6:04 #6431759

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

S'il vous plaît essayez le suivant :
- Faites une sauvegarde complete de votre site.
- Reemplacez le fichier \sitepress-multilingual-cms\dist\js\browser-redirect\app.js
hidden link
- Mettez les "paramètres régionaux par défaut" de votre langue problème en minuscule.

Est-ce que cette fois il fonctionne ?

Cordialement,
Andrés

juin 23, 2020 à 1:36 #6435381

ludovicA-2

Bonjour,

J'ai effectué les opérations demandées.

Cependant, cela ne fonctionne toujours pas depuis les pages suivantes :
- hidden link (= pas de redirection)
- hidden link (= redirection vers page FR)

Par contre, ça fonctionne maintenant depuis la page English hidden link (= redirige bien vers page Canada)

J'ai effectué plusieurs tests avec différentes configuration du navigateur, que j'ai synthétisé ici > hidden link

Merci pour votre aide,

juin 23, 2020 à 3:32 #6436435

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre aide. Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter.
hidden link

Une fois vous êtes sur le Bureau du site, ajoutez votre langue personnalisé et essayez de reproduire cette situation. Si l'erreur est reproduite, j'escaladerais le ticket à notre équipe.

Note: s'il vous plaît, n'installez pas une copie de votre site.

Cordialement

juin 23, 2020 à 4:17 #6436841

ludovicA-2

Bien reçu,

J'ai reproduit la configuration sur votre espace.
Je vous confirme que l'erreur est bien reproduite sur votre environnement.

Voici ce que j'obtiens avec google chrome lorsque la langue préférée du navigateur est "français (Canada)" :

hidden link
>> n'est pas redirigé

hidden link
>> redirige, mais vers la 2ème langue préférée du navigateur

hidden link
>> OK - redirige bien vers /ca-fr/

hidden link
>> OK - redirige bien vers /ca-fr/

juin 23, 2020 à 4:41 #6437033

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci beaucoup de votre aide. Or, je vois que la redirection plus important fonctionne correctement, cela du site principal :
hidden link

Je vais escalader votre ticket et je reviens dès que j'ai des nouvelles pour les autres cas de figure.

Cordialement

juin 24, 2020 à 11:26 #6443489

ludovicA-2

Bonjour,

Le point le plus important pour nous est la gestion du Canada "fr <-> ca-fr", et "en <-> ca-en" (qui seront des pages différentes, au look & feel différent). Le site sera en FR par défaut. J'ai modifié le réglage "langue du site par défaut" de votre espace de test pour bien correspondre à notre problématique, ce qui fait que désormais :

hidden link
>> n'est pas redirigé

hidden link
>> redirige vers la 2ème langue préférée du navigateur

Merci pour votre retour,

juin 24, 2020 à 11:33 #6443565

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci, je reviens dès que j'ai de nouvelles.
Cordialement

août 4, 2020 à 12:55 #6733645

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Juste pour vous informer que cette situation a été transféré à l'équipe des développeurs de WPML.
Cordialement