Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 0.79 hours from now. Thank you for your understanding.

This topic contains 5 réponses, has 2 participants.

Last updated by Jamal il y a 2 mois et 3 semaines.

Assigned support staff: Jamal.

Auteur Messages
juillet 16, 2019 à 9:48 #4224153

emmanuelS-7

Je tente de remplacer l'image FR (langue originale) par une image différente sur la version EN du site.
J'ai utilisé Media Translation pour créer le lien entre les deux images FR/EN.
L'image se trouve dans un module text Beaver Builder.

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir l'image EN sur la version EN, mais c'est toujours l'image FR qui est affichée.

J'ai cherché une solution sur le forum pendant plusieurs heures, ré-enregistré la page, refait la traduction, supprimé et intégré à nouveau l'image l'image dans la page FR, re-créé la liaison dans Media Translation… rien n'y fait.

Franchement, c'est pénible à la longue tous ces problèmes d'utilisation avec WPML 😉
Je pense n'avoir jamais ouvert autant de tickets avec un support de plugin en si peu de temps, un enchaînement de problèmes.

Cordialement
Emmanuel Soyer

juillet 17, 2019 à 9:25 #4228213

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Merci d'avoir contacter l'assistance WPML. Je serais heureux de pouvoir vous aider.

Serait il possible que ce problème provient d'une incompatibilité avec Beaver Builder, il se peut qu'une regression ait été introduite dans les dernières versions de Beaver Builder ou des extensions WPML. Peut être que c'est aussi une incompatibilité avec une autre extension.

Je propose que vous essayez la même image sur une nouvelle page qui soit créée juste par l'éditeur classique WP ou l'éditeur de block Gutenberg. Si l'erreur y est reproduit, on peut dire que Beaver n'a rien à voir dessus. Si l'erreur n'est pas reproduite je dirais que Beaver est impliqué.

Il serait aussi très interessant de tester cela dans une configuration minimale(Juste les extensions WPML et Beaver). Si l'erreur n'est pas reproduite dans ce cas là, réactivez les extensions une par une et vérifiez pour détecter la composante qui cause ce conflit de compatibilité.

Je reste à votre disposition.

Cordialement,
Jamal

juillet 18, 2019 à 10:41 #4237563

emmanuelS-7

Bonjour Jamal,

J'ai testé comme indiqué :

1 - Sur le site Chimie ParisTech

Créé une nouvelle page dans l'éditeur classique WP (au lieu de BB) et intégré l'image FR traduite par Media Translation (qui comporte une image différente pour l'EN) : lorsque je switch de FR à EN en frontend, c'est toujours l'image FR qui est affichée.
hidden link

La traduction media ne semble donc pas prise en charge sur ce site ou pour cette image en particulier (?)

2 - Sur un site WP sandbox mis à disposition par votre collègue Andrés pour un autre ticket de support (WPML / BB / Themer… installés)

Créé une nouvelle page et le reste idem point 1 plus haut : l'image EN change quand on va au FR (EN est la langue originale sur ce site, c'est inversé par rapport au site Chimie).
hidden link

Là, ça fonctionne.

3 - Sur ma copie locale du site Chimie ParisTech (pour ne pas perturber la version live du site)

Désactivé toutes les extensions sauf BB car bizarrement, le site ne fonctionne plus sans BB (message "Ce site rencontre des difficultés techniques.") : toujours pas de swap image au changement de langue.

A noter: il arrive que le swap image s'effectue avec une autre image testée, mais il est difficile de dire dans quel contexte avec certitude, je m'embrouille au bout d'un certain nombre de tests.

Je pense que je vais finir par changer directement l'image dans l'édition de la page traduite avec BB, j'y perdrai la liaison dynamique des images FR/EN mais ça devrait solutionner rapidement ce manque de fiabilité de Media translation avec BB sur ce site.

Cordialement

Emmanuel

juillet 19, 2019 à 9:20 #4245283

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Emmanuel,

Si vous désirez qu'on continue l'investigation sur ce problème, je peux créer un serveur de test sur notre plateforme et vous fournir les instructions pour y migrer votre site, et nous pourrons continuer nos investigations dessus sans impacter votre site en ligne.
Qu'en dites vous?

Cordialement,
Jamal

juillet 19, 2019 à 5:22 #4247621

emmanuelS-7

Bonjour Jamal,

Merci pour votre proposition, j'apprécie 😉
Ça m'intéresserait de prolonger les tests mais je manque de temps dans l'immédiat.
Pour l'instant, je remplace les images directement dans les pages traduites, il y en a peu sur le site donc ça va.

Peut-être pourrons-nous essayer sur un hébergement test plus tard ?

Cordialement
Emmanuel Soyer

juillet 22, 2019 à 8:57 #4255059

Jamal
Supporter

Languages: Anglais (English ) Français (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Emmanuel,

Je reste à votre disposition. Dites moi si vous voulez que je crée un serveur de test.

Best regards,
Jamal

Le sujet ‘[Fermé] Problème Media translation différents médias par langue’ est fermé à de nouvelles réponses.